aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/rubygem-opengl/Makefile27
-rw-r--r--graphics/rubygem-opengl/distinfo2
-rw-r--r--graphics/rubygem-opengl/pkg-descr4
4 files changed, 34 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index a0d4f8ad14c6..59039826abec 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -871,6 +871,7 @@
SUBDIR += rubygem-imagesize
SUBDIR += rubygem-image_science
SUBDIR += rubygem-objectdetect
+ SUBDIR += rubygem-opengl
SUBDIR += rubygem-railroad
SUBDIR += rubygem-scruffy
SUBDIR += rubygem-turing
diff --git a/graphics/rubygem-opengl/Makefile b/graphics/rubygem-opengl/Makefile
new file mode 100644
index 000000000000..1af8a32cd853
--- /dev/null
+++ b/graphics/rubygem-opengl/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: ruby-opengl
+# Date created: 2011-03-14
+# Whom: Steve Wills <steve@meatwad.mouf.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= opengl
+PORTVERSION= 0.60.1
+CATEGORIES= graphics ruby
+MASTER_SITES= RG
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= OpenGL/GLU/GLUT interface modules for Ruby
+
+RUN_DEPENDS= rubygem-mkrf>=0.2.3:${PORTSDIR}/devel/rubygem-mkrf
+
+USE_RUBY= yes
+USE_RAKE= yes
+GEM_NAME= ruby-${PORTNAME}-${PORTVERSION}
+USE_RUBYGEMS= yes
+USE_GL= glut
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/rubygem-opengl/distinfo b/graphics/rubygem-opengl/distinfo
new file mode 100644
index 000000000000..99c60356dc81
--- /dev/null
+++ b/graphics/rubygem-opengl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/ruby-opengl-0.60.1.gem) = aeeeac200acc0e7dad0f59dc47426ed7d3254c77f560cf3dfdecbdee5fa4ab7e
+SIZE (rubygem/ruby-opengl-0.60.1.gem) = 245248
diff --git a/graphics/rubygem-opengl/pkg-descr b/graphics/rubygem-opengl/pkg-descr
new file mode 100644
index 000000000000..47d63d747265
--- /dev/null
+++ b/graphics/rubygem-opengl/pkg-descr
@@ -0,0 +1,4 @@
+ruby-opengl consists of Ruby extension modules that are bindings for the
+OpenGL, GLU, and GLUT libraries.
+
+WWW: http://ruby-opengl.rubyforge.org/