aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/hpn-ssh/Makefile2
-rw-r--r--security/hpn-ssh/files/patch-buffer.c7
-rw-r--r--security/openssh-portable/Makefile2
-rw-r--r--security/openssh-portable/files/patch-buffer.c7
-rw-r--r--security/openssh/Makefile2
-rw-r--r--security/openssh/files/patch-buffer.c7
6 files changed, 15 insertions, 12 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index 11edb8aa95e1..1c7a0849d975 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openssh
PORTVERSION= 3.6.1p2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
ftp://carroll.cac.psu.edu/pub/OpenBSD/OpenSSH/portable/
diff --git a/security/hpn-ssh/files/patch-buffer.c b/security/hpn-ssh/files/patch-buffer.c
index 093e83c586a3..3bb0201df46a 100644
--- a/security/hpn-ssh/files/patch-buffer.c
+++ b/security/hpn-ssh/files/patch-buffer.c
@@ -43,7 +43,7 @@ diff -u -r1.16 -r1.18
buffer->offset = 0;
buffer->end = 0;
}
-@@ -34,8 +37,10 @@
+@@ -34,8 +37,11 @@
void
buffer_free(Buffer *buffer)
{
@@ -51,12 +51,13 @@ diff -u -r1.16 -r1.18
- xfree(buffer->buf);
+ if (buffer->alloc > 0) {
+ memset(buffer->buf, 0, buffer->alloc);
++ buffer->alloc = 0;
+ xfree(buffer->buf);
+ }
}
/*
-@@ -69,6 +74,7 @@
+@@ -69,6 +75,7 @@
void *
buffer_append_space(Buffer *buffer, u_int len)
{
@@ -64,7 +65,7 @@ diff -u -r1.16 -r1.18
void *p;
if (len > 0x100000)
-@@ -98,11 +104,13 @@
+@@ -98,11 +105,13 @@
goto restart;
}
/* Increase the size of the buffer and retry. */
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 11edb8aa95e1..1c7a0849d975 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openssh
PORTVERSION= 3.6.1p2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
ftp://carroll.cac.psu.edu/pub/OpenBSD/OpenSSH/portable/
diff --git a/security/openssh-portable/files/patch-buffer.c b/security/openssh-portable/files/patch-buffer.c
index 093e83c586a3..3bb0201df46a 100644
--- a/security/openssh-portable/files/patch-buffer.c
+++ b/security/openssh-portable/files/patch-buffer.c
@@ -43,7 +43,7 @@ diff -u -r1.16 -r1.18
buffer->offset = 0;
buffer->end = 0;
}
-@@ -34,8 +37,10 @@
+@@ -34,8 +37,11 @@
void
buffer_free(Buffer *buffer)
{
@@ -51,12 +51,13 @@ diff -u -r1.16 -r1.18
- xfree(buffer->buf);
+ if (buffer->alloc > 0) {
+ memset(buffer->buf, 0, buffer->alloc);
++ buffer->alloc = 0;
+ xfree(buffer->buf);
+ }
}
/*
-@@ -69,6 +74,7 @@
+@@ -69,6 +75,7 @@
void *
buffer_append_space(Buffer *buffer, u_int len)
{
@@ -64,7 +65,7 @@ diff -u -r1.16 -r1.18
void *p;
if (len > 0x100000)
-@@ -98,11 +104,13 @@
+@@ -98,11 +105,13 @@
goto restart;
}
/* Increase the size of the buffer and retry. */
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index e1bd9bfaec6d..ae7d3c5aa7d3 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openssh
PORTVERSION= 3.6.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/ \
ftp://ftp.usa.openbsd.org/pub/OpenBSD/OpenSSH/ \
diff --git a/security/openssh/files/patch-buffer.c b/security/openssh/files/patch-buffer.c
index 093e83c586a3..3bb0201df46a 100644
--- a/security/openssh/files/patch-buffer.c
+++ b/security/openssh/files/patch-buffer.c
@@ -43,7 +43,7 @@ diff -u -r1.16 -r1.18
buffer->offset = 0;
buffer->end = 0;
}
-@@ -34,8 +37,10 @@
+@@ -34,8 +37,11 @@
void
buffer_free(Buffer *buffer)
{
@@ -51,12 +51,13 @@ diff -u -r1.16 -r1.18
- xfree(buffer->buf);
+ if (buffer->alloc > 0) {
+ memset(buffer->buf, 0, buffer->alloc);
++ buffer->alloc = 0;
+ xfree(buffer->buf);
+ }
}
/*
-@@ -69,6 +74,7 @@
+@@ -69,6 +75,7 @@
void *
buffer_append_space(Buffer *buffer, u_int len)
{
@@ -64,7 +65,7 @@ diff -u -r1.16 -r1.18
void *p;
if (len > 0x100000)
-@@ -98,11 +104,13 @@
+@@ -98,11 +105,13 @@
goto restart;
}
/* Increase the size of the buffer and retry. */