aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/hs-statistics/Makefile89
-rw-r--r--math/hs-statistics/distinfo3
-rw-r--r--math/hs-statistics/pkg-descr17
-rw-r--r--math/hs-statistics/pkg-plist37
5 files changed, 147 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 4c1bf9eaee2d..5ff847b3faa0 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -118,6 +118,7 @@
SUBDIR += hs-erf
SUBDIR += hs-mwc-random
SUBDIR += hs-probability
+ SUBDIR += hs-statistics
SUBDIR += igraph
SUBDIR += isabelle
SUBDIR += itl
diff --git a/math/hs-statistics/Makefile b/math/hs-statistics/Makefile
new file mode 100644
index 000000000000..6da31865a082
--- /dev/null
+++ b/math/hs-statistics/Makefile
@@ -0,0 +1,89 @@
+# New ports collection makefile for: hs-statistics
+# Date created: January 03 2010
+# Whom: Giuseppe Pilichi aka Jacula Modyun <jacula@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= statistics
+PORTVERSION= 0.4.1
+CATEGORIES= math haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= jacula@gmail.com
+COMMENT= A Haskell library of statistical types, data, and functions
+
+BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
+ hs-uvector>=0.1.0.4:${PORTSDIR}/devel/hs-uvector \
+ hs-uvector-algorithms>=0.2:${PORTSDIR}/devel/hs-uvector-algorithms \
+ hs-erf>=1.0.0.0:${PORTSDIR}/math/hs-erf \
+ hs-mwc-random>=0.4.1.1:${PORTSDIR}/math/hs-mwc-random
+RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc \
+ hs-uvector>=0.1.0.4:${PORTSDIR}/devel/hs-uvector \
+ hs-uvector-algorithms>=0.2:${PORTSDIR}/devel/hs-uvector-algorithms \
+ hs-erf>=1.0.0.0:${PORTSDIR}/math/hs-erf \
+ hs-mwc-random>=0.4.1.1:${PORTSDIR}/math/hs-mwc-random
+
+GHC_VERSION= 6.10.4
+STATISTICS_VERSION= ${PORTVERSION}
+
+GHC_CMD= ${LOCALBASE}/bin/ghc
+SETUP_CMD= ./setup
+
+DATADIR= ${PREFIX}/share/${DISTNAME}
+PORTDATA= *
+
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+STATISTICS_LIBDIR_REL= lib/${DISTNAME}
+
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ STATISTICS_VERSION=${STATISTICS_VERSION} \
+ STATISTICS_LIBDIR_REL=${STATISTICS_LIBDIR_REL}
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= NOPORTDOCS=""
+.else
+PLIST_SUB+= NOPORTDOCS="@comment "
+.endif
+
+.if !defined(NOPORTDOCS)
+
+PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
+.if !empty(PORT_HADDOCK:M?0)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
+
+HSCOLOUR_VERSION= 1.15
+HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
+
+PORTDOCS= *
+.endif
+
+.SILENT:
+
+do-configure:
+ cd ${WRKSRC} && ${GHC_CMD} --make Setup.lhs -o setup -package Cabal \
+ && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
+
+do-build:
+ cd ${WRKSRC} && ${SETUP_CMD} build \
+ && ${SETUP_CMD} register --gen-script
+
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
+ --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${SETUP_CMD} install \
+ && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${STATISTICS_LIBDIR_REL}/register.sh
+.if !defined(NOPORTDATA)
+ ${MKDIR} ${DATADIR} && ${INSTALL_DATA} ${WRKSRC}/README ${DATADIR}
+.endif
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
+
+.include <bsd.port.mk>
diff --git a/math/hs-statistics/distinfo b/math/hs-statistics/distinfo
new file mode 100644
index 000000000000..b8a09b74020d
--- /dev/null
+++ b/math/hs-statistics/distinfo
@@ -0,0 +1,3 @@
+MD5 (statistics-0.4.1.tar.gz) = c2718dd1c30c85f2d691ffcfbc98e697
+SHA256 (statistics-0.4.1.tar.gz) = ecda5fbaea659602ac5a5f0809a29638d52ef970e76d7b5656579536cd5e7e4c
+SIZE (statistics-0.4.1.tar.gz) = 22146
diff --git a/math/hs-statistics/pkg-descr b/math/hs-statistics/pkg-descr
new file mode 100644
index 000000000000..51a6dcb672eb
--- /dev/null
+++ b/math/hs-statistics/pkg-descr
@@ -0,0 +1,17 @@
+This Haskell library provides a number of common functions and types
+useful in statistics. Our focus is on high performance, numerical
+robustness, and use of good algorithms. Where possible, we provide
+references to the statistical literature.
+
+The library's facilities can be divided into three broad categories:
+
+Working with widely used discrete and continuous probability
+distributions. (There are dozens of exotic distributions in use; we
+focus on the most common.)
+
+Computing with sample data: quantile estimation, kernel density
+estimation, bootstrap methods, and autocorrelation analysis.
+
+Random variate generation under several different distributions.
+
+WWW: http://darcs.serpentine.com/statistics
diff --git a/math/hs-statistics/pkg-plist b/math/hs-statistics/pkg-plist
new file mode 100644
index 000000000000..b51d210c0639
--- /dev/null
+++ b/math/hs-statistics/pkg-plist
@@ -0,0 +1,37 @@
+@comment $FreeBSD$
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HSstatistics-%%STATISTICS_VERSION%%.o
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Autocorrelation.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Constants.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Distribution.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Distribution/Binomial.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Distribution/Exponential.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Distribution/Gamma.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Distribution/Geometric.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Distribution/Hypergeometric.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Distribution/Normal.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Distribution/Poisson.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Function.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Internal.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/KernelDensity.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Math.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Quantile.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/RandomVariate.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Resampling.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Resampling/Bootstrap.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Sample.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Sample/Powers.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Types.hi
+%%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHSstatistics-%%STATISTICS_VERSION%%.a
+%%STATISTICS_LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Sample
+@dirrm %%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Resampling
+@dirrm %%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics/Distribution
+@dirrm %%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Statistics
+@dirrm %%STATISTICS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%STATISTICS_LIBDIR_REL%%
+@exec /bin/sh %D/%%STATISTICS_LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister statistics
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old