aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/chkrootkit/Makefile24
-rw-r--r--security/chkrootkit/distinfo6
-rw-r--r--security/chkrootkit/files/600000-patch-chkproc.c21
3 files changed, 46 insertions, 5 deletions
diff --git a/security/chkrootkit/Makefile b/security/chkrootkit/Makefile
index 7cde33e50e5c..5ee6ac684e4b 100644
--- a/security/chkrootkit/Makefile
+++ b/security/chkrootkit/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= chkrootkit
-PORTVERSION= 0.46a
+PORTVERSION= 0.47
CATEGORIES= security
MASTER_SITES= ftp://ftp.pangeia.com.br/pub/seg/pac/ \
ftp://gd.tuwien.ac.at/infosys/security/chkrootkit/ \
@@ -30,6 +30,26 @@ PORTDOCS= ACKNOWLEDGMENTS COPYRIGHT README README.chklastlog README.chkwtmp
BINMODE= 0700
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 600000
+
+EXTRA_PATCHES= ${PATCHDIR}/600000-patch-chkproc.c
+
+pre-everything::
+ @${ECHO_CMD} "######################################################################"
+ @${ECHO_CMD} "#"
+ @${ECHO_CMD} "# WARNING: chkproc process gives false positives values on"
+ @${ECHO_CMD} "# FreeBSD >= 6.x, and, due this fact, the getpriority code"
+ @${ECHO_CMD} "# added to identify LKMs was removed."
+ @${ECHO_CMD} "# So, use with caution."
+ @${ECHO_CMD} "#"
+ @${ECHO_CMD} "# This error will be fixed in the next chkrootkit version."
+ @${ECHO_CMD} "#"
+ @${ECHO_CMD} "######################################################################"
+
+.endif
+
pre-patch:
${REINPLACE_CMD} -e "s/^CC/#CC/; s/^CFLAGS/#CFLAGS/" ${WRKSRC}/Makefile
${REINPLACE_CMD} -e \
@@ -58,4 +78,4 @@ do-install:
${INSTALL_DATA} ${PORTDOCS:C,^,${WRKSRC}/,} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/chkrootkit/distinfo b/security/chkrootkit/distinfo
index 23a29e3d6dc1..55809aeab050 100644
--- a/security/chkrootkit/distinfo
+++ b/security/chkrootkit/distinfo
@@ -1,3 +1,3 @@
-MD5 (chkrootkit-0.46a.tar.gz) = b73fb9e365d2edcd031d65b16e965a18
-SHA256 (chkrootkit-0.46a.tar.gz) = ec23b4be57e08f6c28f646a447a8545f9c612fd4b296133ac9c3c3ac13e1d696
-SIZE (chkrootkit-0.46a.tar.gz) = 37140
+MD5 (chkrootkit-0.47.tar.gz) = 4c6455d202cef35395a673386e4bf01a
+SHA256 (chkrootkit-0.47.tar.gz) = 5a5aeb597769cc2843648858b95fc7abd3485ba7edd1800d69e0125220c6669f
+SIZE (chkrootkit-0.47.tar.gz) = 37791
diff --git a/security/chkrootkit/files/600000-patch-chkproc.c b/security/chkrootkit/files/600000-patch-chkproc.c
new file mode 100644
index 000000000000..31d37609306b
--- /dev/null
+++ b/security/chkrootkit/files/600000-patch-chkproc.c
@@ -0,0 +1,21 @@
+--- chkproc.c.orig Fri Nov 24 12:03:25 2006
++++ chkproc.c Fri Nov 24 12:04:43 2006
+@@ -334,18 +334,6 @@
+ }
+ #endif
+ }
+- else
+- {
+- errno = 0;
+- getpriority(PRIO_PROCESS, i);
+- if (!errno)
+- {
+- retdir++;
+- if (verbose)
+- printf ("PID %5d(%s): not in getpriority readdir output\n", i, buf);
+- }
+- }
+-
+ }
+ if (retdir)
+ printf("You have % 5d process hidden for readdir command\n", retdir);