aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/rezound/Makefile16
-rw-r--r--audio/rezound/files/extra-patch-fbsd422
2 files changed, 0 insertions, 38 deletions
diff --git a/audio/rezound/Makefile b/audio/rezound/Makefile
index 866a581a49e3..6a262860226f 100644
--- a/audio/rezound/Makefile
+++ b/audio/rezound/Makefile
@@ -99,30 +99,14 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if defined(GCCVERSION)
-. if ${GCCVERSION} < 030000
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-fbsd4
-. endif
-.else
-. if ${OSVERSION} < 500035
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-fbsd4
-. endif
-.endif
-
post-patch: .SILENT
-.if ${OSVERSION} > 500027
${REINPLACE_CMD} -e '/atoll/d' ${WRKSRC}/config/platform/bsd.h
-.endif
.if ${OSVERSION} > 502112
${REINPLACE_CMD} -e '/round/d' ${WRKSRC}/config/platform/bsd.h
.endif
.if ${OSVERSION} > 502120
${REINPLACE_CMD} -e '/nearbyint/d' ${WRKSRC}/config/platform/bsd.h
.endif
-.if ${OSVERSION} < 500028
- ${REINPLACE_CMD} -e '22586,$$s/stdint/inttypes/' \
- -e '21693s/$$srcdir/..\/../' ${WRKSRC}/configure
-.endif
${REINPLACE_CMD} -E 's,(_nl_expand_alias \()\),\1...),' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's,$$(prefix)/doc,$$(datadir)/doc,' \
${WRKSRC}/config/am_include.mk ${WRKSRC}/Makefile.in \
diff --git a/audio/rezound/files/extra-patch-fbsd4 b/audio/rezound/files/extra-patch-fbsd4
deleted file mode 100644
index 88cbb9492b86..000000000000
--- a/audio/rezound/files/extra-patch-fbsd4
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/backend/CPortAudioSoundRecorder.cpp.orig Mon Oct 6 13:04:39 2003
-+++ src/backend/CPortAudioSoundRecorder.cpp Mon Oct 2 10:35:16 2006
-@@ -18,6 +18,8 @@
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
- */
-
-+#include <stdio.h>
-+
- #include "CPortAudioSoundRecorder.h"
-
- #ifdef ENABLE_PORTAUDIO
---- src/backend/Remaster/CAdaptiveNormalizeAction.cpp.orig Tue Feb 15 08:54:44 2005
-+++ src/backend/Remaster/CAdaptiveNormalizeAction.cpp Mon Oct 2 10:35:24 2006
-@@ -18,6 +18,8 @@
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
- */
-
-+#include <stdio.h>
-+
- #include "CAdaptiveNormalizeAction.h"
-
- #include <utility>