aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/nss-pam-ldapd/Makefile2
-rw-r--r--net/nss-pam-ldapd/files/nslcd.in12
2 files changed, 12 insertions, 2 deletions
diff --git a/net/nss-pam-ldapd/Makefile b/net/nss-pam-ldapd/Makefile
index 0e0f81a9bb5d..1aec3edcc5de 100644
--- a/net/nss-pam-ldapd/Makefile
+++ b/net/nss-pam-ldapd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nss-pam-ldapd
PORTVERSION= 0.7.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://arthurdejong.org/nss-pam-ldapd/ \
http://static.ipfw.ru/files/
diff --git a/net/nss-pam-ldapd/files/nslcd.in b/net/nss-pam-ldapd/files/nslcd.in
index 5daab7ba603f..bf46a661777f 100644
--- a/net/nss-pam-ldapd/files/nslcd.in
+++ b/net/nss-pam-ldapd/files/nslcd.in
@@ -3,7 +3,8 @@
# $FreeBSD$
#
# PROVIDE: nslcd
-# REQUIRE: DAEMON ldconfig resolv
+# REQUIRE: ldconfig resolv
+# BEFORE: syslogd
#
# Add the following line to /etc/rc.conf to enable the nslcd daemon:
#
@@ -17,6 +18,15 @@ nslcd_enable=${nslcd_enable-"NO"}
name=nslcd
rcvar=$(set_rcvar)
+start_postcmd="nslcd_poststart"
+
+nslcd_poststart () {
+ until $(/usr/local/sbin/nslcd -c); do
+ echo " Waiting for nslcd to start"
+ sleep 1
+ done
+}
+
command="%%PREFIX%%/sbin/${name}"
pidfile="/var/run/${name}.pid"