aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/sylpheed2/Makefile1
-rw-r--r--mail/sylpheed2/files/patch-src_inc.c13
-rw-r--r--mail/sylpheed3/Makefile1
-rw-r--r--mail/sylpheed3/files/patch-src_inc.c13
4 files changed, 28 insertions, 0 deletions
diff --git a/mail/sylpheed2/Makefile b/mail/sylpheed2/Makefile
index 4c53cd21164b..b9b2caeca27b 100644
--- a/mail/sylpheed2/Makefile
+++ b/mail/sylpheed2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sylpheed
PORTVERSION= 2.4.4
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= http://sylpheed.sraoss.jp/sylpheed/v${PORTVERSION:C/\.[^\.]*$//}/
diff --git a/mail/sylpheed2/files/patch-src_inc.c b/mail/sylpheed2/files/patch-src_inc.c
new file mode 100644
index 000000000000..395e1bd38ed2
--- /dev/null
+++ b/mail/sylpheed2/files/patch-src_inc.c
@@ -0,0 +1,13 @@
+Index: inc.c
+===================================================================
+--- src/inc.c (revision 1874)
++++ src/inc.c (revision 1880)
+@@ -1364,7 +1364,7 @@
+ log_warning("%s\n", log_msg);
+ }
+ if (err_msg) {
+- alertpanel_error(err_msg);
++ alertpanel_error("%s", err_msg);
+ g_free(err_msg);
+ }
+ }
diff --git a/mail/sylpheed3/Makefile b/mail/sylpheed3/Makefile
index 4c53cd21164b..b9b2caeca27b 100644
--- a/mail/sylpheed3/Makefile
+++ b/mail/sylpheed3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sylpheed
PORTVERSION= 2.4.4
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= http://sylpheed.sraoss.jp/sylpheed/v${PORTVERSION:C/\.[^\.]*$//}/
diff --git a/mail/sylpheed3/files/patch-src_inc.c b/mail/sylpheed3/files/patch-src_inc.c
new file mode 100644
index 000000000000..395e1bd38ed2
--- /dev/null
+++ b/mail/sylpheed3/files/patch-src_inc.c
@@ -0,0 +1,13 @@
+Index: inc.c
+===================================================================
+--- src/inc.c (revision 1874)
++++ src/inc.c (revision 1880)
+@@ -1364,7 +1364,7 @@
+ log_warning("%s\n", log_msg);
+ }
+ if (err_msg) {
+- alertpanel_error(err_msg);
++ alertpanel_error("%s", err_msg);
+ g_free(err_msg);
+ }
+ }