aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--japanese/gedy/Makefile2
-rw-r--r--japanese/gedy/files/patch-gedy11
-rw-r--r--japanese/gsuica/Makefile2
-rw-r--r--japanese/gsuica/files/patch-gsuica11
4 files changed, 24 insertions, 2 deletions
diff --git a/japanese/gedy/Makefile b/japanese/gedy/Makefile
index 4b227deb0688..7964aae9988f 100644
--- a/japanese/gedy/Makefile
+++ b/japanese/gedy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gedy
PORTVERSION= 0.9.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= japanese ruby
MASTER_SITES= http://homepage3.nifty.com/slokar/pasori/
DISTNAME= ${PORTNAME}
diff --git a/japanese/gedy/files/patch-gedy b/japanese/gedy/files/patch-gedy
new file mode 100644
index 000000000000..076d157b901e
--- /dev/null
+++ b/japanese/gedy/files/patch-gedy
@@ -0,0 +1,11 @@
+--- gedy.orig 2017-01-05 05:52:52 UTC
++++ gedy
+@@ -1341,7 +1341,7 @@ unless (FileTest.exist?(APP_PATH))
+ Dir::mkdir(APP_PATH)
+ end
+
+-Icon = Gdk::Pixbuf.new($GEDY_XPM)
++Icon = GdkPixbuf::Pixbuf.new(:xpm => $GEDY_XPM)
+
+ edy = Edy.new
+
diff --git a/japanese/gsuica/Makefile b/japanese/gsuica/Makefile
index 486c945a4717..11b2c3d29a2d 100644
--- a/japanese/gsuica/Makefile
+++ b/japanese/gsuica/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gsuica
PORTVERSION= 0.9.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= japanese ruby
MASTER_SITES= http://homepage3.nifty.com/slokar/pasori/
DISTNAME= ${PORTNAME}
diff --git a/japanese/gsuica/files/patch-gsuica b/japanese/gsuica/files/patch-gsuica
new file mode 100644
index 000000000000..4a07d2474243
--- /dev/null
+++ b/japanese/gsuica/files/patch-gsuica
@@ -0,0 +1,11 @@
+--- gsuica.orig 2017-01-05 05:49:39 UTC
++++ gsuica
+@@ -2076,7 +2076,7 @@ unless (FileTest.exist?(APP_PATH))
+ Dir::mkdir(path)
+ end
+
+-Icon = Gdk::Pixbuf.new($SUICA_XPM)
++Icon = GdkPixbuf::Pixbuf.new(:xpm => $SUICA_XPM)
+
+ suica = Suica.new(path)
+