aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/textmaze/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/games/textmaze/Makefile b/games/textmaze/Makefile
index f5dd5c80920d..646a56ffe442 100644
--- a/games/textmaze/Makefile
+++ b/games/textmaze/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: textmaze
-# Date created: Sep 8, 2001
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= textmaze
PORTVERSION= 1.2
@@ -18,17 +13,15 @@ COMMENT= Generates mazes on a text terminal and lets you traverse them
RUN_DEPENDS= p5-Curses>=0:${PORTSDIR}/devel/p5-Curses
+USES= shebangfix
USE_PERL5= yes
NO_BUILD= yes
+SHEBANG_FILES= textmaze
PLIST_FILES= bin/textmaze
WRKSRC= ${WRKDIR}/TextMaze
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local/bin/perl|${PERL}|' \
- ${WRKSRC}/${PORTNAME}
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin