aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/m4/Makefile1
-rw-r--r--devel/m4/files/patch-ac20
2 files changed, 21 insertions, 0 deletions
diff --git a/devel/m4/Makefile b/devel/m4/Makefile
index 464c3bba6b26..7cee4bc4ba78 100644
--- a/devel/m4/Makefile
+++ b/devel/m4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= m4
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= m4
diff --git a/devel/m4/files/patch-ac b/devel/m4/files/patch-ac
new file mode 100644
index 000000000000..678532eaf19a
--- /dev/null
+++ b/devel/m4/files/patch-ac
@@ -0,0 +1,20 @@
+--- src/m4.c Mon Oct 22 04:25:47 2001
++++ src/m4.c Mon Oct 22 04:26:03 2001
+@@ -369,7 +369,7 @@
+
+ case 'o':
+ if (!debug_set_output (optarg))
+- error (0, errno, optarg);
++ error (0, errno, "%s", optarg);
+ break;
+
+ case 's':
+@@ -466,7 +466,7 @@
+ fp = path_search (argv[optind]);
+ if (fp == NULL)
+ {
+- error (0, errno, argv[optind]);
++ error (0, errno, "%s", argv[optind]);
+ continue;
+ }
+ else