aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/ayam/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/ayam/Makefile b/graphics/ayam/Makefile
index 6118444d8c58..ce8c0652d512 100644
--- a/graphics/ayam/Makefile
+++ b/graphics/ayam/Makefile
@@ -31,6 +31,12 @@ MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
AYAM_PLUGINS= csphere mfio
PLUGINS_DIR= ${PREFIX}/lib/${PORTNAME}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not build on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/tcl/ayam.tcl
@${REINPLACE_CMD} -e 's|^MF3DCFLAGS =|MF3DCFLAGS = -fPIC|g' \
@@ -87,4 +93,4 @@ do-install:
${DOCSDIR}/html/pics
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>