aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--converters/libiconv/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/converters/libiconv/Makefile b/converters/libiconv/Makefile
index 131b8e24538b..a6376648915b 100644
--- a/converters/libiconv/Makefile
+++ b/converters/libiconv/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libiconv
PORTVERSION= 1.9.1
+PORTREVISION= 1
CATEGORIES= converters devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -25,6 +26,16 @@ INSTALLS_SHLIB= yes
MAN1= iconv.1
MAN3= iconv.3 iconv_open.3 iconv_close.3
+.if !defined(WITHOUT_EXTRA_ENCODINGS)
+CONFIGURE_ARGS+= --enable-extra-encodings
+.endif
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "libiconv has the following tunable option(s):"
+ @${ECHO_MSG} " WITHOUT_EXTRA_ENCODINGS=yes Disable extra character sets"
+ @${ECHO_MSG} ""
+
post-patch:
@${REINPLACE_CMD} -e 's:ei_ksc5601:ei_euc_kr:g' ${WRKSRC}/lib/aliases.h