aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/pear-Crypt_XXTEA/Makefile24
-rw-r--r--security/pear-Crypt_XXTEA/distinfo3
-rw-r--r--security/pear-Crypt_XXTEA/pkg-descr5
4 files changed, 33 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 8ba0b28f3c95..7a285b2e12ec 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -562,6 +562,7 @@
SUBDIR += pear-Crypt_MicroID
SUBDIR += pear-Crypt_RC4
SUBDIR += pear-Crypt_RSA
+ SUBDIR += pear-Crypt_XXTEA
SUBDIR += pear-File_HtAccess
SUBDIR += pear-File_Passwd
SUBDIR += pear-File_SMBPasswd
diff --git a/security/pear-Crypt_XXTEA/Makefile b/security/pear-Crypt_XXTEA/Makefile
new file mode 100644
index 000000000000..12d5e87c32a0
--- /dev/null
+++ b/security/pear-Crypt_XXTEA/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: pear-Crypt_XXTEA
+# Date created: 2008-09-22
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt_XXTEA
+PORTVERSION= 0.9.0
+CATEGORIES= security www pear
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= PEAR XXTEA encryption algorithm
+
+BUILD_DEPENDS+= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS+= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+FILES= Crypt/XXTEA.php
+TESTS= decrypt.phpt encrypt.phpt long2str.phpt setkey.phpt \
+ str2long.phpt
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/security/pear-Crypt_XXTEA/distinfo b/security/pear-Crypt_XXTEA/distinfo
new file mode 100644
index 000000000000..4228a70f628a
--- /dev/null
+++ b/security/pear-Crypt_XXTEA/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Crypt_XXTEA-0.9.0.tgz) = 611bb2fc28aa91d86ee3803b06b1916a
+SHA256 (PEAR/Crypt_XXTEA-0.9.0.tgz) = 65ba8a111a8bea0c7ed0aaa3540fde8cf0ba37ea4262987770dbb1f6ab7b0bdf
+SIZE (PEAR/Crypt_XXTEA-0.9.0.tgz) = 6522
diff --git a/security/pear-Crypt_XXTEA/pkg-descr b/security/pear-Crypt_XXTEA/pkg-descr
new file mode 100644
index 000000000000..811030287dde
--- /dev/null
+++ b/security/pear-Crypt_XXTEA/pkg-descr
@@ -0,0 +1,5 @@
+This package allows you to encrypt and decrypt strings or long integer arrays
+with the XXTEA encryption algorithm, which is secure, fast and suitable for web
+development.
+
+WWW: http://pear.php.net/package/Crypt_XXTEA