aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/mp3unicode/Makefile7
-rw-r--r--audio/mp3unicode/pkg-descr2
-rw-r--r--cad/librecad/Makefile7
-rw-r--r--cad/librecad/pkg-descr2
-rw-r--r--emulators/qtemu/Makefile4
-rw-r--r--games/darkplaces/Makefile1
-rw-r--r--games/frozenbubble/Makefile8
-rw-r--r--games/toppler/Makefile10
-rw-r--r--games/trigger/Makefile2
-rw-r--r--games/trophy/Makefile4
-rw-r--r--games/warmux/Makefile12
-rw-r--r--games/warmux/pkg-descr30
-rw-r--r--irc/kvirc/Makefile12
-rw-r--r--math/qtiplot/Makefile4
-rw-r--r--math/speedcrunch/Makefile8
-rw-r--r--multimedia/minitube/Makefile2
-rw-r--r--multimedia/minitube/pkg-descr6
-rw-r--r--net-im/psi/Makefile6
-rw-r--r--x11-toolkits/qwt5/Makefile2
-rw-r--r--x11-toolkits/qwt6/Makefile2
20 files changed, 62 insertions, 69 deletions
diff --git a/audio/mp3unicode/Makefile b/audio/mp3unicode/Makefile
index cfb56a9a086f..32526c04c60d 100644
--- a/audio/mp3unicode/Makefile
+++ b/audio/mp3unicode/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: mp3unicode
-# Date created: 2007-09-29
-# Whom: Max Brazhnikov <makc@issp.ac.ru>
-#
# $FreeBSD$
-#
PORTNAME= mp3unicode
PORTVERSION= 1.2
@@ -26,6 +21,8 @@ MAN1= mp3unicode.1
PLIST_FILES= bin/mp3unicode
PORTDOCS= COPYING README
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
pre-configure:
diff --git a/audio/mp3unicode/pkg-descr b/audio/mp3unicode/pkg-descr
index bc0b65e3ca62..d011bf897125 100644
--- a/audio/mp3unicode/pkg-descr
+++ b/audio/mp3unicode/pkg-descr
@@ -1,4 +1,4 @@
MP3Unicode is a command line utility to convert ID3 tags in mp3
files between different encodings.
-WWW: http://mp3unicode.sourceforge.net/
+WWW: http://mp3unicode.sourceforge.net/
diff --git a/cad/librecad/Makefile b/cad/librecad/Makefile
index ab2048f9fea3..a1bfc6f99744 100644
--- a/cad/librecad/Makefile
+++ b/cad/librecad/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: librecad
-# Date created: 2012-01-03
-# Whom: Max Brazhnikov <makc@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= librecad
PORTVERSION= 1.0.0
@@ -19,6 +14,8 @@ USE_QT4= help qt3support help-tools_build moc_build qmake_build \
rcc_build uic_build uic3_build
MAKE_JOBS_SAFE= yes
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/cad/librecad/pkg-descr b/cad/librecad/pkg-descr
index 5413f2255fab..2fbf69946976 100644
--- a/cad/librecad/pkg-descr
+++ b/cad/librecad/pkg-descr
@@ -1,4 +1,4 @@
LibreCAD is a 2D CAD drawing application based on the community
edition of QCad (www.qcad.org).
-WWW: http://librecad.org
+WWW: http://librecad.org
diff --git a/emulators/qtemu/Makefile b/emulators/qtemu/Makefile
index e948dbf2e19d..25b96564501c 100644
--- a/emulators/qtemu/Makefile
+++ b/emulators/qtemu/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= emulators
MASTER_SITES= SF
MAINTAINER= makc@FreeBSD.org
-COMMENT= Qt4-based frontend for QEMU
+COMMENT= Qt 4 based frontend for QEMU
USE_BZIP2= yes
USE_QT4= gui xml uic_build moc_build qmake_build rcc_build
@@ -17,6 +17,8 @@ CONFIGURE_ENV+= LOCALBASE=${LOCALBASE}
DESKTOP_ENTRIES="QtEmu" "QEMU frontend" "" \
"qtemu" "" false
+OPTIONS_DEFINE= DOCS NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/games/darkplaces/Makefile b/games/darkplaces/Makefile
index 8eb6ffab39c0..484026c16317 100644
--- a/games/darkplaces/Makefile
+++ b/games/darkplaces/Makefile
@@ -21,6 +21,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
MAKEFILE= makefile
ALL_TARGET= #
+OPTIONS_DEFINE= DOCS
OPTIONS_MULTI= MODULE
OPTIONS_MULTI_MODULE= CLIENT DEDICATED SDL
OPTIONS_DEFAULT= ${OPTIONS_MULTI_MODULE}
diff --git a/games/frozenbubble/Makefile b/games/frozenbubble/Makefile
index 2ea85c928458..c43ad9b0c0b7 100644
--- a/games/frozenbubble/Makefile
+++ b/games/frozenbubble/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: frozen-bubble
-# Date created: 2002-10-06
-# Whom: Klaus Goger <klaus.goger@reflex.at>
-#
+# Created by: Klaus Goger <klaus.goger@reflex.at>
# $FreeBSD$
-#
PORTNAME= frozenbubble
PORTVERSION= 2.2.0
@@ -30,6 +26,8 @@ MAN6= frozen-bubble-editor.6 frozen-bubble.6
LEXECDIR= ${PREFIX}/libexec/${PORTNAME}
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/games/toppler/Makefile b/games/toppler/Makefile
index e94ac4e20ecb..809df25c9afe 100644
--- a/games/toppler/Makefile
+++ b/games/toppler/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: toppler
-# Date created: 18 Jan 2002
-# Whom: Dom Mitchell <dom@happygiraffe.net>
-#
+# Created by: Dom Mitchell <dom@happygiraffe.net>
# $FreeBSD$
-#
PORTNAME= toppler
PORTVERSION= 1.1.5
@@ -12,7 +8,7 @@ CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
MAINTAINER= makc@FreeBSD.org
-COMMENT= A game where you have to climb the tower and avoid the monsters
+COMMENT= Climb a tower and avoid monsters
USE_SDL= mixer sdl
USES= gettext
@@ -25,6 +21,8 @@ MAN6= ${PORTNAME}.6
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/games/trigger/Makefile b/games/trigger/Makefile
index ed15c7fd603f..02f7ce1c64cb 100644
--- a/games/trigger/Makefile
+++ b/games/trigger/Makefile
@@ -33,6 +33,8 @@ DESKTOP_ENTRIES="Trigger" "${COMMENT}" "" \
PORTDOCS= README-stereo.txt README.txt
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
diff --git a/games/trophy/Makefile b/games/trophy/Makefile
index f214698cb372..4b65bf26a4dc 100644
--- a/games/trophy/Makefile
+++ b/games/trophy/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games
MASTER_SITES= SF
MAINTAINER= makc@FreeBSD.org
-COMMENT= A single player racing game
+COMMENT= Single player racing game
LICENSE= GPLv2
@@ -23,6 +23,8 @@ MAN6= trophy.6
PORTDOCS= AUTHORS COPYING ChangeLog README TODO
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
pre-configure:
diff --git a/games/warmux/Makefile b/games/warmux/Makefile
index a15c193a2ff4..3db9192286f3 100644
--- a/games/warmux/Makefile
+++ b/games/warmux/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: wormux
-# Date created: Thu Dec 16 18:46:55 EET 2004
-# Whom: Anton Yudin <toha@FreeBSD.org>
-#
+# Created by: Anton Yudin <toha@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= warmux
DISTVERSION= 11.04.1
@@ -13,7 +9,7 @@ MASTER_SITES= http://download.gna.org/${PORTNAME}/ \
http://download.gna.org/${PORTNAME}/archive/
MAINTAINER= makc@FreeBSD.org
-COMMENT= Wormux game
+COMMENT= Turn-based artillery game with free software mascots
LIB_DEPENDS= xml++-2.6.2:${PORTSDIR}/textproc/libxml++26 \
curl:${PORTSDIR}/ftp/curl
@@ -30,7 +26,7 @@ USE_DOS2UNIX= fixed_class.h
MANCOMPRESSED= no
MAN6= warmux.6
-OPTIONS_DEFINE= FRIBIDI SERVER NLS
+OPTIONS_DEFINE= FRIBIDI SERVER NLS DEBUG
FRIBIDI_DESC= Enable bi-directional unicode support
SERVER_DESC= Enable dedicated server
@@ -44,7 +40,7 @@ post-patch:
${REINPLACE_CMD} -e "s,warmux_files.desktop,," ${WRKSRC}/data/Makefile.in
${FIND} -d ${WRKSRC}/data/ -name "*.*~" -delete
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug \
--enable-logging
.endif
diff --git a/games/warmux/pkg-descr b/games/warmux/pkg-descr
index 89fe1389365c..71ad5d8afd6f 100644
--- a/games/warmux/pkg-descr
+++ b/games/warmux/pkg-descr
@@ -1,17 +1,17 @@
-Almost everyone has heard of the Worms(R) series of games, developed by Team17.
-Worms was created in 1990, the goal of the game consisting of a several teams of
-"worms" fighting to the death on a 2D map. Wormux is heavily influenced by all
-games in this genre, including Scorched Earth and Liero.
+Almost everyone has heard of the Worms(R) series of games, developed
+by Team17. Worms was created in 1990, the goal of the game consisting
+of a several teams of "worms" fighting to the death on a 2D map.
+WarMUX (WAR of Mascots from UniX) is heavily influenced by all games
+in this genre, including Scorched Earth and Liero.
-Wormux is free software clone of this game concept. Though currently under heavy
-development, it is already very playable, with lots of weapons (Dynamite,
-Baseball Bat, Teleportation, etc.). There are also lots of maps available for
-your battling pleasure! Wormux takes the genre to the next level, with great
-customisation options leading to great gameplay. There is a wide selection of
-teams, from the Aliens to the Chickens. Also, new battlefields can be downloaded
-from the Internet, making strategy an important part of each battle.
+WarMUX is free software clone of this game concept. Though currently
+under heavy development, it is already very playable, with lots of
+weapons (Dynamite, Baseball Bat, Teleportation, etc.). There are
+also lots of maps available for your battling pleasure! WarMUX
+takes the genre to the next level, with great customisation options
+leading to great gameplay. There is a wide selection of teams,
+from the Aliens to the Chickens. Also, new battlefields can be
+downloaded from the Internet, making strategy an important part of
+each battle.
-Renamed to WarMUX (WAR of Mascots from UniX):
-http://www.wormux.org/phpboost/news/news-0-17+wormux-becomes-warmux.php
-
-WWW: http://www.wormux.org/
+WWW: http://sourceforge.net/projects/warmux.mirror/
diff --git a/irc/kvirc/Makefile b/irc/kvirc/Makefile
index fff01102ea8c..3c69c604a19e 100644
--- a/irc/kvirc/Makefile
+++ b/irc/kvirc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: kvirc
-# Date created: 05 January 2004
-# Whom: Michael Ranner
-#
+# Created by: Michael Ranner
# $FreeBSD$
-#
PORTNAME= kvirc
PORTVERSION= 4.2.0
@@ -19,7 +15,7 @@ MASTER_SITES= ftp://ftp.kvirc.de/pub/kvirc/%SUBDIR%/ \
MASTER_SITE_SUBDIR= ${PORTVERSION}/source
MAINTAINER= makc@FreeBSD.org
-COMMENT?= IRC client for KDE4
+COMMENT?= IRC client for KDE 4
.if !defined(PKGNAMESUFFIX)
CONFLICTS_INSTALL= kvirc-qt4-4.*
@@ -40,7 +36,7 @@ MAKE_JOBS_SAFE= yes
MAN1= kvirc.1
MANLANG= "" de fr it pt uk
-OPTIONS_DEFINE= AUDIOFILE GSM PERL PYTHON
+OPTIONS_DEFINE= AUDIOFILE GSM PERL PYTHON DEBUG
AUDIOFILE_DESC= Support for various audio formats
GSM_DESC= u-law to gsm audio converter support
@@ -75,7 +71,7 @@ USE_KDE4= kdelibs automoc4 kdeprefix
PLIST_SUB+= QT="@comment " KDE=""
.endif #defined(PKGNAMESUFFIX)
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CMAKE_ARGS+= -DWITH_DEBUG=yes -DVERBOSE=yes
.endif
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index 1434caa159ef..f41cfb52ab95 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -33,7 +33,7 @@ DESKTOP_ENTRIES="QtiPlot" "Data analysis and plotting" \
"${DATADIR}/qtiplot.png" \
"qtiplot" "" false
-OPTIONS_DEFINE= DOCS PYTHON NLS
+OPTIONS_DEFINE= DOCS PYTHON NLS DEBUG
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
DOCS_DESC= Install the QtiPlot Handbook
@@ -89,7 +89,7 @@ post-patch:
${WRKSRC}/fitPlugins/*/*.pro
@${REINPLACE_CMD} -e '/^system($$$$LUPDATE/d; /^system($$$$LRELEASE/d' \
${WRKSRC}/${PORTNAME}/qtiplot.pro
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
@${REINPLACE_CMD} -e \
"/^CONFIG.*release/s|release|debug|" \
${WRKSRC}/build.conf
diff --git a/math/speedcrunch/Makefile b/math/speedcrunch/Makefile
index 3604d00a2674..a84e22ee2caf 100644
--- a/math/speedcrunch/Makefile
+++ b/math/speedcrunch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: speedcrunch
-# Date created: 27 Jul 2007
-# Whom: Yinghong.Liu <relaxbsd@gmail.com>
-#
+# Created by: Yinghong.Liu <relaxbsd@gmail.com>
# $FreeBSD$
-#
PORTNAME= speedcrunch
DISTVERSION= 0.10.1
@@ -23,6 +19,8 @@ MAKE_JOBS_SAFE= yes
LRELEASE_CMD= ${LOCALBASE}/bin/lrelease-qt4
LRELEASE_ARGS= -compress -silent
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/multimedia/minitube/Makefile b/multimedia/minitube/Makefile
index 73caf38ac9e4..bbb5f9fc0bdc 100644
--- a/multimedia/minitube/Makefile
+++ b/multimedia/minitube/Makefile
@@ -22,6 +22,8 @@ LRELEASE= ${LOCALBASE}/bin/lrelease-qt4
STRIP_FILES= bin/minitube
+OPTIONS_DEFINE= NLS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
diff --git a/multimedia/minitube/pkg-descr b/multimedia/minitube/pkg-descr
index 124ec7ac97ee..c449625f3d4e 100644
--- a/multimedia/minitube/pkg-descr
+++ b/multimedia/minitube/pkg-descr
@@ -1,5 +1,5 @@
-Minitube is a native YouTube client. With it you can watch YouTube
+Minitube is a native YouTube client. With it you can watch YouTube
videos in a new way: you type a keyword, Minitube gives you an
-endless video stream. Minitube does not require the Flash Player.
+endless video stream. Minitube does not require the Flash Player.
-WWW: http://flavio.tordini.org/minitube/
+WWW: http://flavio.tordini.org/minitube/
diff --git a/net-im/psi/Makefile b/net-im/psi/Makefile
index b1a043caccc1..f6c99d111a86 100644
--- a/net-im/psi/Makefile
+++ b/net-im/psi/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= net-im
MASTER_SITES= SF/${PORTNAME}/Psi/${PORTVERSION}
MAINTAINER= makc@FreeBSD.org
-COMMENT= A Qt-based Jabber client
+COMMENT= Qt 4 based Jabber client
LIB_DEPENDS= qca.2:${PORTSDIR}/devel/qca
RUN_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl \
@@ -26,7 +26,7 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --qtdir=${LOCALBASE} \
CONFIGURE_ENV= QMAKEFLAGS='${QMAKEFLAGS}'
MAKE_JOBS_SAFE= yes
-OPTIONS_DEFINE= ASPELL ENCHANT DBUS
+OPTIONS_DEFINE= ASPELL ENCHANT DBUS DEBUG
OPTIONS_DEFAULT= ASPELL DBUS
ASPELL_DESC= Use aspell for spell checking
@@ -34,7 +34,7 @@ ENCHANT_DESC= Use Enchant for spell checking
.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --debug
PLIST_SUB+= DEBUG=""
.else
diff --git a/x11-toolkits/qwt5/Makefile b/x11-toolkits/qwt5/Makefile
index aa760c3b75d7..4fb9d0941345 100644
--- a/x11-toolkits/qwt5/Makefile
+++ b/x11-toolkits/qwt5/Makefile
@@ -23,6 +23,8 @@ PLIST_SUB= SHLIB_VER=${PORTVERSION} \
STRIP_FILES= lib/libqwt.so.${PORTVERSION}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.man>
diff --git a/x11-toolkits/qwt6/Makefile b/x11-toolkits/qwt6/Makefile
index e1d1db84e979..fafb7b406045 100644
--- a/x11-toolkits/qwt6/Makefile
+++ b/x11-toolkits/qwt6/Makefile
@@ -28,6 +28,8 @@ PLIST_SUB= INCLUDEDIR=include/${LATEST_LINK} \
STRIP_FILES= lib/libqwt6.so.${PORTVERSION} \
lib/libqwtmathml.so.${PORTVERSION}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch: