aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/netams/Makefile3
-rw-r--r--net-mgmt/netams/files/netams.in (renamed from net-mgmt/netams/files/netams.sh.in)19
2 files changed, 9 insertions, 13 deletions
diff --git a/net-mgmt/netams/Makefile b/net-mgmt/netams/Makefile
index 18e3661c6142..ec1787d965c7 100644
--- a/net-mgmt/netams/Makefile
+++ b/net-mgmt/netams/Makefile
@@ -7,6 +7,7 @@
PORTNAME= netams
PORTVERSION= 3.3.5
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.netams.com/files/
@@ -19,7 +20,7 @@ COMMENT= Network Traffic Accounting and Monitoring Software
NO_PACKAGE= Depends on kernel
USE_SUBMAKE= yes
-USE_RC_SUBR= netams.sh
+USE_RC_SUBR= netams
MANCOMPRESSED= no
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
diff --git a/net-mgmt/netams/files/netams.sh.in b/net-mgmt/netams/files/netams.in
index 8b7ea67b0d47..9f2f9614d90e 100644
--- a/net-mgmt/netams/files/netams.sh.in
+++ b/net-mgmt/netams/files/netams.in
@@ -1,14 +1,11 @@
#!/bin/sh
# $FreeBSD$
-
+#
# PROVIDE: netams
# REQUIRE: NETWORKING
# KEYWORD: shutdown
-# Define these netams_* variables in one of these files:
-# /etc/rc.conf
-# /etc/rc.conf.local
-# /etc/rc.conf.d/netams
+# Add the following line to /etc/rc.conf to enable netams
#
# netams_enable (bool): Set to "NO" by default.
# Set it to "YES" to enable netams.
@@ -17,21 +14,19 @@
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
-netams_enable=${netams_enable-"NO"}
-netams_config=${netams_config-"%%PREFIX%%/etc/netams.cfg"}
-
-netams_pidfile="/var/run/netams.pid"
. %%RC_SUBR%%
name="netams"
rcvar=`set_rcvar`
-command="%%PREFIX%%/libexec/netams"
load_rc_config $name
-pidfile="${netams_pidfile}"
+:${netams_enable="NO"}
+:${netams_config="/usr/local/etc/netams.cfg"}
-start_cmd="echo \"Starting ${name}.\"; ${command} -ldf ${netams_config} > /dev/null"
+pidfile="/var/run/netams.pid"
+command="/usr/local/libexec/netams"
+command_args="-lf ${netams_config} > /dev/null &"
run_rc_command "$1"