aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-CGI-Thin/Makefile22
-rw-r--r--www/p5-CGI-Thin/distinfo2
-rw-r--r--www/p5-CGI-Thin/pkg-descr10
-rw-r--r--www/p5-CGI-Thin/pkg-plist7
5 files changed, 42 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b12670247943..6c88ae2161fe 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -760,6 +760,7 @@
SUBDIR += p5-CGI-Session-ExpireSessions
SUBDIR += p5-CGI-Simple
SUBDIR += p5-CGI-SpeedyCGI
+ SUBDIR += p5-CGI-Thin
SUBDIR += p5-CGI-Untaint
SUBDIR += p5-CGI-Untaint-date
SUBDIR += p5-CGI-Untaint-email
diff --git a/www/p5-CGI-Thin/Makefile b/www/p5-CGI-Thin/Makefile
new file mode 100644
index 000000000000..5189d43a5fae
--- /dev/null
+++ b/www/p5-CGI-Thin/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-CGI-Thin
+# Date created: 2010-11-09
+# Whom: Phil Phillips
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Thin
+PORTVERSION= 0.52
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pphillips@experts-exchange.com
+COMMENT= A very lightweight Parser for CGI Forms
+
+PERL_CONFIGURE= yes
+
+MAN3= CGI::Thin.3 \
+ CGI::Thin::Cookies.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Thin/distinfo b/www/p5-CGI-Thin/distinfo
new file mode 100644
index 000000000000..c8aa357b34fb
--- /dev/null
+++ b/www/p5-CGI-Thin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (CGI-Thin-0.52.tar.gz) = a512adecf1e42b7cae77eb113d77edbf61c84ce8ff5ed67e142e169b460bc7d7
+SIZE (CGI-Thin-0.52.tar.gz) = 6360
diff --git a/www/p5-CGI-Thin/pkg-descr b/www/p5-CGI-Thin/pkg-descr
new file mode 100644
index 000000000000..99ebb491c7a4
--- /dev/null
+++ b/www/p5-CGI-Thin/pkg-descr
@@ -0,0 +1,10 @@
+This module is a very lightweight parser of CGI forms. And it has a special
+feature that it will return an array if the same key is used twice in the
+form. You can force an array even if only one value returned to avoid
+complications.
+
+The hash %cgi_data will have all the form data from either a POST or GET form
+and will also work for "multipart/form-data" forms necessary for uploading
+files.
+
+WWW: http://search.cpan.org/dist/CGI-Thin/
diff --git a/www/p5-CGI-Thin/pkg-plist b/www/p5-CGI-Thin/pkg-plist
new file mode 100644
index 000000000000..da25abf095e8
--- /dev/null
+++ b/www/p5-CGI-Thin/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/CGI/Thin.pm
+%%SITE_PERL%%/CGI/Thin/Cookies.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Thin/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Thin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI
+@dirrm %%SITE_PERL%%/CGI/Thin
+@dirrmtry %%SITE_PERL%%/CGI