aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/suricata/Makefile1
-rw-r--r--security/suricata/files/patch-src__suricata-common.h11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/suricata/Makefile b/security/suricata/Makefile
index fe296bafc997..334d728f7900 100644
--- a/security/suricata/Makefile
+++ b/security/suricata/Makefile
@@ -7,6 +7,7 @@
PORTNAME= suricata
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.openinfosecfoundation.org/download/ \
http://mirrors.rit.edu/zi/
diff --git a/security/suricata/files/patch-src__suricata-common.h b/security/suricata/files/patch-src__suricata-common.h
new file mode 100644
index 000000000000..5c294da203fe
--- /dev/null
+++ b/security/suricata/files/patch-src__suricata-common.h
@@ -0,0 +1,11 @@
+--- ./src/suricata-common.h.orig 2012-09-05 21:43:08.000000000 -0400
++++ ./src/suricata-common.h 2012-09-05 21:46:28.000000000 -0400
+@@ -131,6 +131,8 @@
+ #include <assert.h>
+ #define BUG_ON(x) assert(!(x))
+
++#define table_getc(x, y) table_get_c(x, y)
++
+ /* we need this to stringify the defines which are supplied at compiletime see:
+ http://gcc.gnu.org/onlinedocs/gcc-3.4.1/cpp/Stringification.html#Stringification */
+ #define xstr(s) str(s)