aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--biology/iqtree/Makefile3
-rw-r--r--biology/iqtree/distinfo6
-rw-r--r--devel/catch/Makefile6
-rw-r--r--devel/catch/distinfo6
-rw-r--r--games/openrct2/Makefile4
-rw-r--r--games/openrct2/distinfo6
-rw-r--r--games/sdlpop/Makefile3
-rw-r--r--games/sdlpop/distinfo6
-rw-r--r--math/tomsfastmath/Makefile1
-rw-r--r--security/bruteforceblocker/Makefile1
10 files changed, 19 insertions, 23 deletions
diff --git a/biology/iqtree/Makefile b/biology/iqtree/Makefile
index 1d9dddaabbef..35bf00c45200 100644
--- a/biology/iqtree/Makefile
+++ b/biology/iqtree/Makefile
@@ -18,8 +18,7 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen3.pc:math/eigen3
USES= cmake compiler:openmp
USE_GITHUB= yes
GH_ACCOUNT= Cibiv
-
-WRKSRC= ${WRKDIR}/IQ-TREE-${DISTVERSION}
+GH_PROJECT= IQ-TREE
PLIST_FILES= bin/iqtree
PORTEXAMPLES= example.cf example.nex example.phy models.nex
diff --git a/biology/iqtree/distinfo b/biology/iqtree/distinfo
index 45ad53376bf8..0beaadfc3780 100644
--- a/biology/iqtree/distinfo
+++ b/biology/iqtree/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1508602968
-SHA256 (Cibiv-iqtree-v1.6.beta4_GH0.tar.gz) = 78ff4cb03140aa36f5e057e0182f304e83f46cb729e09a1ef08ce9720bcce04f
-SIZE (Cibiv-iqtree-v1.6.beta4_GH0.tar.gz) = 4450460
+TIMESTAMP = 1509967096
+SHA256 (Cibiv-IQ-TREE-v1.6.beta4_GH0.tar.gz) = 78ff4cb03140aa36f5e057e0182f304e83f46cb729e09a1ef08ce9720bcce04f
+SIZE (Cibiv-IQ-TREE-v1.6.beta4_GH0.tar.gz) = 4450460
diff --git a/devel/catch/Makefile b/devel/catch/Makefile
index dde36ae51a99..d570fe063386 100644
--- a/devel/catch/Makefile
+++ b/devel/catch/Makefile
@@ -16,14 +16,12 @@ TEST_DEPENDS= cmake:devel/cmake
USES= compiler:c++11-lang
USE_GITHUB= yes
-GH_ACCOUNT= philsquared
-GH_PROJECT= Catch
+GH_ACCOUNT= catchorg
+GH_PROJECT= Catch2
NO_BUILD= yes
NO_ARCH= yes
-WRKSRC= ${WRKDIR}/${GH_PROJECT}2-${PORTVERSION}
-
REPORTERS= catch_reporter_automake.hpp \
catch_reporter_bases.cpp \
catch_reporter_bases.hpp \
diff --git a/devel/catch/distinfo b/devel/catch/distinfo
index f960e2a69b66..d02403c4a3ba 100644
--- a/devel/catch/distinfo
+++ b/devel/catch/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1509889172
-SHA256 (philsquared-Catch-v2.0.1_GH0.tar.gz) = 5f31b93712e65d363f257ad0f0c02cfbed7a3988979d5f320ad7771e513d4cc8
-SIZE (philsquared-Catch-v2.0.1_GH0.tar.gz) = 397154
+TIMESTAMP = 1509966699
+SHA256 (catchorg-Catch2-v2.0.1_GH0.tar.gz) = 5f31b93712e65d363f257ad0f0c02cfbed7a3988979d5f320ad7771e513d4cc8
+SIZE (catchorg-Catch2-v2.0.1_GH0.tar.gz) = 397154
diff --git a/games/openrct2/Makefile b/games/openrct2/Makefile
index 8fda3bf0c995..9f6cfbea790a 100644
--- a/games/openrct2/Makefile
+++ b/games/openrct2/Makefile
@@ -6,7 +6,6 @@ DISTVERSIONPREFIX= v
DISTVERSION= 0.1.1
PORTREVISION= 2
CATEGORIES= games
-EXTRACT_ONLY= ${PORTNAME}-${PORTNAME}-${DISTVERSIONPREFIX}${DISTVERSION}_GH0${EXTRACT_SUFX}
MAINTAINER= pkubaj@anongoth.pl
COMMENT= Open source re-implementation of RollerCoaster Tycoon 2
@@ -23,8 +22,9 @@ LIB_DEPENDS= libpng.so:graphics/png \
libfreetype.so:print/freetype2
USE_GITHUB= yes
+GH_ACCOUNT= OpenRCT2
+GH_PROJECT= OpenRCT2
-WRKSRC= ${WRKDIR}/OpenRCT2-${PORTVERSION}
INSTALLS_ICONS= yes
USES= compiler:c++14-lang cmake:outsource iconv localbase:ldflags pkgconfig ssl
USE_GL= gl
diff --git a/games/openrct2/distinfo b/games/openrct2/distinfo
index 9c8e9804dece..648f35e54f1a 100644
--- a/games/openrct2/distinfo
+++ b/games/openrct2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1502898621
-SHA256 (openrct2-openrct2-v0.1.1_GH0.tar.gz) = 5d7a6c7f3c770e7de506958f86789c438c543c27d312fd096322cde4e89f50ad
-SIZE (openrct2-openrct2-v0.1.1_GH0.tar.gz) = 6284135
+TIMESTAMP = 1509967245
+SHA256 (OpenRCT2-OpenRCT2-v0.1.1_GH0.tar.gz) = 5d7a6c7f3c770e7de506958f86789c438c543c27d312fd096322cde4e89f50ad
+SIZE (OpenRCT2-OpenRCT2-v0.1.1_GH0.tar.gz) = 6284135
diff --git a/games/sdlpop/Makefile b/games/sdlpop/Makefile
index 99d9dfbc2af7..05525ed8166e 100644
--- a/games/sdlpop/Makefile
+++ b/games/sdlpop/Makefile
@@ -16,8 +16,9 @@ USES= cmake localbase:ldflags
USE_GITHUB= yes
GH_ACCOUNT= NagyD
+GH_PROJECT= SDLPoP
-WRKSRC= ${WRKDIR}/SDLPoP-${PORTVERSION}/src
+WRKSRC_SUBDIR= src
USE_SDL= sdl2 image2 mixer2
PORTDOCS= *
diff --git a/games/sdlpop/distinfo b/games/sdlpop/distinfo
index 46f253e3c7db..c54ad8307fd1 100644
--- a/games/sdlpop/distinfo
+++ b/games/sdlpop/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1502897183
-SHA256 (NagyD-sdlpop-v1.17_GH0.tar.gz) = aa4b254ab80b889a6db491b41c4f83467124d932cc0836e5979fa73b6c49a94d
-SIZE (NagyD-sdlpop-v1.17_GH0.tar.gz) = 3713129
+TIMESTAMP = 1509967343
+SHA256 (NagyD-SDLPoP-v1.17_GH0.tar.gz) = aa4b254ab80b889a6db491b41c4f83467124d932cc0836e5979fa73b6c49a94d
+SIZE (NagyD-SDLPoP-v1.17_GH0.tar.gz) = 3713129
diff --git a/math/tomsfastmath/Makefile b/math/tomsfastmath/Makefile
index 355b9bdf2191..a2ba5799a147 100644
--- a/math/tomsfastmath/Makefile
+++ b/math/tomsfastmath/Makefile
@@ -17,7 +17,6 @@ USES= compiler:features gmake tar:bzip2
USE_GITHUB= yes
GH_ACCOUNT= libtom
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKEFILE= makefile
ALL_TARGET= default
CFLAGS+= -fPIC
diff --git a/security/bruteforceblocker/Makefile b/security/bruteforceblocker/Makefile
index e091ad792e1c..e9cc0a03f4fd 100644
--- a/security/bruteforceblocker/Makefile
+++ b/security/bruteforceblocker/Makefile
@@ -23,7 +23,6 @@ USE_PERL5= run
OPTIONS_DEFINE= DOCS
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
SUB_FILES= pkg-message
SHEBANG_FILES= ${PORTNAME}.pl