aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/horde-passwd/Makefile5
-rw-r--r--www/horde-passwd/files/patch-lib_Driver.php12
2 files changed, 16 insertions, 1 deletions
diff --git a/www/horde-passwd/Makefile b/www/horde-passwd/Makefile
index 57a260c667fe..7c82b2d37869 100644
--- a/www/horde-passwd/Makefile
+++ b/www/horde-passwd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= horde-passwd
PORTVERSION= 3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www mail
MASTER_SITES= ftp://ftp.horde.org/pub/passwd/ \
ftp://ftp.planetmirror.com/pub/horde/passwd/ \
@@ -60,6 +60,9 @@ pre-configure:
@${SED} -e "s:/home/httpd/html/horde/passwd:${PWDDIR}:g" \
${FILESDIR}/httpd.conf.pwd > ${WRKDIR}/httpd-pwd.conf
+post-patch:
+ @${FIND} ${WRKSRC} -name "*.orig" -delete
+
do-install:
@${MKDIR} ${PWDDIR}
.for REP in ${SUB_DIRS}
diff --git a/www/horde-passwd/files/patch-lib_Driver.php b/www/horde-passwd/files/patch-lib_Driver.php
new file mode 100644
index 000000000000..e5472ef12db1
--- /dev/null
+++ b/www/horde-passwd/files/patch-lib_Driver.php
@@ -0,0 +1,12 @@
+--- lib/Driver.php.orig Wed Aug 23 13:18:54 2006
++++ lib/Driver.php Wed Aug 23 13:19:40 2006
+@@ -107,7 +107,8 @@
+ require_once dirname(__FILE__) . '/Driver/' . $driver . '.php';
+ $class = 'Passwd_Driver_' . $driver;
+ if (class_exists($class)) {
+- return $ret = &new $class($params);
++ $ret = &new $class($params);
++ return $ret;
+ } else {
+ Horde::fatal(PEAR::raiseError(sprintf(_("No such backend \"%s\" found."), $driver)), __FILE__, __LINE__);
+ }