aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/mod_python3/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/www/mod_python3/Makefile b/www/mod_python3/Makefile
index 5af033bae04b..7769e6558c80 100644
--- a/www/mod_python3/Makefile
+++ b/www/mod_python3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mod_python
PORTVERSION= 3.3.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR= modpython
@@ -13,21 +13,27 @@ EXTRACT_SUFX= .tgz
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module that embeds the Python interpreter within the server
-
USE_APACHE= 22
USE_PYTHON= yes
-MAKE_ARGS+= APXS=${APXS}
-
INSTALLS_EGGINFO= yes
-LATEST_LINK= mod_python3
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-apxs="${APXS}" --with-python="${PYTHON_CMD}" \
- --without-flex
+LATEST_LINK= mod_python3
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-apxs="${APXS}" \
+ --with-python="${PYTHON_CMD}" \
+ --without-flex
+
+LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_ARGS+= APXS=${APXS}
MAKE_ENV= EXPR_COMPAT=yes
NO_STAGE= yes
post-install:
@${CAT} ${PKGMESSAGE}
+# You need to install apache & mod_python before you run this
+regression-test: build
+ @cd ${WRKSRC} && ${MAKE} check
+
.include <bsd.port.mk>