aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--irc/bobot++/Makefile18
-rw-r--r--irc/evangeline/Makefile17
-rw-r--r--irc/minbif/Makefile23
-rw-r--r--irc/srvx/Makefile15
-rw-r--r--lang/Sather/Makefile7
-rw-r--r--lang/bigloo/Makefile23
-rw-r--r--lang/expect/Makefile15
-rw-r--r--lang/rubinius/Makefile6
-rw-r--r--lang/xotcl/Makefile18
9 files changed, 75 insertions, 67 deletions
diff --git a/irc/bobot++/Makefile b/irc/bobot++/Makefile
index 9bf6dcea42b3..8e3ddcff93b8 100644
--- a/irc/bobot++/Makefile
+++ b/irc/bobot++/Makefile
@@ -17,7 +17,9 @@ COMMENT= An IRC bot written in C++
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-OPTIONS= GUILE "Use Guile scripts" on
+OPTIONS_DEFINE= GUILE
+OPTIONS_DEFAULT= GUILE
+GUILE_DESC= Use Guile scripts
GNU_CONFIGURE= yes
@@ -29,11 +31,9 @@ PLIST_FILES= bin/${PORTNAME}
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_GUILE)
-CONFIGURE_ARGS+= --disable-scripting
-.else
+.if ${PORT_OPTIONS:MGUILE}
LIB_DEPENDS+= guile.21:${PORTSDIR}/lang/guile
CONFIGURE_ARGS+= --enable-scripting
PLIST_FILES+= share/guile/site/bobotpp/bot.scm \
@@ -42,6 +42,8 @@ PLIST_DIRS+= %%DATADIR%%/scripts \
%%DATADIR%% \
share/guile/site/bobotpp
PLIST_DIRSTRY+= share/guile/site
+.else
+CONFIGURE_ARGS+= --disable-scripting
.endif
post-patch:
@@ -49,13 +51,13 @@ post-patch:
@${REINPLACE_CMD} -e 's|std::snprintf|snprintf|g' ${WRKSRC}/source/Bot.C
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@(cd ${WRKSRC}/documentation && ${INSTALL_DATA} *.html ${DOCSDIR})
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/evangeline/Makefile b/irc/evangeline/Makefile
index 6a7e54d6e7b6..4e7dcc8ebe7a 100644
--- a/irc/evangeline/Makefile
+++ b/irc/evangeline/Makefile
@@ -22,23 +22,24 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
IS_INTERACTIVE= yes
-OPTIONS= IPV6 "Enable IPv6 support" off \
- CRYPT "Enable Encryption" on
+OPTIONS_DEFINe= IPV6 CRYPT
+OPTIONS_DEFAULT= CRYPT
+CRYPT_DESC= Enable Encryption
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6
.endif
-.if defined(WITHOUT_CRYPT)
-CONFIGURE_ARGS+= --disable-crypt
-.else
+.if ${PORT_OPTIONS:MCRYPT}
CONFIGURE_ARGS+= --enable-crypt
+.else
+CONFIGURE_ARGS+= --disable-crypt
.endif
PLIST_FILES= bin/evangeline
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/minbif/Makefile b/irc/minbif/Makefile
index bb47cac35b16..6f5a1998f9e7 100644
--- a/irc/minbif/Makefile
+++ b/irc/minbif/Makefile
@@ -34,23 +34,24 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
PORTDOCS= *
# right now WITH_PLUGINS installs prpl-coincoin and prpl-gayattitude
-OPTIONS= CACA "Buddy icon display using libcaca" On \
- GNUTLS "Compile with GnuTLS support" Off \
- VIDEO "Webcam display using libcaca (depends on CACA)" Off \
- PLUGINS "Compile additional libpurple-plugins" Off
+OPTIONS_DEFINE= CACA GNUTLS VIDEO PLUGINS DOCS
+OPTIONS_DEFAULT= CACA
+CACA_DESC= Buddy icon display using libcaca
+VIDEO_DESC= Webcam display using libcaca (depends on CACA)
+PLUGINS_DESC= Compile additional libpurple-plugins
SUB_LIST+= USERS=${USERS}
.include <bsd.port.options.mk>
-.if defined(WITH_CACA)
+.if ${PORT_OPTIONS:MCACA}
LIB_DEPENDS+= caca.0:${PORTSDIR}/graphics/libcaca
CMAKE_ARGS+= -DENABLE_CACA:BOOL=ON
.else
CMAKE_ARGS+= -DENABLE_CACA:BOOL=OFF
.endif
-.if defined(WITH_VIDEO) && defined(WITH_CACA)
+.if ${PORT_OPTIONS:MVIDEO} && !empty(PORT_OPTIONS:MCACA)
USE_GSTREAMER+= core good
LIB_DEPENDS+= gstfarsight-0.10.0:${PORTSDIR}/net-im/farsight2
CMAKE_ARGS+= -DENABLE_VIDEO:BOOL=ON
@@ -58,12 +59,12 @@ CMAKE_ARGS+= -DENABLE_VIDEO:BOOL=ON
CMAKE_ARGS+= -DENABLE_VIDEO:BOOL=OFF
.endif
-.if defined(WITH_VIDEO) && !defined(WITH_CACA)
+.if ${PORT_OPTIONS:MVIDEO} && empty(PORT_OPTIONS:MCACA)
IGNORE= if you want to enable webcam support, you must \
also enable CACA.
.endif
-.if defined(WITH_PLUGINS)
+.if ${PORT_OPTIONS:MPLUGINS}
CMAKE_ARGS+= -DENABLE_PLUGIN:BOOL=ON
PLIST_FILES+= lib/purple-2/libcoincoin.so \
lib/purple-2/libgayattitude.so
@@ -71,7 +72,7 @@ PLIST_FILES+= lib/purple-2/libcoincoin.so \
CMAKE_ARGS+= -DENABLE_PLUGIN:BOOL=OFF
.endif
-.if defined(WITH_GNUTLS)
+.if ${PORT_OPTIONS:MGNUTLS}
LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls
CMAKE_ARGS+= -DENABLE_GNUTLS:BOOL=ON
.endif
@@ -82,11 +83,11 @@ do-install:
${MKDIR} ${ETCDIR}
${INSTALL_DATA} ${WRKSRC}/minbif.conf ${ETCDIR}/minbif.conf-dist
${INSTALL_DATA} ${WRKSRC}/minbif.motd ${ETCDIR}/minbif.motd-dist
-.if defined(WITH_PLUGINS)
+.if ${PORT_OPTIONS:MPLUGINS}
${INSTALL_PROGRAM} ${WRKSRC}/plugins/coincoin/libcoincoin.so ${PREFIX}/lib/purple-2
${INSTALL_PROGRAM} ${WRKSRC}/plugins/gayattitude/libgayattitude.so ${PREFIX}/lib/purple-2
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/COPYING ${DOCSDIR}
diff --git a/irc/srvx/Makefile b/irc/srvx/Makefile
index 2af995a39777..a095f61caa22 100644
--- a/irc/srvx/Makefile
+++ b/irc/srvx/Makefile
@@ -13,8 +13,9 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A set of services for ircu P10 protocol networks
-OPTIONS= PROTOCOL_BAHAMUT "Enables Bahamut protocol (P10 is default)" "on" \
- DEBUG "Enables debug mode" "off"
+OPTIONS_DEFINE= PROTOCOL_BAHAMUT DEBUG
+OPTIONS_DEFAULT= PROTOCOL_BAHAMUT
+PROTOCOL_BAHAMUT_DESC= Enables Bahamut protocol (P10 is default)
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-getopt
@@ -35,13 +36,13 @@ PLIST_FILES= bin/srvx \
etc/srvx.conf.example \
etc/sockcheck.conf.example
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug
.endif
-.if defined(WITH_PROTOCOL_BAHAMUT)
+.if ${PORT_OPTIONS:MPROTOCOL_BAHAMUT}
CONFIGURE_ARGS+= --with-protocol=bahamut
.endif
@@ -52,10 +53,10 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/srvx ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/*.conf.example ${PREFIX}/etc
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/src/*.help ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/Sather/Makefile b/lang/Sather/Makefile
index 29cabd45da3f..69f1af2e4b72 100644
--- a/lang/Sather/Makefile
+++ b/lang/Sather/Makefile
@@ -37,7 +37,8 @@ SAT_CFLAGS= ${CFLAGS} -I. \
SAT_LIBS= -L${LOCALBASE}/lib -lgc-redirect -lm
SAT_LIBDIR= ${PREFIX}/lib/sather
-OPTIONS= EMACS "Install Emacs syntax files" off
+OPTIONS_DEFINE= EMACS DOCS
+EMACS_DESC= Install Emacs syntax files
.if !defined(NOPORTDOCS)
PORTDOCS= *
@@ -168,13 +169,13 @@ do-install:
.for file in ${INFO}
${INSTALL_DATA} ${WRKSRC}/Emacs/${file}.info ${PREFIX}/info
.endfor
-.if defined(WITH_EMACS)
+.if ${PORT_OPTIONS:MEMACS}
. for file in hl319.el sather-lib.el sather-module.el sather.el
${INSTALL_DATA} ${WRKSRC}/Emacs/${file} ${PREFIX}/share/emacs/site-lisp
@${ECHO_CMD} "share/emacs/site-lisp/${file}" >> ${TMPPLIST}
. endfor
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@(cd ${WRKSRC}/Doc && ${COPYTREE_SHARE} "*" ${DOCSDIR} \
"! -regex .*man.* ! -regex .*GPL ! -regex .*\.bak")
diff --git a/lang/bigloo/Makefile b/lang/bigloo/Makefile
index 3b6ce5c7c832..f12a8c8c57bc 100644
--- a/lang/bigloo/Makefile
+++ b/lang/bigloo/Makefile
@@ -21,12 +21,9 @@ LICENSE_COMB= multi
LIB_DEPENDS= gc.1:${PORTSDIR}/devel/boehm-gc \
gmp.10:${PORTSDIR}/math/gmp
-OPTIONS= ALSA "Enable ALSA support" off \
- FLAC "Enable FLAC support" off \
- GSTREAMER "Enable Gstreamer support" off \
- MPG123 "Enable MPG123 support" off \
- SQLITE "Enable SQLite support" off \
- OPENSSL "Enable OpenSSL support" on
+OPTIONS_DEFINE= ALSA FLAC GSTREAMER MPG123 SQLITE OPENSSL DOCS
+OPTIONS_DEFAULT= OPENSSL
+MPG123_DESC= Enable MPG123 support
WANT_GSTREAMER= yes
USE_GCC= 4.6+
@@ -51,7 +48,7 @@ INFO= bigloo
.include <bsd.port.options.mk>
-.if defined(WITH_ALSA)
+.if ${PORT_OPTIONS:MALSA}
LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
PLIST_SUB+= ALSA=""
.else
@@ -59,7 +56,7 @@ CONFIGURE_ARGS+=--disable-alsa
PLIST_SUB+= ALSA="@comment "
.endif
-.if defined(WITH_FLAC)
+.if ${PORT_OPTIONS:MFLAC}
LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
PLIST_SUB+= FLAC=""
.else
@@ -67,7 +64,7 @@ CONFIGURE_ARGS+=--disable-flac
PLIST_SUB+= FLAC="@comment "
.endif
-.if defined(WITH_GSTREAMER)
+.if ${PORT_OPTIONS:MGSTREAMER}
USE_GSTREAMER= yes
PLIST_SUB+= GSTREAMER=""
.else
@@ -75,7 +72,7 @@ CONFIGURE_ARGS+=--disable-gstreamer
PLIST_SUB+= GSTREAMER="@comment "
.endif
-.if defined(WITH_MPG123)
+.if ${PORT_OPTIONS:MMPG123}
LIB_DEPENDS+= mpg123.0:${PORTSDIR}/audio/mpg123
PLIST_SUB+= MPG123=""
.else
@@ -83,7 +80,7 @@ CONFIGURE_ARGS+=--disable-mpg123
PLIST_SUB+= MPG123="@comment "
.endif
-.if defined(WITH_SQLITE)
+.if ${PORT_OPTIONS:MSQLITE}
USE_SQLITE= yes
PLIST_SUB+= SQLITE=""
.else
@@ -91,7 +88,7 @@ CONFIGURE_ARGS+=--disable-pkglib --disable-sqlite
PLIST_SUB+= SQLITE="@comment "
.endif
-.if defined(WITH_OPENSSL)
+.if ${PORT_OPTIONS:MOPENSSL}
USE_OPENSSL= yes
PLIST_SUB+= OPENSSL=""
.else
@@ -129,7 +126,7 @@ post-configure:
post-install:
${INSTALL_MAN} ${WRKSRC}/manuals/bigloo.man ${MANPREFIX}/man/man1/${MAN1}
${INSTALL_DATA} ${WRKSRC}/manuals/bigloo.info ${PREFIX}/${INFO_PATH}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/manuals/*.html ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/manuals/*.sui ${DOCSDIR}
diff --git a/lang/expect/Makefile b/lang/expect/Makefile
index bd3bbb7a7c55..ed6d6e0f5d66 100644
--- a/lang/expect/Makefile
+++ b/lang/expect/Makefile
@@ -27,23 +27,24 @@ GNU_CONFIGURE= yes
PLIST_SUB+= EXPECT_VER="${EXPECT_VER}"
PLIST_SUB+= LIBEXPECT_VER="${LIBEXPECT_VER}"
-OPTIONS= X11 "Enable X11 support" on
+OPTIONS_DEFINE= X11
+OPTIONS_DEFAULT= X11
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
LIB_DEPENDS?= tk84.1:${PORTSDIR}/x11-toolkits/tk84
.else
LIB_DEPENDS?= tcl84.1:${PORTSDIR}/lang/tcl84
.endif
-.if defined(WITHOUT_X11)
-TK_CONFIG_ARGS=
-PLIST_SUB+= XFILES="@comment "
-.else
+.if ${PORT_OPTIONS:MX11}
TK_CONFIG_ARGS= --with-tkconfig=${LOCALBASE}/lib/tk8.4 \
--with-tkinclude=${LOCALBASE}/include/tk8.4
PLIST_SUB+= XFILES=""
+.else
+TK_CONFIG_ARGS=
+PLIST_SUB+= XFILES="@comment "
.endif
CONFIGURE_ARGS?=--enable-shared \
@@ -55,7 +56,7 @@ CONFIGURE_ARGS?=--enable-shared \
MAN1= autoexpect.1 cryptdir.1 decryptdir.1 dislocate.1 \
expect.1 kibitz.1 mkpasswd.1 multixterm.1 passmass.1 \
tknewsbiff.1 unbuffer.1 xkibitz.1
-.if !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MX11}
MAN1+= expectk.1
.endif
MAN3= libexpect.3
diff --git a/lang/rubinius/Makefile b/lang/rubinius/Makefile
index 71636643e7b8..4aac2fc1526a 100644
--- a/lang/rubinius/Makefile
+++ b/lang/rubinius/Makefile
@@ -37,7 +37,9 @@ USE_PERL5_BUILD= yes
USE_GMAKE= yes
MAKE_JOBS_UNSAFE= yes
-OPTIONS= GDBM "Enable GDBM support" on
+OPTIONS_DEFINE= GDBM
+OPTIONS_DEFAULT= GDBM
+GDBM_DESC= Enable GDBM support
.include <bsd.port.pre.mk>
@@ -49,7 +51,7 @@ MANUAL_PACKAGE_BUILD= hangs on pointyhat
BROKEN= Does not compile on sparc64
.endif
-.if !defined(WITHOUT_GDBM) || exists(${LOCALBASE}/include/gdbm.h)
+.if ${PORT_OPTIONS:MGDBM} || exists(${LOCALBASE}/include/gdbm.h)
LIB_DEPENDS= gdbm.4:${PORTSDIR}/databases/gdbm
PLIST_SUB+= GDBM=""
.else
diff --git a/lang/xotcl/Makefile b/lang/xotcl/Makefile
index d76f18acb56c..157154963d55 100644
--- a/lang/xotcl/Makefile
+++ b/lang/xotcl/Makefile
@@ -32,8 +32,10 @@ USE_LDCONFIG= ${PREFIX}/lib/xotcl${PORTVERSION}
GNU_CONFIGURE= yes
PORTDOCS= *
-OPTIONS= ACTIWEB "Include actiweb" on \
- TUTORIAL "Install XOTcl tutorial" off
+OPTIONS_DEFINE= ACTIWEB TUTORIAL DOCS
+OPTIONS_DEFAULT= ACTIWEB
+ACTIWEB_DESC= Include actiweb
+TUTORIAL_DESC= Install XOTcl tutorial
LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
CONFIGURE_ARGS+= --with-expat=${LOCALBASE}/include,${LOCALBASE}/lib
@@ -41,7 +43,7 @@ CONFIGURE_ARGS+= --with-expat=${LOCALBASE}/include,${LOCALBASE}/lib
AOLSERVERBASE?= aolserver
.endif
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(AOLSERVER_XOTCL)
RUN_DEPENDS+= ${LOCALBASE}/aolserver/bin/init.tcl:${PORTSDIR}/www/aolserver \
@@ -52,7 +54,7 @@ LATEST_LINK= aolserver-xotcl
NO_BUILD= yes
.endif
-.if defined(WITH_ACTIWEB)
+.if ${PORT_OPTIONS:MACTIWEB}
CONFIGURE_ARGS+= --with-actiweb --with-gdbm=${LOCALBASE}/include,${LOCALBASE}/lib
LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm
PLIST_SUB+= ACTIWEB=""
@@ -60,7 +62,7 @@ PLIST_SUB+= ACTIWEB=""
PLIST_SUB+= ACTIWEB="@comment "
.endif
-.if defined(WITH_TUTORIAL)
+.if ${PORT_OPTIONS:MTUTORIAL}
PLIST_SUB+= TUTORIAL=""
.else
PLIST_SUB+= TUTORIAL="@comment "
@@ -96,7 +98,7 @@ do-install:
.if !defined(AOLSERVER_XOTCL) # Aolserver module has no post-install
post-install:
-.if defined(WITH_TUTORIAL)
+.if ${PORT_OPTIONS:MTUTORIAL}
${MKDIR} ${EXAMPLESDIR}/tutorial/html ${EXAMPLESDIR}/tutorial/pdf
.for FILE in langRef-xotcl.pdf tutorial.pdf
${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${EXAMPLESDIR}/tutorial/pdf
@@ -104,7 +106,7 @@ post-install:
@cd ${WRKSRC}; ${FIND} doc/ -type f \( -name '*.html' -or -name '*.css' -or -name '*.gif' \) \
-exec ${INSTALL_DATA} ${WRKSRC}/{} ${EXAMPLESDIR}/tutorial/html \;
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for FILE in ChangeLog README README.aol
${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
@@ -114,4 +116,4 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/man/xotclsh.1 ${PREFIX}/man/man1/
.endif
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>