aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--cad/ngspice_rework/Makefile30
-rw-r--r--cad/ngspice_rework/distinfo4
-rw-r--r--cad/ngspice_rework/files/patch-configure.in23
-rw-r--r--cad/ngspice_rework/files/patch-doc:Makefile.in11
-rw-r--r--cad/ngspice_rework/files/patch-doc:ngspice.texi14
-rw-r--r--cad/ngspice_rework/files/patch-src__frontend__resource.c10
-rw-r--r--cad/ngspice_rework/files/patch-src__xspice__icm__Makefile14
-rw-r--r--cad/ngspice_rework/files/patch-src__xspice__ipc__ipcstdio.c11
-rw-r--r--cad/ngspice_rework/pkg-descr14
-rw-r--r--cad/ngspice_rework/pkg-plist152
10 files changed, 163 insertions, 120 deletions
diff --git a/cad/ngspice_rework/Makefile b/cad/ngspice_rework/Makefile
index e06ea9c9342e..1a573594e93b 100644
--- a/cad/ngspice_rework/Makefile
+++ b/cad/ngspice_rework/Makefile
@@ -1,33 +1,31 @@
-# New ports collection makefile for: ngspice_rework
-# Date created: 2002-01-02
-# Whom: AMAKAWA Shuhei <amakawa@jp.FreeBSD.org>
-#
+# Created by: AMAKAWA Shuhei <amakawa@jp.FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= ngspice_rework
-PORTVERSION= 18
-PORTREVISION= 1
+PORTVERSION= 25
CATEGORIES= cad
MASTER_SITES= SF/ngspice/ng-spice-rework/${PORTVERSION}
-DISTNAME= ng-spice-rework-${PORTVERSION}
+DISTNAME= ngspice-${PORTVERSION}
-MAINTAINER= amakawa@jp.FreeBSD.org
-COMMENT= A circuit simulator derived from spice3f5
+MAINTAINER= kevinz5000@gmail.com
+COMMENT= Mixed-signal circuit simulator derived from Spice and Cider
-USE_AUTOTOOLS= autoconf
+OPTIONS_DEFINE= DEBUG
+
+GNU_CONFIGURE= yes
USE_GMAKE= yes
-#XSPICE doesn't build
-#CONFIGURE_ARGS+= --enable-xspice
+.include <bsd.port.options.mk>
+
+CONFIGURE_ARGS+=--enable-xspice \
+ --with-readline=yes
-.ifndef PACKAGE_BUILDING
-CONFIGURE_ARGS+= --with-readline=yes
+.if ${PORT_OPTIONS:MDEBUG}
+CONFIGURE_ARGS+= --enable-debug
.else
CONFIGURE_ARGS+= --disable-debug
.endif
-INFO= ngspice
MAN1= ngspice.1 ngnutmeg.1 ngsconvert.1 ngmultidec.1
.include <bsd.port.mk>
diff --git a/cad/ngspice_rework/distinfo b/cad/ngspice_rework/distinfo
index c7b8e95615d3..528a48a112ce 100644
--- a/cad/ngspice_rework/distinfo
+++ b/cad/ngspice_rework/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ng-spice-rework-18.tar.gz) = 1ae8ff5db42a0ca89803faed17fca75836f7c4f8dc026530efabc57eb4956954
-SIZE (ng-spice-rework-18.tar.gz) = 7061554
+SHA256 (ngspice-25.tar.gz) = d000bbb978db846ff6df7ce327d8194abe046fdd5c93e7cba23c484137ef140e
+SIZE (ngspice-25.tar.gz) = 6729137
diff --git a/cad/ngspice_rework/files/patch-configure.in b/cad/ngspice_rework/files/patch-configure.in
deleted file mode 100644
index 48d342a79560..000000000000
--- a/cad/ngspice_rework/files/patch-configure.in
+++ /dev/null
@@ -1,23 +0,0 @@
---- configure.in.orig 2008-12-29 19:13:00.000000000 -0500
-+++ configure.in 2008-12-29 19:16:35.000000000 -0500
-@@ -205,16 +205,16 @@
- if test "$enable_debug" = "no"; then
- if test "x$GCC" = "xyes"; then
- AC_MSG_WARN(Removing debugging option!)
-- CFLAGS="$ext_CFLAGS -O2 -Wall -s"
-+ CFLAGS+="$ext_CFLAGS -O2 -Wall -s"
- else
- AC_MSG_WARN(Removing debugging option!)
-- CFLAGS="$ext_CFLAGS -O2"
-+ CFLAGS+="$ext_CFLAGS -O2"
- fi
- else
- if test "x$GCC" = "xyes"; then
-- CFLAGS="$ext_CFLAGS -g -O0 -Wall"
-+ CFLAGS+="$ext_CFLAGS -g -O0 -Wall"
- else
-- CFLAGS="$ext_CFLAGS -g"
-+ CFLAGS+="$ext_CFLAGS -g"
- fi
- fi
-
diff --git a/cad/ngspice_rework/files/patch-doc:Makefile.in b/cad/ngspice_rework/files/patch-doc:Makefile.in
deleted file mode 100644
index 61abb2dd8fab..000000000000
--- a/cad/ngspice_rework/files/patch-doc:Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- doc/Makefile.in.orig 2008-11-30 11:12:39.000000000 -0500
-+++ doc/Makefile.in 2008-12-29 15:41:25.000000000 -0500
-@@ -114,7 +114,7 @@
- LN_S = @LN_S@
- LTLIBOBJS = @LTLIBOBJS@
- MAINT = @MAINT@
--MAKEINFO = @MAKEINFO@
-+MAKEINFO = @MAKEINFO@ --no-split
- MKDIR_P = @MKDIR_P@
- NDEV_DIR = @NDEV_DIR@
- NDEV_LIB = @NDEV_LIB@
diff --git a/cad/ngspice_rework/files/patch-doc:ngspice.texi b/cad/ngspice_rework/files/patch-doc:ngspice.texi
deleted file mode 100644
index c3376442ce5b..000000000000
--- a/cad/ngspice_rework/files/patch-doc:ngspice.texi
+++ /dev/null
@@ -1,14 +0,0 @@
---- doc/ngspice.texi.orig Tue Aug 16 07:24:58 2005
-+++ doc/ngspice.texi Sat Dec 10 17:56:39 2005
-@@ -7,6 +7,11 @@
- @setchapternewpage odd
- @c %**end of header
-
-+@dircategory Utilities
-+@direntry
-+* NGSPICE: (ngspice). NGSPICE User Manual
-+@end direntry
-+
- @c Summary Description and Copyright
- @copying
- Copyright 1996 The Regents of the University of California.
diff --git a/cad/ngspice_rework/files/patch-src__frontend__resource.c b/cad/ngspice_rework/files/patch-src__frontend__resource.c
deleted file mode 100644
index fe7042666618..000000000000
--- a/cad/ngspice_rework/files/patch-src__frontend__resource.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/frontend/resource.c.orig 2008-11-19 14:45:28.000000000 -0500
-+++ src/frontend/resource.c 2008-12-29 15:44:52.000000000 -0500
-@@ -605,6 +605,7 @@
- fault(void)
- {
- signal(SIGSEGV, (SIGNAL_FUNCTION) fault); /* SysV style */
-+ signal(SIGBUS, (SIGNAL_FUNCTION) fault); /* SysV style */
- LONGJMP(env, 1);
- }
-
diff --git a/cad/ngspice_rework/files/patch-src__xspice__icm__Makefile b/cad/ngspice_rework/files/patch-src__xspice__icm__Makefile
deleted file mode 100644
index 1f39716c754f..000000000000
--- a/cad/ngspice_rework/files/patch-src__xspice__icm__Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/xspice/icm/Makefile.orig 2008-12-29 15:47:40.000000000 -0500
-+++ src/xspice/icm/Makefile 2008-12-29 15:48:36.000000000 -0500
-@@ -12,9 +12,9 @@
- -include .deps/cm.P
- -include .deps/dlmain.P
-
--UPMAKE = make -f $(TOPDIR)../Makefile TOPDIR=$(TOPDIR)../
-+UPMAKE = gmake -f $(TOPDIR)../Makefile TOPDIR=$(TOPDIR)../
-
--MAKE = make -f $(TOPDIR)Makefile TOPDIR=$(TOPDIR)
-+MAKE = gmake -f $(TOPDIR)Makefile TOPDIR=$(TOPDIR)
-
- COMPILE = $(CC) $(INCLUDES) $(CFLAGS)
-
diff --git a/cad/ngspice_rework/files/patch-src__xspice__ipc__ipcstdio.c b/cad/ngspice_rework/files/patch-src__xspice__ipc__ipcstdio.c
deleted file mode 100644
index 5a2faa22f502..000000000000
--- a/cad/ngspice_rework/files/patch-src__xspice__ipc__ipcstdio.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/xspice/ipc/ipcstdio.c.orig Mon Nov 19 15:13:29 2007
-+++ src/xspice/ipc/ipcstdio.c Mon Nov 19 15:18:42 2007
-@@ -40,7 +40,7 @@
- Ipc_Wait_t wait;
- {
- printf ("GET_LINE\n");
-- gets (str);
-+ fgets (str, sizeof str, stdin);
- *len = strlen (str);
- return IPC_STATUS_OK;
- }
diff --git a/cad/ngspice_rework/pkg-descr b/cad/ngspice_rework/pkg-descr
index 39c3745f82d4..514d51691ff7 100644
--- a/cad/ngspice_rework/pkg-descr
+++ b/cad/ngspice_rework/pkg-descr
@@ -1,9 +1,9 @@
- Ngspice is the name of a project and of a program in the project.
- Spice is the famous circuit simulator developed by the CAD Group of
- the University of California at Berkeley (UCB). The NG prefix has a
- lot of meanings: Next Generation, New Good, etc. Choose or invent the
- one you prefer. The ngspice project aims to improve the capabilities
- of the Spice3 circuit simulator. The heart of the project is the
- ngspice program, a circuit simulator derived from spice3f5.
+Ngspice is the name of a project and of a program in the project. Spice is
+the famous circuit simulator developed by the CAD Group of the University of
+California at Berkeley (UCB). The NG prefix has a lot of meanings: Next
+Generation, New Good, etc. Choose or invent the one you prefer. The ngspice
+project aims to improve the capabilities of the Spice3 circuit simulator. The
+heart of the project is the ngspice program, a circuit simulator derived from
+spice3f5.
WWW: http://ngspice.sourceforge.net/
diff --git a/cad/ngspice_rework/pkg-plist b/cad/ngspice_rework/pkg-plist
index a7d2257efbdd..c9f7ee0d0ea1 100644
--- a/cad/ngspice_rework/pkg-plist
+++ b/cad/ngspice_rework/pkg-plist
@@ -1,14 +1,142 @@
-bin/ngmakeidx
-bin/ngmultidec
+share/ngspice/include/ngspice/tclspice.h
+share/ngspice/include/ngspice/acdefs.h
+share/ngspice/include/ngspice/bdrydefs.h
+share/ngspice/include/ngspice/bool.h
+share/ngspice/include/ngspice/carddefs.h
+share/ngspice/include/ngspice/ciderinp.h
+share/ngspice/include/ngspice/cidersupt.h
+share/ngspice/include/ngspice/cktdefs.h
+share/ngspice/include/ngspice/cluster.h
+share/ngspice/include/ngspice/cmconstants.h
+share/ngspice/include/ngspice/cm.h
+share/ngspice/include/ngspice/cmproto.h
+share/ngspice/include/ngspice/cmtypes.h
+share/ngspice/include/ngspice/compatmode.h
+share/ngspice/include/ngspice/complex.h
+share/ngspice/include/ngspice/const.h
+share/ngspice/include/ngspice/contdefs.h
+share/ngspice/include/ngspice/cpdefs.h
+share/ngspice/include/ngspice/cpextern.h
+share/ngspice/include/ngspice/cpstd.h
+share/ngspice/include/ngspice/defines.h
+share/ngspice/include/ngspice/devdefs.h
+share/ngspice/include/ngspice/dgen.h
+share/ngspice/include/ngspice/distodef.h
+share/ngspice/include/ngspice/dllitf.h
+share/ngspice/include/ngspice/domndefs.h
+share/ngspice/include/ngspice/dopdefs.h
+share/ngspice/include/ngspice/dstring.h
+share/ngspice/include/ngspice/dvec.h
+share/ngspice/include/ngspice/elctdefs.h
+share/ngspice/include/ngspice/enh.h
+share/ngspice/include/ngspice/evt.h
+share/ngspice/include/ngspice/evtproto.h
+share/ngspice/include/ngspice/evtudn.h
+share/ngspice/include/ngspice/ftedbgra.h
+share/ngspice/include/ngspice/ftedebug.h
+share/ngspice/include/ngspice/ftedefs.h
+share/ngspice/include/ngspice/fteoptdefs.h
+share/ngspice/include/ngspice/ftedev.h
+share/ngspice/include/ngspice/fteext.h
+share/ngspice/include/ngspice/fteinp.h
+share/ngspice/include/ngspice/fteinput.h
+share/ngspice/include/ngspice/fteparse.h
+share/ngspice/include/ngspice/gendefs.h
+share/ngspice/include/ngspice/gendev.h
+share/ngspice/include/ngspice/graph.h
+share/ngspice/include/ngspice/grid.h
+share/ngspice/include/ngspice/hash.h
+share/ngspice/include/ngspice/hlpdefs.h
+share/ngspice/include/ngspice/iferrmsg.h
+share/ngspice/include/ngspice/ifsim.h
+share/ngspice/include/ngspice/inpdefs.h
+share/ngspice/include/ngspice/inpmacs.h
+share/ngspice/include/ngspice/inpptree.h
+share/ngspice/include/ngspice/ipc.h
+share/ngspice/include/ngspice/ipcproto.h
+share/ngspice/include/ngspice/ipctiein.h
+share/ngspice/include/ngspice/jobdefs.h
+share/ngspice/include/ngspice/lsort.h
+share/ngspice/include/ngspice/macros.h
+share/ngspice/include/ngspice/material.h
+share/ngspice/include/ngspice/matldefs.h
+share/ngspice/include/ngspice/memory.h
+share/ngspice/include/ngspice/meshdefs.h
+share/ngspice/include/ngspice/meshext.h
+share/ngspice/include/ngspice/methdefs.h
+share/ngspice/include/ngspice/mifcmdat.h
+share/ngspice/include/ngspice/mifdefs.h
+share/ngspice/include/ngspice/mif.h
+share/ngspice/include/ngspice/mifparse.h
+share/ngspice/include/ngspice/mifproto.h
+share/ngspice/include/ngspice/miftypes.h
+share/ngspice/include/ngspice/missing_math.h
+share/ngspice/include/ngspice/mobdefs.h
+share/ngspice/include/ngspice/modldefs.h
+share/ngspice/include/ngspice/multi_line.h
+share/ngspice/include/ngspice/ngspice.h
+share/ngspice/include/ngspice/noisedef.h
+share/ngspice/include/ngspice/numcards.h
+share/ngspice/include/ngspice/numconst.h
+share/ngspice/include/ngspice/numenum.h
+share/ngspice/include/ngspice/numgen.h
+share/ngspice/include/ngspice/numglobs.h
+share/ngspice/include/ngspice/onedev.h
+share/ngspice/include/ngspice/onemesh.h
+share/ngspice/include/ngspice/opdefs.h
+share/ngspice/include/ngspice/optdefs.h
+share/ngspice/include/ngspice/optndefs.h
+share/ngspice/include/ngspice/outpdefs.h
+share/ngspice/include/ngspice/plot.h
+share/ngspice/include/ngspice/pnode.h
+share/ngspice/include/ngspice/profile.h
+share/ngspice/include/ngspice/pssdefs.h
+share/ngspice/include/ngspice/pzdefs.h
+share/ngspice/include/ngspice/sen2defs.h
+share/ngspice/include/ngspice/sensdefs.h
+share/ngspice/include/ngspice/sensgen.h
+share/ngspice/include/ngspice/sim.h
+share/ngspice/include/ngspice/smpdefs.h
+share/ngspice/include/ngspice/sperror.h
+share/ngspice/include/ngspice/spmatrix.h
+share/ngspice/include/ngspice/stringutil.h
+share/ngspice/include/ngspice/suffix.h
+share/ngspice/include/ngspice/swec.h
+share/ngspice/include/ngspice/tfdefs.h
+share/ngspice/include/ngspice/trandefs.h
+share/ngspice/include/ngspice/trcvdefs.h
+share/ngspice/include/ngspice/tskdefs.h
+share/ngspice/include/ngspice/twodev.h
+share/ngspice/include/ngspice/twomesh.h
+share/ngspice/include/ngspice/typedefs.h
+share/ngspice/include/ngspice/wordlist.h
+share/ngspice/include/ngspice/1-f-code.h
+share/ngspice/include/ngspice/FastNorm3.h
+share/ngspice/include/ngspice/fftext.h
+share/ngspice/include/ngspice/wallace.h
+share/ngspice/include/ngspice/wstdio.h
+share/ngspice/include/ngspice/config.h
+share/ngspice/dlmain.c
+share/ngspice/helpdir/ngspice.txt
+share/ngspice/helpdir/ngspice.idx
+share/ngspice/scripts/spinit
+share/ngspice/scripts/setplot
+share/ngspice/scripts/spectrum
+bin/cmpp
+bin/ngspice
bin/ngnutmeg
-bin/ngproc2mod
bin/ngsconvert
-bin/ngspice
-share/ng-spice-rework/helpdir/ngspice.idx
-share/ng-spice-rework/helpdir/ngspice.txt
-share/ng-spice-rework/scripts/setplot
-share/ng-spice-rework/scripts/spectrum
-share/ng-spice-rework/scripts/spinit
-@dirrm share/ng-spice-rework/helpdir
-@dirrm share/ng-spice-rework/scripts
-@dirrm share/ng-spice-rework
+bin/ngproc2mod
+bin/ngmultidec
+bin/ngmakeidx
+lib/ngspice/spice2poly.cm
+lib/ngspice/digital.cm
+lib/ngspice/analog.cm
+lib/ngspice/xtradev.cm
+lib/ngspice/xtraevt.cm
+@dirrm lib/ngspice
+@dirrm share/ngspice/scripts
+@dirrm share/ngspice/helpdir
+@dirrm share/ngspice/include/ngspice
+@dirrm share/ngspice/include
+@dirrm share/ngspice