aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--science/py-scipy/Makefile4
-rw-r--r--science/py-scipy03/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/science/py-scipy/Makefile b/science/py-scipy/Makefile
index 4be02f380c31..88fe0aca95df 100644
--- a/science/py-scipy/Makefile
+++ b/science/py-scipy/Makefile
@@ -34,6 +34,10 @@ post-patch:
.include <bsd.port.pre.mk>
+.if !exists(${LOCALBASE}/lib/libalapack.a)
+IGNORE= Atlas needs to be built with WITH_STATICLIB for scipy to function properly
+.endif
+
post-install:
@${RMDIR} ${PYTHON_SITELIBDIR}/weave/swig # empty
.for dir in ${PYTHON_SITELIBDIR}/gui_thread ${PYTHON_SITELIBDIR}/scipy \
diff --git a/science/py-scipy03/Makefile b/science/py-scipy03/Makefile
index 4be02f380c31..88fe0aca95df 100644
--- a/science/py-scipy03/Makefile
+++ b/science/py-scipy03/Makefile
@@ -34,6 +34,10 @@ post-patch:
.include <bsd.port.pre.mk>
+.if !exists(${LOCALBASE}/lib/libalapack.a)
+IGNORE= Atlas needs to be built with WITH_STATICLIB for scipy to function properly
+.endif
+
post-install:
@${RMDIR} ${PYTHON_SITELIBDIR}/weave/swig # empty
.for dir in ${PYTHON_SITELIBDIR}/gui_thread ${PYTHON_SITELIBDIR}/scipy \