aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/opera-devel/Makefile26
-rw-r--r--www/opera-devel/distinfo2
-rw-r--r--www/opera-devel/files/patch-install.sh65
-rw-r--r--www/opera-devel/pkg-message9
-rw-r--r--www/opera-devel/pkg-plist7
5 files changed, 76 insertions, 33 deletions
diff --git a/www/opera-devel/Makefile b/www/opera-devel/Makefile
index 94190f0d9528..ab39cb12f16c 100644
--- a/www/opera-devel/Makefile
+++ b/www/opera-devel/Makefile
@@ -6,27 +6,25 @@
#
PORTNAME= opera
-PORTVERSION= 7.23.20031119
+PORTVERSION= ${OPERA_VER}.${OPERA_DATE}
CATEGORIES= www
-MASTER_SITES= ftp://ftp.sunet.se/pub/www/clients/Opera/unix/freebsd/723/final/en/ \
- ftp://sunsite.cnlab-switch.ch/mirror/opera/unix/freebsd/723/final/en/ \
- ftp://ftp.tiscali.nl/pub/mirrors/opera/unix/freebsd/723/final/en/ \
- ftp://ftp.ntua.gr/pub/www/Opera/unix/freebsd/723/final/en/ \
- http://mirrors.pmmf.hu/mirror/opera/unix/freebsd/723/final/en/ \
- ftp://ftp.task.gda.pl/pub/opera/unix/freebsd/723/final/en/ \
- ftp://ftp.planetmirror.com/pub/opera/unix/freebsd/723/final/en/ \
- http://gd.tuwien.ac.at/infosys/browsers/opera/unix/freebsd/723/final/en/ \
- ftp://ftp.opera.com/pub/opera/unix/freebsd/723/final/en/
-
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/3./3-/}.1-static-qt.i386.freebsd-en
+MASTER_SITES= http://snapshot.opera.com/unix/${OPERA_VER}-Preview-1/intel-freebsd/en/
+PKGNAMESUFFIX= -devel
+DISTNAME= ${PORTNAME}-${OPERA_VER}-${OPERA_DATE}.1-static-qt.i386.freebsd-en
MAINTAINER= avleeuwen@piwebs.com
COMMENT= A blazingly fast, full-featured, standards-compliant browser
-CONFLICTS= linux-opera-*
-
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+OPERA_VER= 7.50
+OPERA_DATE= 20031219
+
+CONFLICTS= linux-opera-devel-*
+
+DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
diff --git a/www/opera-devel/distinfo b/www/opera-devel/distinfo
index 0fdd9095ea88..2ce2781adcb8 100644
--- a/www/opera-devel/distinfo
+++ b/www/opera-devel/distinfo
@@ -1 +1 @@
-MD5 (opera-7.23-20031119.1-static-qt.i386.freebsd-en.tar.bz2) = cb838b40b70e42481ee0c159539d10c7
+MD5 (opera-7.50-20031219.1-static-qt.i386.freebsd-en.tar.bz2) = 6b47e5bc28d863b18c7a43487ea7d62c
diff --git a/www/opera-devel/files/patch-install.sh b/www/opera-devel/files/patch-install.sh
index 48cee1317bcc..71a9c6efb7b5 100644
--- a/www/opera-devel/files/patch-install.sh
+++ b/www/opera-devel/files/patch-install.sh
@@ -1,8 +1,22 @@
---- install.sh.orig Mon Oct 6 15:01:39 2003
-+++ install.sh Wed Oct 8 22:36:31 2003
-@@ -760,9 +760,7 @@
+--- install.sh.orig Fri Dec 19 14:45:42 2003
++++ install.sh Wed Dec 31 14:59:00 2003
+@@ -108,8 +108,8 @@
- wrapper_opera_plugin_paths=" \"\${HOME}/.opera/plugins\" \\
+ if test ${os} = 'FreeBSD' -o ${os} = 'OpenBSD'; then
+ wrapper_dir="${prefix}/bin"
+- doc_dir="${prefix}/share/doc/opera"
+- share_dir="${prefix}/share/opera"
++ doc_dir="${prefix}/share/doc/opera-devel"
++ share_dir="${prefix}/share/opera-devel"
+ exec_dir="${share_dir}/bin"
+ plugin_dir="${share_dir}/plugins"
+ else
+@@ -758,11 +758,9 @@
+
+ debug_msg 0 "in generate_wrapper()"
+
+- wrapper_opera_plugin_paths=" \"\${HOME}/.opera/plugins\" \\
++ wrapper_opera_plugin_paths=" \"\${HOME}/.opera-devel/plugins\" \\
${str_localdirplugin} \\
- /usr/lib/opera/plugins \\
- /usr/local/lib/opera/plugins \\
@@ -11,7 +25,7 @@
case "${machine}:${os}" in
i[3456]86:Linux|i[3456]86:FreeBSD|i[3456]86:NetBSD|i[3456]86:OpenBSD)
-@@ -817,15 +815,10 @@
+@@ -817,17 +815,12 @@
;;
esac
wrapper_netscape_plugin_paths="
@@ -28,9 +42,27 @@
- /usr/local/lib/netscape/plugins \\"
+ /usr/local/lib/netscape-linux/plugins \\"
- wrapper_file="${wrapper_dir}/opera"
+- wrapper_file="${wrapper_dir}/opera"
++ wrapper_file="${wrapper_dir}/opera-devel"
-@@ -981,11 +974,8 @@
+ wrapper_contain="#!/bin/sh
+
+@@ -871,9 +864,12 @@
+ OPERA_LD_PRELOAD=\"\${LD_PRELOAD}\"
+ export OPERA_LD_PRELOAD
+
++OPERA_PERSONALDIR=\${HOME}/.opera-devel
++export OPERA_PERSONALDIR
++
+ # Native Java enviroment
+-if test -f \"\${HOME}/.opera/javapath.txt\"; then
+- INIJAVA=\`cat \${HOME}/.opera/javapath.txt\`
++if test -f \"\${HOME}/.opera-devel/javapath.txt\"; then
++ INIJAVA=\`cat \${HOME}/.opera-devel/javapath.txt\`
+ if test -f \"\${INIJAVA}/libjava.so\"; then OPERA_JAVA_DIR=\"\${INIJAVA}\"; fi
+ fi
+
+@@ -983,11 +979,8 @@
# Acrobat Reader
for BINDIR in \\
@@ -44,7 +76,16 @@
; do
if test -d \${BINDIR} ; then PATH=\${PATH}:\${BINDIR}; fi
done
-@@ -1243,29 +1233,6 @@
+@@ -1115,7 +1108,7 @@
+
+ #cp $cpv $cpf wrapper.sh $wrapper_dir/opera
+ generate_wrapper
+- chmod $chmodv 755 $wrapper_dir/opera
++ chmod $chmodv 755 $wrapper_file
+
+ # Documentation
+ debug_msg 1 "Documentation"
+@@ -1248,29 +1241,6 @@
if test -z "${OPERADESTDIR}"; then
@@ -74,7 +115,7 @@
# Shorcuts and Icons
icons
gnome
-@@ -1356,22 +1323,22 @@
+@@ -1361,22 +1331,22 @@
debug_msg 0 "in icons()"
@@ -109,7 +150,7 @@
fi
if test ! -d /etc/X11/wmconfig/; then
-@@ -1437,33 +1404,33 @@
+@@ -1442,33 +1412,33 @@
fi
# end /opt/gnome share
@@ -164,7 +205,7 @@
fi
fi
# end /usr/share/gnome link
-@@ -1503,12 +1470,12 @@
+@@ -1508,12 +1478,12 @@
fi
@@ -182,7 +223,7 @@
fi
}
-@@ -1532,8 +1499,8 @@
+@@ -1537,8 +1507,8 @@
fi
if test -w /opt/kde/share/applnk/Internet; then generate_desktop /opt/kde/share/applnk/Internet; fi
diff --git a/www/opera-devel/pkg-message b/www/opera-devel/pkg-message
index e7596af789c9..5a34086ac40d 100644
--- a/www/opera-devel/pkg-message
+++ b/www/opera-devel/pkg-message
@@ -1,8 +1,9 @@
-If you are upgrading from version 6, it is recommended to backup your personal
-"~/.opera" directory and remove it before starting the upgraded Opera for the
-first time. This can be done from the command line using
-"mv ~/.opera ~/.opera-mybackup".
+This port will use the ~/.opera-devel directory to save its personal settings.
If you are running FreeBSD 5.x and are experiencing a core dump when starting
Opera, try updating the compat4x port.
+
+*** THIS IS AN UNSTABLE PREVIEW VERSION OF OPERA. PLEASE DO NOT REPORT ***
+*** BUGS TO THE PORT MAINTAINER. ***
+
diff --git a/www/opera-devel/pkg-plist b/www/opera-devel/pkg-plist
index 539d68c1af82..70ecd980d1f6 100644
--- a/www/opera-devel/pkg-plist
+++ b/www/opera-devel/pkg-plist
@@ -1,4 +1,4 @@
-bin/opera
+bin/opera-devel
%%DOCSDIR%%/LICENSE
%%DOCSDIR%%/help
%%DATADIR%%/bin/m2.so
@@ -10,6 +10,7 @@ bin/opera
%%DATADIR%%/config/opera6rc.fixed
%%DATADIR%%/help/advertising.html
%%DATADIR%%/help/background.png
+%%DATADIR%%/help/chat.html
%%DATADIR%%/help/dialogs.html
%%DATADIR%%/help/filetypes.html
%%DATADIR%%/help/fonts.html
@@ -30,6 +31,7 @@ bin/opera
%%DATADIR%%/help/multimedia.html
%%DATADIR%%/help/network.html
%%DATADIR%%/help/page.html
+%%DATADIR%%/help/panels.html
%%DATADIR%%/help/paths.html
%%DATADIR%%/help/personal.html
%%DATADIR%%/help/preferences.html
@@ -60,7 +62,7 @@ bin/opera
%%DATADIR%%/images/startup2.png
%%DATADIR%%/ini/dialog.ini
%%DATADIR%%/ini/fastforward.ini
-%%DATADIR%%/ini/minimal_toolbar.ini
+%%DATADIR%%/ini/pluginpath.ini
%%DATADIR%%/ini/standard_keyboard.ini
%%DATADIR%%/ini/standard_menu.ini
%%DATADIR%%/ini/standard_mouse.ini
@@ -72,6 +74,7 @@ bin/opera
%%DATADIR%%/lngcode.txt
%%DATADIR%%/locale/english.lng
%%DATADIR%%/locale/en/default.adr
+%%DATADIR%%/locale/en/lngcode.txt
%%DATADIR%%/locale/en/search.ini
%%DATADIR%%/opera6.adr
%%DATADIR%%/plugins/libnpp.so