aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/mjpegtools/Makefile2
-rw-r--r--multimedia/mkvtoolnix/Makefile2
-rw-r--r--multimedia/tovid/Makefile1
-rw-r--r--multimedia/vcdimager/Makefile3
4 files changed, 5 insertions, 3 deletions
diff --git a/multimedia/mjpegtools/Makefile b/multimedia/mjpegtools/Makefile
index 7b61ff9e720b..cb0d6f2b3768 100644
--- a/multimedia/mjpegtools/Makefile
+++ b/multimedia/mjpegtools/Makefile
@@ -18,7 +18,7 @@ QUICKTIME_DESC= Enable libQuickTime support
CONFLICTS= mplex-[0-9]*
-USE_PKGCONFIG= build
+USES= pkgconfig
USE_GMAKE= yes
USE_AUTOTOOLS= libtoolize aclocal autoheader automake autoconf
LIBTOOLIZE_ARGS=--force
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
index 79653fdd0b44..ea0432a33f46 100644
--- a/multimedia/mkvtoolnix/Makefile
+++ b/multimedia/mkvtoolnix/Makefile
@@ -24,6 +24,7 @@ LIB_DEPENDS= FLAC:${PORTSDIR}/audio/flac \
ebml:${PORTSDIR}/textproc/libebml \
matroska:${PORTSDIR}/multimedia/libmatroska
+USES= pkgconfig
USE_BZIP2= yes
USE_GCC= 4.6+
USE_GETTEXT= yes
@@ -31,7 +32,6 @@ USE_ICONV= yes
GNU_CONFIGURE= yes
USE_RAKE= yes
USE_RUBY= yes
-USE_PKGCONFIG= build
RUBY_NO_RUN_DEPENDS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/multimedia/tovid/Makefile b/multimedia/tovid/Makefile
index ed2b534ba5d4..cfeb23b473a3 100644
--- a/multimedia/tovid/Makefile
+++ b/multimedia/tovid/Makefile
@@ -34,6 +34,7 @@ RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer \
bash:${PORTSDIR}/shells/bash \
${PYTHON_SITELIBDIR}/cairo/__init__.py:${PORTSDIR}/graphics/py-cairo
+USES= pkgconfig
USE_WX= 2.6
WX_COMPS= python
NO_BUILD= yes
diff --git a/multimedia/vcdimager/Makefile b/multimedia/vcdimager/Makefile
index 062c808d9216..7bd770112626 100644
--- a/multimedia/vcdimager/Makefile
+++ b/multimedia/vcdimager/Makefile
@@ -17,12 +17,13 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
xml2:${PORTSDIR}/textproc/libxml2 \
cdio.13:${PORTSDIR}/sysutils/libcdio
+USES= pkgconfig pathfix
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
USE_PKGCONFIG= build
-USE_GNOME= gnomehack lthack
+USE_GNOME= lthack
CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib