aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/py-google/Makefile21
-rw-r--r--www/py-google/distinfo2
-rw-r--r--www/py-google/pkg-descr3
4 files changed, 27 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 5b0679232d3c..81e5b5e30f0d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1600,6 +1600,7 @@
SUBDIR += py-funkload
SUBDIR += py-gandi.cli
SUBDIR += py-gevent-websocket
+ SUBDIR += py-google
SUBDIR += py-google-api-python-client
SUBDIR += py-graphite-web
SUBDIR += py-grequests
diff --git a/www/py-google/Makefile b/www/py-google/Makefile
new file mode 100644
index 000000000000..d97baaea5857
--- /dev/null
+++ b/www/py-google/Makefile
@@ -0,0 +1,21 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= google
+PORTVERSION= 1.7
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Python bindings to the Google search engine
+
+LICENSE= BSD2CLAUSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4:${PORTSDIR}/www/py-beautifulsoup
+
+USES= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-google/distinfo b/www/py-google/distinfo
new file mode 100644
index 000000000000..fc7cd30076c6
--- /dev/null
+++ b/www/py-google/distinfo
@@ -0,0 +1,2 @@
+SHA256 (google-1.7.tar.gz) = d6e25f5d55b5205d84564452d459ce815924ffaf19ef077188e274959aa7df64
+SIZE (google-1.7.tar.gz) = 6127
diff --git a/www/py-google/pkg-descr b/www/py-google/pkg-descr
new file mode 100644
index 000000000000..114597a3024c
--- /dev/null
+++ b/www/py-google/pkg-descr
@@ -0,0 +1,3 @@
+Google search from Python.
+
+WWW: https://breakingcode.wordpress.com/