aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--comms/hylafax/Makefile13
-rw-r--r--graphics/jasper/Makefile13
2 files changed, 14 insertions, 12 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index fb34ea88ffa7..d702b518c3f7 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -57,9 +57,10 @@ MAN8= choptest.8c cqtest.8c dialtest.8c faxabort.8c faxaddmodem.8c \
SUID_EXES= ${PREFIX}/sbin/faxgetty ${PREFIX}/sbin/faxq \
${PREFIX}/bin/faxrm ${PREFIX}/bin/faxalter
-OPTIONS= PAM "Include pam support" ON \
- NLS "Native Language Support" ON \
- GAWK "Use gawk for scripts" OFF \
+OPTIONS_DEFINE= PAM NLS GAWK
+OPTIONS_DEFAULT=PAM NLS
+NO_OPTIONS_SORT=yes
+GAWK_DESC= Use gawk for scripts
.include <bsd.port.pre.mk>
@@ -69,7 +70,7 @@ CONFIGURE_ARGS+=--with-PAGESIZE="${PAGESIZE}"
.endif
# Want PAM?
-.if defined(WITHOUT_PAM)
+.if empty(PORT_OPTIONS:MPAM)
CONFIGURE_ARGS+=--disable-pam
.endif
@@ -92,12 +93,12 @@ PLIST_SUB+= HYLAFAX_SPOOL=${HYLAFAX_SPOOL}
CONFIGURE_ARGS+=--nointeractive
.endif
-.if defined(WITH_GAWK)
+.if ${PORT_OPTIONS:MGAWK}
BUILD_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
RUN_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
CONFIGURE_ARGS+=--with-AWK="${LOCALBASE}/bin/gawk"
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= WITH_NLS=""
.else
diff --git a/graphics/jasper/Makefile b/graphics/jasper/Makefile
index 5b08fa263935..a5d8db1f4a42 100644
--- a/graphics/jasper/Makefile
+++ b/graphics/jasper/Makefile
@@ -34,12 +34,13 @@ MASTER_SITE_IMAGEMAGICK= \
ftp://ftp.imagemagick.org/pub/%SUBDIR%/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/&,}
-OPTIONS= OPENGL "OpenGL support" off \
- UUID "UUID support (required by GDAL)" off
+OPTIONS_DEFINE= OPENGL UUID
+OPTIONS_DEFAULT=
+UUID_DESC= UUID support (required by GDAL)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_OPENGL)
+.if ${PORT_OPTIONS:MOPENGL}
USE_GL= glut
CONFIGURE_ARGS+=--enable-opengl
PLIST_SUB+= OPENGL=""
@@ -48,7 +49,7 @@ CONFIGURE_ARGS+=--disable-opengl
PLIST_SUB+= OPENGL="@comment "
.endif
-.if defined(WITH_UUID)
+.if ${PORT_OPTIONS:MUUID}
EXTRA_PATCHES+= ${FILESDIR}/uuid.patch
.endif
@@ -65,4 +66,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>