aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/pear-apd/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/devel/pear-apd/Makefile b/devel/pear-apd/Makefile
index d451a59b9039..5530ef9730a6 100644
--- a/devel/pear-apd/Makefile
+++ b/devel/pear-apd/Makefile
@@ -16,12 +16,10 @@ COMMENT= A full-featured engine-level PHP profiler/debugger
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${BUILD_DEPENDS}
-BROKEN= Does not compile
-
USE_PHP= yes
USE_PHPIZE= yes
-CONFIGURE_ARGS= --enable-apd
+CONFIGURE_ARGS= --enable-apd --with-apd
DUMP_DIR?= /var/tmp/apd
@@ -47,6 +45,11 @@ SUB_LIST= PHP_EXT_DIR=${PHP_EXT_DIR} DUMP_DIR=${DUMP_DIR} DEBUG=${PHP_DEBUG:S/-/
post-extract:
@${CHMOD} -R u+w ${WRKSRC}
+post-patch:
+.if ${PHP_VER} == 5
+ @${REINPLACE_CMD} -e '396,398 d' ${WRKSRC}/php_apd.c
+.endif
+
post-install-script:
@${STRIP_CMD} ${PHP_BASE}/lib/php/${PHP_EXT_DIR}/apd.so
@${MKDIR} ${DUMP_DIR}