aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/rt36/Makefile38
-rw-r--r--www/rt36/distinfo12
-rw-r--r--www/rt36/pkg-plist4
3 files changed, 26 insertions, 28 deletions
diff --git a/www/rt36/Makefile b/www/rt36/Makefile
index ed9c7aa999c2..8b6482a4325a 100644
--- a/www/rt36/Makefile
+++ b/www/rt36/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= rt
-PORTVERSION?= 3.6.3
-PORTREVISION= 1
+PORTVERSION?= 3.6.4
+#PORTREVISION= 0
CATEGORIES= www
MASTER_SITES?= http://download.bestpractical.com/pub/rt/release/ \
http://download.bestpractical.com/pub/rt/devel/ \
@@ -29,22 +29,17 @@ PERL_MODULES = ${APXS}:${PORTSDIR}/${APACHE_PORT} \
${SITE_PERL}/HTML/FormatText.pm:${PORTSDIR}/textproc/p5-HTML-Format \
${SITE_PERL}/HTML/Scrubber.pm:${PORTSDIR}/www/p5-HTML-Scrubber \
${SITE_PERL}/HTML/TreeBuilder.pm:${PORTSDIR}/www/p5-HTML-Tree \
- ${SITE_PERL}/HTTP/Server/Simple/Mason.pm:${PORTSDIR}/www/p5-HTTP-Server-Simple-Mason \
${SITE_PERL}/Locale/Maketext.pm:${PORTSDIR}/devel/p5-Locale-Maketext \
${SITE_PERL}/Locale/Maketext/Fuzzy.pm:${PORTSDIR}/devel/p5-Locale-Maketext-Fuzzy \
${SITE_PERL}/Locale/Maketext/Lexicon.pm:${PORTSDIR}/devel/p5-Locale-Maketext-Lexicon \
${SITE_PERL}/Log/Dispatch.pm:${PORTSDIR}/devel/p5-Log-Dispatch \
${SITE_PERL}/Mail/Mailer.pm:${PORTSDIR}/mail/p5-Mail-Tools \
${SITE_PERL}/MIME/Entity.pm:${PORTSDIR}/mail/p5-MIME-Tools \
- ${SITE_PERL}/Module/Refresh.pm:${PORTSDIR}/devel/p5-Module-Refresh \
${SITE_PERL}/Module/Versions/Report.pm:${PORTSDIR}/devel/p5-Module-Versions-Report \
- ${SITE_PERL}/MLDBM.pm:${PORTSDIR}/databases/p5-MLDBM \
${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
${SITE_PERL}/Regexp/Common.pm:${PORTSDIR}/textproc/p5-Regexp-Common \
${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
- ${SITE_PERL}/Test/WWW/Mechanize.pm:${PORTSDIR}/devel/p5-Test-WWW-Mechanize \
- ${SITE_PERL}/Test/Expect.pm:${PORTSDIR}/devel/p5-Test-Expect \
${SITE_PERL}/Text/Autoformat.pm:${PORTSDIR}/textproc/p5-Text-Autoformat \
${SITE_PERL}/Text/Quoted.pm:${PORTSDIR}/textproc/p5-Text-Quoted \
${SITE_PERL}/Text/Template.pm:${PORTSDIR}/textproc/p5-Text-Template \
@@ -53,18 +48,14 @@ PERL_MODULES = ${APXS}:${PORTSDIR}/${APACHE_PORT} \
${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
${SITE_PERL}/Time/ParseDate.pm:${PORTSDIR}/devel/p5-Time-modules \
${SITE_PERL}/Tree/Simple.pm:${PORTSDIR}/devel/p5-Tree-Simple \
- ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize \
${SITE_PERL}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS \
- ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
${SITE_PERL}/GD/Text.pm:${PORTSDIR}/graphics/p5-GD-TextUtil \
${SITE_PERL}/Calendar/Simple.pm:${PORTSDIR}/devel/p5-Calendar-Simple \
${SITE_PERL}/Date/Format.pm:${PORTSDIR}/devel/p5-TimeDate \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-require
-BUILD_DEPENDS+= ${PERL_MODULES}
-RUN_DEPENDS+= ${PERL_MODULES}
-
LATEST_LINK= rt36
HAS_CONFIGURE= yes
NO_BUILD= yes
@@ -90,21 +81,21 @@ CONFIGURE_ARGS= --prefix=${RT_PATH} \
.if defined(WITH_FASTCGI)
.if defined(WITH_APACHE2)
-BUILD_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi
+PERL_MODULES+= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi
.else
-BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi
+PERL_MODULES+= ${LOCALBASE}/libexec/apache/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi
.endif
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/FCGI.pm:${PORTSDIR}/www/p5-FastCGI
+PERL_MODULES+= ${SITE_PERL}/${PERL_ARCH}/FCGI.pm:${PORTSDIR}/www/p5-FastCGI
DEPENDS_ARGS+= WITHOUT_MODPERL=yes
.else
-BUILD_DEPENDS+= ${SITE_PERL}/Apache/DBI.pm:${PORTSDIR}/www/p5-Apache-DBI
+PERL_MODULES+= ${SITE_PERL}/Apache/DBI.pm:${PORTSDIR}/www/p5-Apache-DBI
.if defined(WITH_APACHE2)
-BUILD_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_perl.so:${PORTSDIR}/www/mod_perl2
+PERL_MODULES+= ${LOCALBASE}/${APACHEMODDIR}/mod_perl.so:${PORTSDIR}/www/mod_perl2
DEPENDS_ARGS+= WITHOUT_MODPERL=yes
DEPENDS_ARGS+= WITH_MODPERL2=yes
.else
# XXX - probe for static mod_perl using `httpd -l | grep perl`
-BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl \
+PERL_MODULES+= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl \
${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq
.endif
.endif
@@ -115,20 +106,23 @@ EXTRA_PATCHES+= ${FILESDIR}/multiple*
DB_TYPE?= mysql
.if ${DB_TYPE} == "Oracle"
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Oracle.pm:${PORTSDIR}/databases/p5-DBD-Oracle
+PERL_MODULES+= ${SITE_PERL}/${PERL_ARCH}/DBD/Oracle.pm:${PORTSDIR}/databases/p5-DBD-Oracle
.else
.if ${DB_TYPE} == "Pg"
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+PERL_MODULES+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
.else
.if ${DB_TYPE} == "SQLite"
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite
+PERL_MODULES+= ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite
.else
DB_TYPE= mysql
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+PERL_MODULES+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
.endif
.endif
.endif
+BUILD_DEPENDS+= ${PERL_MODULES}
+RUN_DEPENDS+= ${PERL_MODULES}
+
USE_PERL5= yes
RT_PATH?= ${PREFIX}/rt3
PLIST_SUB= RT_PATH=${RT_PATH} RTPLIST=${RT_PATH:S/^${PREFIX}\///}
diff --git a/www/rt36/distinfo b/www/rt36/distinfo
index 0c4bef34f539..7d8341682b6b 100644
--- a/www/rt36/distinfo
+++ b/www/rt36/distinfo
@@ -1,6 +1,6 @@
-MD5 (rt-3.6.3.tar.gz) = d6b2fa930441f16b6530aa00665eb8c7
-SHA256 (rt-3.6.3.tar.gz) = fc29f1fd95b3cd4813e3fbdef1882e8cd6c4516c66b3e78237272bdd200a1a67
-SIZE (rt-3.6.3.tar.gz) = 1602818
-MD5 (rt-3.6.3.tar.gz.sig) = 63bc8bd88d3edf384c6d42558ae79b87
-SHA256 (rt-3.6.3.tar.gz.sig) = a30b40b7e4939b7eee9503144a062d97a019da5cd8730c90e5e4b7711c009bf1
-SIZE (rt-3.6.3.tar.gz.sig) = 64
+MD5 (rt-3.6.4.tar.gz) = b7a42c308a07b1f7a496d4d816bb87cc
+SHA256 (rt-3.6.4.tar.gz) = c26b3f261639d5237d1f89d986dee3517f4a1aa32523f670aed9b66cf0fc52d6
+SIZE (rt-3.6.4.tar.gz) = 1689581
+MD5 (rt-3.6.4.tar.gz.sig) = 74bf36584c34db8cd4c0b5425ccba92e
+SHA256 (rt-3.6.4.tar.gz.sig) = 2f321e5b27ed5a685a0bf8772118958ca062db202c42cfcc62d7e052c6cc822b
+SIZE (rt-3.6.4.tar.gz.sig) = 65
diff --git a/www/rt36/pkg-plist b/www/rt36/pkg-plist
index bd97a4edc7a4..6d7f882627dc 100644
--- a/www/rt36/pkg-plist
+++ b/www/rt36/pkg-plist
@@ -105,6 +105,8 @@
%%RTPLIST%%/lib/RT/I18N/pl.po
%%RTPLIST%%/lib/RT/I18N/pt_br.po
%%RTPLIST%%/lib/RT/I18N/ru.po
+%%RTPLIST%%/lib/RT/I18N/sv.po
+%%RTPLIST%%/lib/RT/I18N/tr.po
%%RTPLIST%%/lib/RT/I18N/zh_cn.po
%%RTPLIST%%/lib/RT/I18N/zh_tw.po
%%RTPLIST%%/lib/RT/Interface/CLI.pm
@@ -512,6 +514,7 @@
%%RTPLIST%%/share/html/REST/1.0/Forms/ticket/links
%%RTPLIST%%/share/html/REST/1.0/Forms/ticket/merge
%%RTPLIST%%/share/html/REST/1.0/Forms/ticket/take
+%%RTPLIST%%/share/html/REST/1.0/Forms/transaction/default
%%RTPLIST%%/share/html/REST/1.0/Forms/user/default
%%RTPLIST%%/share/html/REST/1.0/Forms/user/ns
%%RTPLIST%%/share/html/REST/1.0/NoAuth/mail-gateway
@@ -655,6 +658,7 @@
@dirrm %%RTPLIST%%/share/html/REST/1.0/search
@dirrm %%RTPLIST%%/share/html/REST/1.0/NoAuth
@dirrm %%RTPLIST%%/share/html/REST/1.0/Forms/user
+@dirrm %%RTPLIST%%/share/html/REST/1.0/Forms/transaction
@dirrm %%RTPLIST%%/share/html/REST/1.0/Forms/ticket
@dirrm %%RTPLIST%%/share/html/REST/1.0/Forms/queue
@dirrm %%RTPLIST%%/share/html/REST/1.0/Forms
ome/commit/polish?h=gstreamer&id=530706893f31269bbfa303e069f2e76cbbe2fce7'>- update png to 1.5.10dinoex2012-06-017-6/+7 * - Remove koffice-i18n ports, as they are not very useful withoutavilla2012-05-315-64/+0 * The KDE/FreeBSD team is pleased to announce Calligra Suite 2.4.2, KDEavilla2012-05-319-96/+48 * - Update to 20120527sunpoet2012-05-292-3/+3 * KDE/FreeBSD team presents long awaited KDE SC 4.8.3!makc2012-05-254-16/+36 * Explicitly depend on phonon.rakuco2012-05-221-1/+2 * - Update to 20120520sunpoet2012-05-212-3/+3 * - Update to 20120513sunpoet2012-05-152-3/+3 * - Update to 20120506sunpoet2012-05-072-3/+3 * Update to 0.11.3pawel2012-05-012-3/+3 * - Update to 20120429sunpoet2012-04-302-3/+3 * - Update to 20120422sunpoet2012-04-242-3/+3 * - upgrade to 3.5.2bapt2012-04-234-0/+22 * - Update to 20120408sunpoet2012-04-102-3/+3 * Update to bugfix release 0.11.2pawel2012-04-043-4/+3 * - Update to 20120401sunpoet2012-04-022-3/+3 * - Update to 20120325sunpoet2012-03-262-3/+3 * - Update to 20120311sunpoet2012-03-122-3/+3 * - Update to 20120304sunpoet2012-03-052-3/+3 * Update to 0.11.1 bugfix releasepawel2012-03-023-11/+3 * - Update to 20120219sunpoet2012-02-202-3/+3 * - Bump PORTREVISION to chase the update of multimedia/libvpxashish2012-02-161-0/+1 * Bump pcre library dependency due to 8.30 updatemm2012-02-141-2/+2 * - Update to 20120212sunpoet2012-02-132-3/+3 * - Update to version 0.11.0pawel2012-02-116-2676/+2741 * - Update to 20120205sunpoet2012-02-062-3/+3 * - Update to 20120129sunpoet2012-01-302-3/+3 * The KDE/FreeBSD team is pleased to announce KDE SC 4.7.4, whichavilla2012-01-251-2/+2 * - Update to 20120122sunpoet2012-01-232-3/+3 * Update to version 1.11.1pawel2012-01-182-3/+3 * - Update to 20120115sunpoet2012-01-162-3/+3 * - Update to 20120108sunpoet2012-01-092-3/+3 * - Add UNICODE option (default off) which enables experimental unicode supportpawel2012-01-062-16/+16 * - Update to 20120101sunpoet2012-01-022-3/+3 * - Update to 20111225sunpoet2011-12-262-3/+3 * - Update to 20111218sunpoet2011-12-192-3/+3 * - Update to 20111211sunpoet2011-12-122-3/+3 * - Update to 20111204sunpoet2011-12-052-3/+3 * - Pass maintainership to office@FreeBSD.orgsunpoet2011-11-291-1/+1 * - Update to 20111127sunpoet2011-11-282-3/+3 * - Update to 20111120sunpoet2011-11-212-3/+3 * Remove CMAKE_USE_PTHREAD from the ports using it.rakuco2011-11-141-1/+0 * The KDE on FreeBSD team is pleased to update the KDE4 ports to 4.7.3.rakuco2011-11-141-2/+2 * - Update to 20111113sunpoet2011-11-142-3/+3 * - Update to 20111106sunpoet2011-11-072-3/+3 * - Update to 20111030sunpoet2011-10-312-3/+3 * Remove more tags from pkg-descr files fo the form:dougb2011-10-242-6/+0 * - Update to 20111023sunpoet2011-10-242-3/+3 * Update to 0.10.1 bugfix releasepawel2011-10-203-4/+7 * - Update to 20111016sunpoet2011-10-172-3/+3 * The KDE/FreeBSD team is pleased to announce KDE Software Compilationavilla2011-10-173-13/+68 * - Add dependency on qt4-scripttools.avilla2011-10-171-2/+3 * - Update to 20111009sunpoet2011-10-102-3/+3 * - Update to 20111002sunpoet2011-10-032-3/+3 * - Update to 20110925sunpoet2011-09-262-3/+3 * - Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)amdmi32011-09-244-7/+8 * - Update to 20110918sunpoet2011-09-192-3/+3 * - This version needs pl-libgadu>=1.11.0pawel2011-09-151-1/+3 * - Update to version 0.10.0pawel2011-09-1412-765/+1225 * - Track dependencies after databases/gdbm updategabor2011-09-131-2/+2 * - Update to 20110904sunpoet2011-09-052-3/+3 * - Update to 20110828sunpoet2011-08-292-3/+3 * Update to 20110825crees2011-08-252-3/+3 * - update to version 0.11.0pawel2011-08-252-9/+9 * Update to 20110823crees2011-08-232-3/+3 * - unbreak and update to version 0.9.2pawel2011-08-2312-577/+3132 * - fix install phasepawel2011-08-201-3/+3 * - Update to 20110817sunpoet2011-08-182-3/+3 * - Set DIST_SUBDIR: move dist files to DISTDIR/mythessunpoet2011-08-182-2/+3 * - Set DIST_SUBDIR: move dist files to DISTDIR/hyphensunpoet2011-08-182-2/+3 * - Set DIST_SUBDIR: move dist files to DISTDIR/hunspellsunpoet2011-08-182-2/+3 * - Change MASTER_SITES to my LOCAL to avoid implicit change of non-versionedsunpoet2011-08-182-4/+4 * - Update to 20110816sunpoet2011-08-162-3/+3 * Fix build with clangpawel2011-08-161-1/+1 * - Update to 20110815sunpoet2011-08-152-3/+3 * - Update to 20110814sunpoet2011-08-142-3/+3 * - Update to 20110813sunpoet2011-08-132-3/+3 * - Set WRKSRCsunpoet2011-08-131-1/+2 * - Update to 20110812sunpoet2011-08-132-3/+3 * - Update to 20110811sunpoet2011-08-122-3/+3 * - Update to 20110809sunpoet2011-08-092-3/+3 * - Update to 20110807sunpoet2011-08-072-4/+5 * - Update to 20110805sunpoet2011-08-052-3/+3 * - Update to 20110803sunpoet2011-08-032-3/+3 * - Update to 20110801sunpoet2011-08-022-5/+4 * Bye bye abandonwares (part 4)bapt2011-08-015-38/+0 * - Update to 20110731sunpoet2011-08-012-3/+3 * - Add polish categorysunpoet2011-07-311-2/+1 * - Connect polish/hunspellsunpoet2011-07-311-0/+1 * - Move language prefix to PKGNAMEPREFIXsunpoet2011-07-292-10/+12 * - Update to 20110729sunpoet2011-07-292-9/+10 * - Update to 20110727sunpoet2011-07-272-6/+6 * - Fix typosunpoet2011-07-251-1/+1 * update to 20110722bapt2011-07-232-3/+3 * Pass matainership to the new office teambapt2011-07-223-3/+3 * Add some locales thesaurusbapt2011-07-214-0/+37 * Add Polish hyphenation rulesbapt2011-07-214-0/+33 * Add Polish hunspell dictionariesbapt2011-07-213-0/+40 * Reset maintainership de jure. In fact KDE 3 has not been maintained by our teammakc2011-07-082-2/+2 * Update KDE Software Compilation ports to 4.6.5makc2011-07-082-2/+53 * - remove MD5ohauer2011-07-031-4/+0 * Last bunch of deprecation: no more public distfiles and/or abandonware... las...bapt2011-06-171-0/+3 * The FreeBSD KDE Team is pleased to announce KDE SC 4.6.4. Read fullavilla2011-06-141-2/+2 * - Mark BROKEN: does not configurepav2011-05-241-0/+2 * Update KDE Software Compilation ports to 4.6.3makc2011-05-172-2/+36 * The FreeBSD KDE Team is pleased to announce April updates for KDEavilla2011-04-072-2/+4 * - Update to 0.3.1pawel2011-03-313-14/+4 * - Update KOffice to 2.3.1.avilla2011-03-252-2/+2 * The FreeBSD KDE Team is pleased to announce KDE SC 4.6.1 and KDE PIMavilla2011-03-253-56/+240 * - Update my email to FreeBSDpawel2011-03-242-2/+2 * - Get Rid MD5 supportmiwi2011-03-1912-14/+0 * - Update to 1.10.1wen2011-03-152-5/+6 * - update to version 0.3.0miwi2011-02-234-147/+223 * - Remove unnecessary PKGNAMEPREFIX declarationsunpoet2011-01-095-5/+0 * - The KDE FreeBSD team is proud to announce the release of KDE 4.5.5fluffy2011-01-081-2/+2 * - Add LICENSE infomakc2010-12-196-27/+45 * KDE FreeBSD team presents KDE SC 4.5.4.makc2010-12-032-2/+3 * KDE FreeBSD team presents KDE SC 4.5.3.makc2010-11-042-3/+18 * KDE FreeBSD team presents KDE SC 4.5.2.makc2010-10-062-3/+44 * Autotools update. Read ports/UPDATING 20100915 for details.ade2010-09-162-4/+2 * KDE FreeBSD team presents KDE SC 4.5.1.makc2010-09-033-224/+55 * Update KOffice l10n ports to 2.2.2makc2010-08-284-6/+8 * Present KDE SC 4.4.5 for FreeBSD.makc2010-06-301-3/+3 * - Update KOffice (and its l10n packs) to 2.2.0 releasefluffy2010-06-194-8/+18 * Connect gimp-help portsmakc2010-06-151-0/+1 * Add new ports for GIMP Manual:makc2010-06-151-0/+18 * Present KDE SC 4.4.4 for FreeBSD.makc2010-06-021-3/+3 * Bounce PORTREVISION for gettext-related ports. Have fun, ya'll.ade2010-05-314-4/+4 * - Update to 1.9.0sylvio2010-05-172-8/+9 * - Update KOffice to 2.1.2 releasefluffy2010-05-114-8/+6 * - The FreeBSD KDE team is pleased to announce KDE SC 4.4.3 for FreeBSDfluffy2010-05-114-276/+328 * Chase the ftp/curl shlib version bump.roam2010-04-031-2/+2