aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-byebug/Makefile25
-rw-r--r--devel/rubygem-byebug/distinfo2
-rw-r--r--devel/rubygem-byebug/pkg-descr7
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 03bd1cf8931e..cd9215680c6a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4148,6 +4148,7 @@
SUBDIR += rubygem-builder
SUBDIR += rubygem-builder31
SUBDIR += rubygem-builder32
+ SUBDIR += rubygem-byebug
SUBDIR += rubygem-caesars
SUBDIR += rubygem-cairo-gobject
SUBDIR += rubygem-capybara
diff --git a/devel/rubygem-byebug/Makefile b/devel/rubygem-byebug/Makefile
new file mode 100644
index 000000000000..752c74fc1865
--- /dev/null
+++ b/devel/rubygem-byebug/Makefile
@@ -0,0 +1,25 @@
+# Created by: Michael Moll <kvedulv at kvedulv.de>
+# $FreeBSD$
+
+PORTNAME= byebug
+PORTVERSION= 2.7.0
+CATEGORIES= devel ruby
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby 2 debugger
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= rubygem-columnize>=0.3:${PORTSDIR}/devel/rubygem-columnize \
+ rubygem-debugger-linecache>=1.2:${PORTSDIR}/devel/rubygem-debugger-linecache
+
+USE_RUBY= yes
+RUBY_REQUIRE= Ruby >= 200
+
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+PLIST_FILES= bin/byebug
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-byebug/distinfo b/devel/rubygem-byebug/distinfo
new file mode 100644
index 000000000000..708178304a4b
--- /dev/null
+++ b/devel/rubygem-byebug/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/byebug-2.7.0.gem) = b728ad5c72d2ff4d53e809ddf3711136c622bf621f19ad59982c032858a1f690
+SIZE (rubygem/byebug-2.7.0.gem) = 93696
diff --git a/devel/rubygem-byebug/pkg-descr b/devel/rubygem-byebug/pkg-descr
new file mode 100644
index 000000000000..8bf88c4edac7
--- /dev/null
+++ b/devel/rubygem-byebug/pkg-descr
@@ -0,0 +1,7 @@
+Byebug is a simple to use, feature rich debugger for Ruby 2. It uses the
+new TracePoint API for execution control and the new Debug Inspector API
+for call stack navigation, so it doesn't depend on internal core sources.
+It's developed as a C extension, so it's fast. And it has a full test
+suite so it's reliable.
+
+WWW: https://github.com/deivid-rodriguez/byebug