aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-p2p/rtorrent/Makefile8
-rw-r--r--net-p2p/rtorrent/distinfo4
-rw-r--r--net-p2p/rtorrent/files/patch-src__display__canvas.h11
-rw-r--r--net-p2p/rtorrent/files/patch-src_thread_base.cc8
4 files changed, 10 insertions, 21 deletions
diff --git a/net-p2p/rtorrent/Makefile b/net-p2p/rtorrent/Makefile
index 9f3d6e11fb78..2cd83ef64c1c 100644
--- a/net-p2p/rtorrent/Makefile
+++ b/net-p2p/rtorrent/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME?= rtorrent
-PORTVERSION?= 0.8.7
-PORTREVISION?= 2
+PORTVERSION?= 0.8.9
+PORTREVISION?= 0
CATEGORIES= net-p2p
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/ \
${MASTER_SITE_LOCAL}
@@ -16,8 +16,8 @@ MASTER_SITE_SUBDIR= flz/rtorrent/
MAINTAINER?= flz@FreeBSD.org
COMMENT?= BitTorrent Client written in C++
-BUILD_DEPENDS?= libtorrent=0.12.7:${PORTSDIR}/net-p2p/libtorrent
-RUN_DEPENDS?= libtorrent=0.12.7:${PORTSDIR}/net-p2p/libtorrent
+BUILD_DEPENDS?= libtorrent=0.12.9:${PORTSDIR}/net-p2p/libtorrent
+RUN_DEPENDS?= libtorrent=0.12.9:${PORTSDIR}/net-p2p/libtorrent
LIB_DEPENDS?= curl.6:${PORTSDIR}/ftp/curl
CONFLICTS?= rtorrent-devel-[0-9]*
diff --git a/net-p2p/rtorrent/distinfo b/net-p2p/rtorrent/distinfo
index ed3ea8ed47cf..822f267d5929 100644
--- a/net-p2p/rtorrent/distinfo
+++ b/net-p2p/rtorrent/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rtorrent-0.8.7.tar.gz) = 1fd0c9b2b3fe81b035209417c4dd4514473411f16b15ffe7fefe87eaff1a58d2
-SIZE (rtorrent-0.8.7.tar.gz) = 547435
+SHA256 (rtorrent-0.8.9.tar.gz) = cca70eb36a0c176bbd6fdb3afe2bc9f163fa4c9377fc33bc29689dec60cf6d84
+SIZE (rtorrent-0.8.9.tar.gz) = 570904
diff --git a/net-p2p/rtorrent/files/patch-src__display__canvas.h b/net-p2p/rtorrent/files/patch-src__display__canvas.h
deleted file mode 100644
index 583ef1828aed..000000000000
--- a/net-p2p/rtorrent/files/patch-src__display__canvas.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/display/canvas.h.orig 2010-06-26 14:05:07.000000000 +0200
-+++ src/display/canvas.h 2011-04-09 11:21:30.000000000 +0200
-@@ -48,7 +48,7 @@
- public:
- typedef std::vector<Attributes> attributes_list;
-
-- Canvas(int x = 0, int y = 0, int width = 0, int height = 0) :
-+ Canvas(int x = 0, int y = 0, int width = 1, int height = 1) :
- m_window(newwin(height, width, y, x)) {}
- ~Canvas() { delwin(m_window); }
-
diff --git a/net-p2p/rtorrent/files/patch-src_thread_base.cc b/net-p2p/rtorrent/files/patch-src_thread_base.cc
index 1119ac82fe18..0a84dda1069d 100644
--- a/net-p2p/rtorrent/files/patch-src_thread_base.cc
+++ b/net-p2p/rtorrent/files/patch-src_thread_base.cc
@@ -1,11 +1,11 @@
---- src/thread_base.cc.orig 2011-06-07 12:06:49.729114328 -0400
-+++ src/thread_base.cc 2011-06-07 12:07:19.880080780 -0400
+--- src/thread_base.cc.orig 2011-04-05 11:26:11.000000000 +0100
++++ src/thread_base.cc 2011-06-09 18:59:41.375670521 +0100
@@ -61,7 +61,7 @@
static const unsigned int max_size = 32;
-- thread_queue_hack() { std::memset(m_queue, 0, sizeof(thread_queue_hack)); }
-+ thread_queue_hack() : m_lock(0) { std::memset(m_queue, 0, sizeof(thread_queue_hack)); }
+- thread_queue_hack() { std::memset(this, 0, sizeof(thread_queue_hack)); }
++ thread_queue_hack() : m_lock(0) { std::memset(this, 0, sizeof(thread_queue_hack)); }
void lock() { while (!__sync_bool_compare_and_swap(&m_lock, 0, 1)) usleep(0); }
void unlock() { __sync_bool_compare_and_swap(&m_lock, 1, 0); }
252-2/+2 * Fix make -jarved2009-03-251-0/+1 * Where it matters, update regarding MAKE_JOBS_{UN}SAFE for my portsdougb2009-03-251-0/+2 * bump PORTREVISION after cmake updatemakc2009-03-257-1/+7 * Update to confget-1.02.roam2009-03-254-25/+15 * - Update to 0.03miwi2009-03-252-4/+4 * - Update to 2.4.7pav2009-03-242-5/+4 * - Update to 2.4.8pav2009-03-243-7/+7 * Add p5-Unicode-EastAsianWidth, East Asian Width properties.chinsan2009-03-245-0/+35 * - Update to 1.88chinsan2009-03-243-6/+12 * - Update to 1.05chinsan2009-03-242-4/+4 * Use DOCSDIR consistently and repect NOPORTDOCS.itetcu2009-03-232-5/+5 * Reset barner@FreeBSD.org due to several months of inactivity.linimon2009-03-231-1/+1 * Solr is an open source enterprise search server based on the Lucenemiwi2009-03-225-0/+178 * - Update to 0.9.6miwi2009-03-223-12/+13 * - Update to 1.1.3gahr2009-03-222-4/+4 * - Fix PORTDATA supportpgj2009-03-212-14/+24 * - Update to 0.8amdmi32009-03-213-16/+4 * - Update to 0.43miwi2009-03-212-4/+4 * - Update to 0.21miwi2009-03-212-4/+4 * - Update to 2.1.4miwi2009-03-212-4/+4 * - udpate to 0.4.1dinoex2009-03-206-9/+12 * p5-XML-Bare is a minimal XML parser, schema checker and pretty-printermiwi2009-03-205-0/+36 * - update to 0.4.0dinoex2009-03-203-9/+8 * Welcome to the new linux ports infrastructure which allows usingbsam2009-03-206-15/+6 * - Update to 3.27miwi2009-03-202-4/+5 * Add a port of confget-1.01, a simple tool to read variables fromroam2009-03-185-0/+76 * - Update to 2.14.0pgj2009-03-182-4/+4 * Update to 2.24.3bland2009-03-183-22/+22 * Attempt to fix the NOPORTDOCS case.marcus2009-03-182-0/+4 * Mark as broken on sparc64-6.linimon2009-03-181-0/+4 * - update to 20090316leeym2009-03-183-10/+8 * Aspell Ancient Greek dictionary.thierry2009-03-185-0/+30 * PyStemmer provides access to efficient algorithms for calculating amiwi2009-03-175-0/+42 * - Update to 1.1.2gahr2009-03-172-4/+4 * Nope, still broken on sparc64.linimon2009-03-161-3/+3 * - Update to 0.16.0miwi2009-03-162-6/+11 * This module provides a set of methods for adding (updating) andmiwi2009-03-165-0/+43 * This is an experimental distribution that attempts to intuit the underlyingmiwi2009-03-165-0/+35 * - Update to 2.11.07miwi2009-03-152-4/+4 * Update to 0.40.6.marcus2009-03-153-18/+4 * - Update to 0.12.3miwi2009-03-142-12/+8 * Fix on perl-5.10.skv2009-03-143-20/+25 * - Update to 1.0.0gahr2009-03-142-4/+4 * - Update to 0.10.9lwhsu2009-03-142-4/+4 * This extension provides WBXML (Wireless Binary XML) conversion capabilitiesmiwi2009-03-136-0/+69 * FormValidator::Simple like lightweight form validation library.miwi2009-03-125-0/+52 * - Bump PORTREVISION to chase databases/tokyocabinet updatelwhsu2009-03-101-0/+1 * - Update to 1.3.4miwi2009-03-102-4/+4 * - Reset farrokhi@freebsd.org due to long period of inactivity.miwi2009-03-101-1/+1 * - Update to 2.13.2pgj2009-03-106-56/+173 * Update KDE to 4.2.1.makc2009-03-094-14/+41 * - update to 2009.0305leeym2009-03-092-4/+4 * - update to 0.15leeym2009-03-092-4/+4 * Remove textproc/latte and textproc/nicetext per expiration note.gerald2009-03-0850-1766/+0 * - Update to 0.9.9gahr2009-03-083-6/+5 * - Update to 1.2pgj2009-03-074-8/+8 * - Use my FreeBSD address on the ports I maintaindhn2009-03-073-3/+3 * Bump PORTREVISION after xfce 4.6 updateoliver2009-03-061-0/+1 * Update to 0.40.5mat2009-03-052-4/+4 * Update to 0.38mat2009-03-052-4/+4 * - Update to 0.10.8.lwhsu2009-03-052-5/+5 * Fix plist error in textproc/libyamljpaetzel2009-03-041-1/+3 * - Update to 1.01clsung2009-03-032-4/+4 * Update to 2.1.0.marcus2009-03-033-10/+11 * - Chase textproc/ctpp2 updatewxs2009-03-031-0/+1 * - Update to 2.4.4wxs2009-03-033-5/+5 * Remove uneeded patch file.jpaetzel2009-03-031-15/+0 * - Update to 1.14pgj2009-03-033-23/+13 * - Update to 0.52amdmi32009-03-022-4/+4 * Update libyaml to 0.1.2jpaetzel2009-03-012-5/+5 * - Update to 1.1amdmi32009-03-012-4/+4 * - Pass maintainership to submittertabthorpe2009-02-281-1/+1 * - Pass maintainership to gabor.alepulver2009-02-281-1/+1 * Tempita is a small templating language for text substitution.miwi2009-02-275-0/+32 * Update to 0.14mat2009-02-262-4/+4 * Update MASTER_SITES and WWWmakc2009-02-262-2/+2 * - Fix plist after DOCSDIR changegabor2009-02-263-3/+8 * - Update to 1.1.7garga2009-02-254-42/+13 * Add p5-Text-Truncate 1.03, perl module with simple string truncatinglth2009-02-255-0/+34 * - use oniguruma5 by defaultdinoex2009-02-251-4/+14 * Don't use PERL_VER (it will be deleted soon), use PERL_VERSION instead.skv2009-02-241-1/+1 * - Change DOCSDIR to avoid conflict with other DocBook portsgabor2009-02-241-0/+2 * EBook-Tools contains a library and a command-line tool for unpacking,miwi2009-02-245-0/+67 * Update to 2.49skv2009-02-232-5/+4 * - Change default Tcl/Tk version to 8.5mm2009-02-235-2/+5 * - Fix previous commitgabor2009-02-232-4/+4 * - Change DOCSDIR to avoid conflict with other DocBook portsgabor2009-02-232-0/+4 * Update to 1.5.5.nobutaka2009-02-217-18/+101 * Update to 1.5.5.nobutaka2009-02-212-4/+5 * Use my @FreeBSD.org email for the rest of my portsmakc2009-02-211-1/+1 * - Update to 2.11.03miwi2009-02-212-4/+4 * - Update to 0.21.0miwi2009-02-212-6/+26 * - Update to 1.2lmiwi2009-02-212-5/+4 * Updated my mail address to use @FreeBSD.org now.mva2009-02-201-1/+1 * - Update to 0.6.3.1miwi2009-02-202-11/+6 * - Update to 1.3nivit2009-02-162-7/+7 * - Update to 0.91miwi2009-02-162-4/+4 * - Fix plist after ruby update by generating it dynamically.stas2009-02-152-90/+9 * - Change USE_TCL from YES to 84 due to planned default tcl changemm2009-02-151-2/+2 * Update PyQt4 ports to 4.4.4, new ports:makc2009-02-158-28/+125 * Update to 2.07skv2009-02-152-4/+4 * Update to 1.38skv2009-02-152-5/+4 * Add LIBS to CONFIGURE_ARGS to fix build.skv2009-02-151-1/+2 * - Update to 1.3.1.1miwi2009-02-152-12/+6 * - Fix plist after ruby update by generating it dynamically.stas2009-02-146-237/+3 * - Fix build after ruby update.stas2009-02-141-0/+10 * - Fix packaging with ruby 1.8.7 (use dynamic rdoc plist).stas2009-02-142-216/+10 * - Update to version 1abeech2009-02-132-5/+4 * - Update to 0.5.1miwi2009-02-132-4/+4