aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--java/eclipse-emf/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/java/eclipse-emf/Makefile b/java/eclipse-emf/Makefile
index 48192991a60f..7ebbea5a82f2 100644
--- a/java/eclipse-emf/Makefile
+++ b/java/eclipse-emf/Makefile
@@ -31,12 +31,12 @@ JAVA_VERSION= 1.5+
JAVA_OS= native
do-install:
- @${MKDIR} ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/eclipse
- @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) >> ${TMPPLIST}
+ @${MKDIR} ${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/lib/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
@(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
| ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
+ | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
.include <bsd.port.mk>