aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/py-pychess/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/games/py-pychess/Makefile b/games/py-pychess/Makefile
index f4cee1b35a9e..e65f4f91c64a 100644
--- a/games/py-pychess/Makefile
+++ b/games/py-pychess/Makefile
@@ -26,7 +26,8 @@ OPTIONS= PYGSTREAMER "Install gst-python for audio support" off \
GNUCHESS "Install gnuchess (chess engine)" off \
PHALANX "Install phalanx (chess engine)" off \
SJENG "Install sjeng (chess engine)" off \
- STRONGPLAYER "Install psyco/gmpy (strong player)" off
+ STRONGPLAYER "Install psyco/gmpy (strong player)" off \
+ STOCKFISH "Install stockfish (chess engine)" off
OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
@@ -76,4 +77,8 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}psyco>=1.6:${PORTSDIR}/devel/py-psyco
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gmpy>=1.13:${PORTSDIR}/math/py-gmpy
.endif
+.if defined (WITH_STOCKFISH)
+RUN_DEPENDS+= stockfish:${PORTSDIR}/games/stockfish
+.endif
+
.include <bsd.port.post.mk>