aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--misc/tinderbox/Makefile4
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile4
-rw-r--r--ports-mgmt/tinderbox/Makefile4
3 files changed, 12 insertions, 0 deletions
diff --git a/misc/tinderbox/Makefile b/misc/tinderbox/Makefile
index 250e373b34bd..a6dc44d731a4 100644
--- a/misc/tinderbox/Makefile
+++ b/misc/tinderbox/Makefile
@@ -29,6 +29,10 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
+.if !defined(WITH_PGSQL) && !defined(WITH_MYSQL)
+BROKEN= "Tinderbox is useless without a database. Please (re)run 'make config' and choose one of PGSQL and MYSQL"
+.endif
+
.if defined(WITH_PGSQL)
USE_PGSQL= yes
USE_PHP+= pgsql
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index 250e373b34bd..a6dc44d731a4 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -29,6 +29,10 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
+.if !defined(WITH_PGSQL) && !defined(WITH_MYSQL)
+BROKEN= "Tinderbox is useless without a database. Please (re)run 'make config' and choose one of PGSQL and MYSQL"
+.endif
+
.if defined(WITH_PGSQL)
USE_PGSQL= yes
USE_PHP+= pgsql
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index 250e373b34bd..a6dc44d731a4 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -29,6 +29,10 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
+.if !defined(WITH_PGSQL) && !defined(WITH_MYSQL)
+BROKEN= "Tinderbox is useless without a database. Please (re)run 'make config' and choose one of PGSQL and MYSQL"
+.endif
+
.if defined(WITH_PGSQL)
USE_PGSQL= yes
USE_PHP+= pgsql