aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/jpeginfo/Makefile23
-rw-r--r--graphics/jpeginfo/distinfo1
-rw-r--r--graphics/jpeginfo/pkg-comment1
-rw-r--r--graphics/jpeginfo/pkg-descr5
-rw-r--r--graphics/jpeginfo/pkg-plist1
6 files changed, 32 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index e4c881045c2a..13a9a354d375 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -105,6 +105,7 @@
SUBDIR += jpeg
SUBDIR += jpeg2ps-a4
SUBDIR += jpeg2ps-letter
+ SUBDIR += jpeginfo
SUBDIR += jslice
SUBDIR += juno-2
SUBDIR += kdc2tiff
diff --git a/graphics/jpeginfo/Makefile b/graphics/jpeginfo/Makefile
new file mode 100644
index 000000000000..fef659258673
--- /dev/null
+++ b/graphics/jpeginfo/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: jpeginfo
+# Date created: 9.8.2001
+# Whom: ache
+#
+# $FreeBSD$
+#
+
+PORTNAME= jpeginfo
+PORTVERSION= 1.5a
+CATEGORIES= graphics
+MASTER_SITES= http://www.cc.jyu.fi/~tjko/src/
+
+MAINTAINER= ache@freebsd.org
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+MAN1= jpeginfo.1
+
+.include <bsd.port.mk>
diff --git a/graphics/jpeginfo/distinfo b/graphics/jpeginfo/distinfo
new file mode 100644
index 000000000000..963d6cc2a9f1
--- /dev/null
+++ b/graphics/jpeginfo/distinfo
@@ -0,0 +1 @@
+MD5 (jpeginfo-1.5a.tar.gz) = 380068d145efe3b2f738a3e971cce26f
diff --git a/graphics/jpeginfo/pkg-comment b/graphics/jpeginfo/pkg-comment
new file mode 100644
index 000000000000..e206807c5818
--- /dev/null
+++ b/graphics/jpeginfo/pkg-comment
@@ -0,0 +1 @@
+Generate listing and MD5, check jpegs for error, delete broken ones
diff --git a/graphics/jpeginfo/pkg-descr b/graphics/jpeginfo/pkg-descr
new file mode 100644
index 000000000000..6abf177324f9
--- /dev/null
+++ b/graphics/jpeginfo/pkg-descr
@@ -0,0 +1,5 @@
+jpeginfo is used to generate informative listings of jpeg
+files, and also to check jpeg files for errors. Program
+also supports automatic deletion of broken jpegs.
+
+WWW: http://www.cc.jyu.fi/~tjko/projects.html
diff --git a/graphics/jpeginfo/pkg-plist b/graphics/jpeginfo/pkg-plist
new file mode 100644
index 000000000000..7dad7a530a5b
--- /dev/null
+++ b/graphics/jpeginfo/pkg-plist
@@ -0,0 +1 @@
+bin/jpeginfo