aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/cxxtools/Makefile1
-rw-r--r--devel/cxxtools/files/patch-clang36
-rw-r--r--www/tntnet/Makefile2
3 files changed, 30 insertions, 9 deletions
diff --git a/devel/cxxtools/Makefile b/devel/cxxtools/Makefile
index e868d495499d..72e52984cc5e 100644
--- a/devel/cxxtools/Makefile
+++ b/devel/cxxtools/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cxxtools
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.tntnet.org/download/
diff --git a/devel/cxxtools/files/patch-clang b/devel/cxxtools/files/patch-clang
index 7781b7bce960..83334f2b4701 100644
--- a/devel/cxxtools/files/patch-clang
+++ b/devel/cxxtools/files/patch-clang
@@ -117,12 +117,32 @@
{ }
/// returns the parent-object
-@@ -339,7 +339,7 @@ class QueryParams
+@@ -332,8 +332,15 @@ class QueryParams
+ //
+
+ /// get named parameter.
++#if 0 // XXX this will return a temporary object for def with clang
+ const string& param(const string& name, size_type n = 0,
+ const string& def = std::string()) const
++#else
++ static const std::string emptystring;
++
++ const string& param(const string& name, size_type n = 0,
++ const string& def = emptystring) const
++#endif
+ {
+ named_params_type::const_iterator i = named_params.find(name);
if (i != named_params.end() && n < i->second.size())
- return i->second[n];
- else if (!useParentValues())
-- return def;
-+ return std::string(def);
- else
- {
- if (i != named_params.end())
+--- a/src/query_params.cpp
++++ b/src/query_params.cpp
+@@ -164,6 +164,10 @@ void _parse_url(
+ }
+ }
+
++#if 1 // XXX clang problem, see query_params.h
++const std::string QueryParams::emptystring;
++#endif
++
+ void QueryParams::parse_url(const std::string& url)
+ {
+ _parse_url(url.begin(), url.end(), unnamed_params, named_params);
diff --git a/www/tntnet/Makefile b/www/tntnet/Makefile
index 893d3d5f7da4..562722852901 100644
--- a/www/tntnet/Makefile
+++ b/www/tntnet/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tntnet
PORTVERSION= 2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www devel
MASTER_SITES= http://www.tntnet.org/download/