aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.gecko.mk10
-rw-r--r--www/firefox/Makefile9
-rw-r--r--www/firefox/distinfo4
-rw-r--r--www/firefox/files/patch-browser-app-Makefile.in86
-rw-r--r--www/firefox/files/patch-browser-app-nsBrowserApp.cpp49
-rw-r--r--www/firefox/files/patch-bugzilla-736961111
-rw-r--r--www/firefox/files/patch-configure.in41
-rw-r--r--www/firefox/files/patch-gfx-ycbcr-Makefile.in21
-rw-r--r--www/firefox/files/patch-xpcom_base_nsStackWalk.cpp10
-rw-r--r--www/firefox/pkg-descr2
10 files changed, 252 insertions, 91 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 392736accb72..273b4016b669 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -181,7 +181,7 @@ Gecko_Pre_Include= bsd.gecko.mk
# is given by the maintainer via the port or by the
# user via defined variable try to find the highest
# stable installed version.
-# Available values: yes 10+ 12+ 10 12+
+# Available values: yes 10+ 13+ 10 13+
# NOTE:
# default value 10 is used in case of USE_FIREFOX=yes
#
@@ -223,11 +223,11 @@ _FIREFOX_BUILD_DEPENDS= yes
.endif
_FIREFOX_DEFAULT_VERSION= 10
-_FIREFOX_VERSIONS= 10 12
-_FIREFOX_RANGE_VERSIONS= 10+ 12+
+_FIREFOX_VERSIONS= 10 13
+_FIREFOX_RANGE_VERSIONS= 10+ 13+
# For specifying [10, ..]+
-_FIREFOX_12P= 12 ${_FIREFOX_10P}
+_FIREFOX_13P= 13 ${_FIREFOX_10P}
_FIREFOX_10P= 10
# Set the default Firefox version and check if USE_FIREFOX=yes was given
@@ -281,7 +281,7 @@ IGNORE= cannot install: unknown Firefox version: firefox-${USE_FIREFOX:C/([0-9
# Dependence lines for different Firefox versions
10_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox-esr
-12_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
+13_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
# Add dependencies
.if defined(USE_FIREFOX)
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index dbbfdfe9973a..e26ca82133c6 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= firefox
-DISTVERSION= 12.0
-PORTREVISION= 1
+DISTVERSION= 13.0
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -17,7 +16,7 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}.source
MAINTAINER= gecko@FreeBSD.org
COMMENT= Web browser based on the browser portion of Mozilla
-BUILD_DEPENDS= nspr>=4.8.8:${PORTSDIR}/devel/nspr \
+BUILD_DEPENDS= nspr>=4.9:${PORTSDIR}/devel/nspr \
cairo>=1.10.2_1,1:${PORTSDIR}/graphics/cairo \
unzip:${PORTSDIR}/archivers/unzip
LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
@@ -59,6 +58,10 @@ OPTIONS= DBUS "Enable D-BUS support" on \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 800000
+USE_GCC= 4.6+
+.endif
+
WRKSRC:= ${WRKDIR}/mozilla-release
.if ${HAVE_GNOME:Mlibgnomeui}!=""
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index b2218ba6a033..a542c620779a 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (firefox-12.0.source.tar.bz2) = 9a232a10e5803b0e4a85bd986e3e88b87ccde7bdc3363ea7022d5761944dbb1d
-SIZE (firefox-12.0.source.tar.bz2) = 78956707
+SHA256 (firefox-13.0.source.tar.bz2) = dc801286e752ba3c2006caa0728024cb5b92460d9a3a1636c111c1f4f4f50b55
+SIZE (firefox-13.0.source.tar.bz2) = 79605635
diff --git a/www/firefox/files/patch-browser-app-Makefile.in b/www/firefox/files/patch-browser-app-Makefile.in
index 742939363af1..3a3a449c2fca 100644
--- a/www/firefox/files/patch-browser-app-Makefile.in
+++ b/www/firefox/files/patch-browser-app-Makefile.in
@@ -1,6 +1,22 @@
---- browser/app/Makefile.in.orig 2012-02-22 17:06:17.000000000 +0100
-+++ browser/app/Makefile.in 2012-03-07 20:46:17.000000000 +0100
-@@ -66,23 +66,36 @@
+--- browser/app/Makefile.in.orig 2012-05-23 20:56:32.000000000 +0200
++++ browser/app/Makefile.in 2012-05-27 18:12:41.000000000 +0200
+@@ -56,37 +56,46 @@
+ # hardcode en-US for the moment
+ AB_CD = en-US
+
+-DEFINES += \
+- -DAB_CD=$(AB_CD) \
+- -DAPP_VERSION="$(MOZ_APP_VERSION)" \
+- -DFIREFOX_ICO=\"$(DIST)/branding/firefox.ico\" \
+- -DDOCUMENT_ICO=\"$(DIST)/branding/document.ico\" \
+- $(NULL)
++DEFINES += -DAB_CD=$(AB_CD)
++
++APP_VERSION = $(shell cat $(srcdir)/../config/version.txt)
++DEFINES += -DAPP_VERSION="$(APP_VERSION)"
+
+ ifdef LIBXUL_SDK
+ include $(topsrcdir)/config/rules.mk
else
# Build a binary bootstrapping with XRE_main
@@ -12,10 +28,15 @@
CPPSRCS = nsBrowserApp.cpp
- LOCAL_INCLUDES += -I$(topsrcdir)/toolkit/xre
- LOCAL_INCLUDES += -I$(topsrcdir)/xpcom/base
--LOCAL_INCLUDES += -I$(topsrcdir)/xpcom/build
- LOCAL_INCLUDES += -I$(DEPTH)/build
+-LOCAL_INCLUDES += \
+- -I$(topsrcdir)/toolkit/xre \
+- -I$(topsrcdir)/xpcom/base \
+- -I$(topsrcdir)/xpcom/build \
+- -I$(DEPTH)/build \
+- $(NULL)
++LOCAL_INCLUDES += -I$(topsrcdir)/toolkit/xre
++LOCAL_INCLUDES += -I$(topsrcdir)/xpcom/base
++LOCAL_INCLUDES += -I$(DEPTH)/build
-DEFINES += -DXPCOM_GLUE
-STL_FLAGS=
@@ -41,7 +62,25 @@
ifdef MOZ_LINKER
LIBS += $(ZLIB_LIBS)
endif
-@@ -157,9 +170,18 @@
+@@ -118,11 +127,17 @@
+ else
+ RCFLAGS += -DMOZ_PHOENIX --include-dir $(srcdir)
+ endif
++ifdef DEBUG
++RCFLAGS += -DDEBUG
++endif
+ endif
+
+ ifeq ($(OS_ARCH),OS2)
+ RESFILE=splashos2.res
+ RCFLAGS += -DMOZ_PHOENIX
++ifdef DEBUG
++RCFLAGS += -DDEBUG
++endif
+ RCFLAGS += -DFIREFOX_ICO=\"$(DIST)/branding/firefox-os2.ico\" -DDOCUMENT_ICO=\"$(DIST)/branding/document-os2.ico\"
+ endif
+
+@@ -150,15 +165,26 @@
ifneq (,$(filter-out OS2 WINNT,$(OS_ARCH)))
@@ -51,14 +90,41 @@
+ cat $< | sed -e "s|%MOZAPPDIR%|$(installdir)|" \
+ -e "s|%MOZ_APP_DISPLAYNAME%|$(MOZ_APP_DISPLAYNAME)|" > $@
+ chmod +x $@
-+
+
+libs:: $(MOZ_APP_NAME)
+ $(INSTALL) $< $(DIST)/bin
+
+install:: $(MOZ_APP_NAME)
+ $(SYSINSTALL) $< $(DESTDIR)$(bindir)
-
++
+GARBAGE += $(MOZ_APP_NAME)
GARBAGE += $(addprefix $(DIST)/bin/defaults/pref/, firefox.js)
endif
+
+ endif # LIBXUL_SDK
+
++DEFINES += -DFIREFOX_ICO=\"$(DIST)/branding/firefox.ico\" -DDOCUMENT_ICO=\"$(DIST)/branding/document.ico\"
++
+ ifeq ($(MOZ_WIDGET_TOOLKIT),gtk2)
+ libs::
+ $(INSTALL) $(IFLAGS1) $(DIST)/branding/mozicon128.png $(DIST)/bin/icons
+@@ -201,15 +227,17 @@
+ rsync -a --exclude "*.in" $(srcdir)/macbuild/Contents $(DIST)/$(MOZ_MACBUNDLE_NAME) --exclude English.lproj
+ $(MKDIR) -p $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Resources/$(AB).lproj
+ rsync -a --exclude "*.in" $(srcdir)/macbuild/Contents/Resources/English.lproj/ $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Resources/$(AB).lproj
+- sed -e "s/%APP_VERSION%/$(MOZ_APP_VERSION)/" -e "s/%MAC_APP_NAME%/$(MAC_APP_NAME)/" -e "s/%LOWER_MAC_APP_NAME%/$(LOWER_MAC_APP_NAME)/" $(srcdir)/macbuild/Contents/Info.plist.in > $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Info.plist
++ sed -e "s/%APP_VERSION%/$(APP_VERSION)/" -e "s/%MAC_APP_NAME%/$(MAC_APP_NAME)/" -e "s/%LOWER_MAC_APP_NAME%/$(LOWER_MAC_APP_NAME)/" $(srcdir)/macbuild/Contents/Info.plist.in > $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Info.plist
+ sed -e "s/%MAC_APP_NAME%/$(MAC_APP_NAME)/" $(srcdir)/macbuild/Contents/Resources/English.lproj/InfoPlist.strings.in | iconv -f UTF-8 -t UTF-16 > $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Resources/$(AB).lproj/InfoPlist.strings
+ rsync -a $(DIST)/bin/ $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/$(APPFILES)
++ $(RM) $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/$(APPFILES)/mangle $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/$(APPFILES)/shlibsign
+ ifdef LIBXUL_SDK
+ cp $(LIBXUL_DIST)/bin/$(XR_STUB_NAME) $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/MacOS/firefox
+ else
+ $(RM) $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/MacOS/$(PROGRAM)
+ rsync -aL $(PROGRAM) $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/MacOS
+ endif
++ -cp -L $(DIST)/bin/mangle $(DIST)/bin/shlibsign $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/$(APPFILES)
+ cp -RL $(DIST)/branding/firefox.icns $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Resources/firefox.icns
+ cp -RL $(DIST)/branding/document.icns $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/Resources/document.icns
+ printf APPLMOZB > $(DIST)/$(MOZ_MACBUNDLE_NAME)/Contents/PkgInfo
diff --git a/www/firefox/files/patch-browser-app-nsBrowserApp.cpp b/www/firefox/files/patch-browser-app-nsBrowserApp.cpp
index ba6fbe56405c..1862bd5ece8a 100644
--- a/www/firefox/files/patch-browser-app-nsBrowserApp.cpp
+++ b/www/firefox/files/patch-browser-app-nsBrowserApp.cpp
@@ -1,13 +1,12 @@
---- browser/app/nsBrowserApp.cpp 2012-03-13 02:36:38.000000000 +0100
-+++ ../../../firefox-esr/work/mozilla-esr10/browser/app/nsBrowserApp.cpp 2012-03-15 10:17:09.000000000 +0100
-@@ -36,23 +36,14 @@
- *
+--- browser/app/nsBrowserApp.cpp.orig 2012-05-23 20:56:32.000000000 +0200
++++ browser/app/nsBrowserApp.cpp 2012-05-27 18:11:50.000000000 +0200
+@@ -37,38 +37,28 @@
* ***** END LICENSE BLOCK ***** */
+ #include "nsXULAppAPI.h"
-#include "application.ini.h"
-#include "nsXPCOMGlue.h"
-#if defined(XP_WIN)
-+#include "nsXULAppAPI.h"
+#ifdef XP_WIN
#include <windows.h>
#include <stdlib.h>
@@ -22,11 +21,13 @@
#include <stdio.h>
#include <stdarg.h>
--#include <string.h>
- #include "plstr.h"
- #include "prprf.h"
-@@ -63,16 +54,11 @@
++#include "plstr.h"
++#include "prprf.h"
++#include "prenv.h"
++
+ #include "nsCOMPtr.h"
+ #include "nsILocalFile.h"
#include "nsStringGlue.h"
#ifdef XP_WIN
@@ -45,7 +46,7 @@
static void Output(const char *fmt, ... )
{
-@@ -99,12 +85,12 @@
+@@ -95,12 +85,12 @@
{
if (*++arg == '-')
++arg;
@@ -60,7 +61,7 @@
#endif
return false;
-@@ -120,35 +106,22 @@
+@@ -116,35 +106,22 @@
~ScopedLogging() { NS_LogTerm(); }
};
@@ -85,7 +86,7 @@
- { nsnull, nsnull }
-};
-
--static int do_main(const char *exePath, int argc, char* argv[])
+-static int do_main(int argc, char* argv[])
+int main(int argc, char* argv[])
{
+ ScopedLogging log;
@@ -107,7 +108,7 @@
if (appDataFile && *appDataFile) {
rv = XRE_GetFileFromPath(appDataFile, getter_AddRefs(appini));
if (NS_FAILED(rv)) {
-@@ -168,133 +141,23 @@
+@@ -164,119 +141,23 @@
return 255;
}
@@ -124,7 +125,6 @@
argc -= 2;
}
-- int result;
- if (appini) {
- nsXREAppData *appData;
- rv = XRE_CreateAppData(appini, &appData);
@@ -132,25 +132,12 @@
- Output("Couldn't read application.ini");
- return 255;
- }
-- result = XRE_main(argc, argv, appData);
+- int result = XRE_main(argc, argv, appData);
- XRE_FreeAppData(appData);
-- } else {
--#ifdef XP_WIN
-- // exePath comes from mozilla::BinaryPath::Get, which returns a UTF-8
-- // encoded path, so it is safe to convert it
-- rv = NS_NewLocalFile(NS_ConvertUTF8toUTF16(exePath), PR_FALSE,
-- getter_AddRefs(appini));
--#else
-- rv = NS_NewNativeLocalFile(nsDependentCString(exePath), PR_FALSE,
-- getter_AddRefs(appini));
--#endif
-- if (NS_FAILED(rv)) {
-- return 255;
-- }
-- result = XRE_main(argc, argv, &sAppData);
+- return result;
- }
-
-- return result;
+- return XRE_main(argc, argv, &sAppData);
-}
-
-int main(int argc, char* argv[])
@@ -240,7 +227,7 @@
- int result;
- {
- ScopedLogging log;
-- result = do_main(exePath, argc, argv);
+- result = do_main(argc, argv);
- }
-
- XPCOMGlueShutdown();
diff --git a/www/firefox/files/patch-bugzilla-736961 b/www/firefox/files/patch-bugzilla-736961
new file mode 100644
index 000000000000..0de541101dc0
--- /dev/null
+++ b/www/firefox/files/patch-bugzilla-736961
@@ -0,0 +1,111 @@
+--- config/rules.mk.orig Wed May 2 05:16:35 2012
++++ config/rules.mk Fri May 11 08:42:50 2012
+@@ -1479,7 +1487,7 @@ $(XPIDL_GEN_DIR)/%.h: %.idl $(XPIDL_DEPS) $(XPIDL_GEN_
+ $(PYTHON_PATH) \
+ -I$(topsrcdir)/other-licenses/ply \
+ -I$(topsrcdir)/xpcom/idl-parser \
+- $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=$(DEPTH)/xpcom/idl-parser $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
++ $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=$(DEPTH)/xpcom/idl-parser/cache $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
+ @if test -n "$(findstring $*.h, $(EXPORTS))"; \
+ then echo "*** WARNING: file $*.h generated from $*.idl overrides $(srcdir)/$*.h"; else true; fi
+
+@@ -1492,7 +1500,7 @@ $(XPIDL_GEN_DIR)/%.xpt: %.idl $(XPIDL_DEPS) $(XPIDL_GE
+ -I$(topsrcdir)/other-licenses/ply \
+ -I$(topsrcdir)/xpcom/idl-parser \
+ -I$(topsrcdir)/xpcom/typelib/xpt/tools \
+- $(topsrcdir)/xpcom/idl-parser/typelib.py --cachedir=$(DEPTH)/xpcom/idl-parser $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
++ $(topsrcdir)/xpcom/idl-parser/typelib.py --cachedir=$(DEPTH)/xpcom/idl-parser/cache $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
+
+ # no need to link together if XPIDLSRCS contains only XPIDL_MODULE
+ ifneq ($(XPIDL_MODULE).idl,$(strip $(XPIDLSRCS)))
+--- js/src/config/rules.mk.orig Fri May 11 08:42:57 2012
++++ js/src/config/rules.mk Fri May 11 08:43:15 2012
+@@ -1479,7 +1479,7 @@ $(XPIDL_GEN_DIR)/%.h: %.idl $(XPIDL_DEPS) $(XPIDL_GEN_
+ $(PYTHON_PATH) \
+ -I$(topsrcdir)/other-licenses/ply \
+ -I$(topsrcdir)/xpcom/idl-parser \
+- $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=$(DEPTH)/xpcom/idl-parser $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
++ $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=$(DEPTH)/xpcom/idl-parser/cache $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
+ @if test -n "$(findstring $*.h, $(EXPORTS))"; \
+ then echo "*** WARNING: file $*.h generated from $*.idl overrides $(srcdir)/$*.h"; else true; fi
+
+@@ -1492,7 +1492,7 @@ $(XPIDL_GEN_DIR)/%.xpt: %.idl $(XPIDL_DEPS) $(XPIDL_GE
+ -I$(topsrcdir)/other-licenses/ply \
+ -I$(topsrcdir)/xpcom/idl-parser \
+ -I$(topsrcdir)/xpcom/typelib/xpt/tools \
+- $(topsrcdir)/xpcom/idl-parser/typelib.py --cachedir=$(DEPTH)/xpcom/idl-parser $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
++ $(topsrcdir)/xpcom/idl-parser/typelib.py --cachedir=$(DEPTH)/xpcom/idl-parser/cache $(XPIDL_FLAGS) $(_VPATH_SRCS) -d $(MDDEPDIR)/$(@F).pp -o $@
+
+ # no need to link together if XPIDLSRCS contains only XPIDL_MODULE
+ ifneq ($(XPIDL_MODULE).idl,$(strip $(XPIDLSRCS)))
+--- js/xpconnect/src/Makefile.in.orig Fri May 11 08:43:27 2012
++++ js/xpconnect/src/Makefile.in Fri May 11 08:44:03 2012
+@@ -151,7 +151,7 @@ dom_quickstubs.cpp: $(srcdir)/dom_quickstubs.qsconf \
+ -I$(topsrcdir)/xpcom/idl-parser \
+ $(srcdir)/qsgen.py \
+ --idlpath=$(DEPTH)/dist/idl \
+- --cachedir=$(DEPTH)/xpcom/idl-parser \
++ --cachedir=$(DEPTH)/xpcom/idl-parser/cache \
+ --header-output dom_quickstubs.h \
+ --stub-output dom_quickstubs.cpp \
+ --makedepend-output $(MDDEPDIR)/dom_qsgen.pp \
+@@ -172,7 +172,7 @@ dombindings_gen.h: $(srcdir)/dombindings.conf \
+ -I$(topsrcdir)/xpcom/idl-parser \
+ $(srcdir)/dombindingsgen.py \
+ --idlpath=$(DEPTH)/dist/idl \
+- --cachedir=$(DEPTH)/xpcom/idl-parser \
++ --cachedir=$(DEPTH)/xpcom/idl-parser/cache \
+ --header-output dombindings_gen.h \
+ $(srcdir)/dombindings.conf
+
+@@ -189,7 +189,7 @@ dombindings_gen.cpp: $(srcdir)/dombindings.conf \
+ -I$(topsrcdir)/xpcom/idl-parser \
+ $(srcdir)/dombindingsgen.py \
+ --idlpath=$(DEPTH)/dist/idl \
+- --cachedir=$(DEPTH)/xpcom/idl-parser \
++ --cachedir=$(DEPTH)/xpcom/idl-parser/cache \
+ --stub-output dombindings_gen.cpp \
+ --makedepend-output $(MDDEPDIR)/dombindingsgen.pp \
+ $(srcdir)/dombindings.conf
+@@ -208,7 +208,7 @@ DictionaryHelpers.h: $(srcdir)/dictionary_helper_gen.c
+ -I$(topsrcdir)/xpcom/idl-parser \
+ $(srcdir)/dictionary_helper_gen.py \
+ -I $(DEPTH)/dist/idl \
+- --cachedir=$(DEPTH)/xpcom/idl-parser \
++ --cachedir=$(DEPTH)/xpcom/idl-parser/cache \
+ --header-output DictionaryHelpers.h \
+ $(srcdir)/dictionary_helper_gen.conf
+
+@@ -223,7 +223,7 @@ DictionaryHelpers.cpp: $(srcdir)/dictionary_helper_gen
+ -I$(topsrcdir)/xpcom/idl-parser \
+ $(srcdir)/dictionary_helper_gen.py \
+ -I $(DEPTH)/dist/idl \
+- --cachedir=$(DEPTH)/xpcom/idl-parser \
++ --cachedir=$(DEPTH)/xpcom/idl-parser/cache \
+ --header-output DictionaryHelpers.h \
+ --stub-output DictionaryHelpers.cpp \
+ --makedepend-output $(MDDEPDIR)/dictionary_helper_gen.pp \
+--- xpcom/idl-parser/Makefile.in.orig Fri May 11 08:44:10 2012
++++ xpcom/idl-parser/Makefile.in Fri May 11 08:44:29 2012
+@@ -61,7 +61,7 @@ export:: $(PARSER_SRCS) $(PLY_PROGS)
+ $(PYTHON_PATH) \
+ -I$(topsrcdir)/other-licenses/ply \
+ -I$(topsrcdir)/xpcom/idl-parser \
+- $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=. --regen
++ $(topsrcdir)/xpcom/idl-parser/header.py --cachedir=$(DEPTH)/xpcom/idl-parser/cache --regen
+
+ check::
+ $(PYTHON_PATH) \
+--- xpcom/typelib/xpidl/Makefile.in.orig Fri May 11 08:44:51 2012
++++ xpcom/typelib/xpidl/Makefile.in Fri May 11 08:45:09 2012
+@@ -48,8 +48,8 @@ SDK_BINARY = \
+ $(topsrcdir)/xpcom/idl-parser/xpidl.py \
+ $(topsrcdir)/xpcom/idl-parser/header.py \
+ $(topsrcdir)/xpcom/idl-parser/typelib.py \
+- $(DEPTH)/xpcom/idl-parser/xpidllex.py \
+- $(DEPTH)/xpcom/idl-parser/xpidlyacc.py \
++ $(DEPTH)/xpcom/idl-parser/cache/xpidllex.py \
++ $(DEPTH)/xpcom/idl-parser/cache/xpidlyacc.py \
+ $(NULL)
+
+ ifndef MOZ_SYSTEM_PLY
diff --git a/www/firefox/files/patch-configure.in b/www/firefox/files/patch-configure.in
index 103defe63c68..74abe4451b47 100644
--- a/www/firefox/files/patch-configure.in
+++ b/www/firefox/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig 2010-11-04 21:05:18.000000000 +0100
-+++ configure.in 2010-11-09 12:59:28.000000000 +0100
-@@ -1549,7 +1549,7 @@
+--- configure.in.orig 2012-05-23 20:56:34.000000000 +0200
++++ configure.in 2012-05-27 18:18:25.000000000 +0200
+@@ -1517,7 +1517,7 @@
CPU_ARCH=sparc
;;
@@ -9,7 +9,7 @@
CPU_ARCH="$OS_TEST"
;;
-@@ -1567,7 +1567,7 @@ dnl Set INTEL_ARCHITECTURE if we're comp
+@@ -1539,7 +1539,7 @@
dnl ===============================================================
INTEL_ARCHITECTURE=
case "$OS_TEST" in
@@ -18,34 +18,7 @@
INTEL_ARCHITECTURE=1
esac
-@@ -3803,19 +3803,21 @@
- AC_CHECK_FUNCS(localtime_r strtok_r)
-
- dnl check for clock_gettime(), the CLOCK_MONOTONIC clock, and -lrt
--_SAVE_LDFLAGS=$LDFLAGS
--LDFLAGS="$LDFLAGS -lrt"
--AC_CACHE_CHECK(for clock_gettime(CLOCK_MONOTONIC) and -lrt,
-+_SAVE_LIBS=$LIBS
-+AC_SEARCH_LIBS(clock_gettime, rt)
-+AC_CACHE_CHECK(for clock_gettime(CLOCK_MONOTONIC),
- ac_cv_have_clock_monotonic,
- [AC_TRY_LINK([#include <time.h>],
- [ struct timespec ts;
- clock_gettime(CLOCK_MONOTONIC, &ts); ],
- ac_cv_have_clock_monotonic=yes,
- ac_cv_have_clock_monotonic=no)])
--LDFLAGS=$_SAVE_LDFLAGS
-+LIBS=$_SAVE_LIBS
- if test "$ac_cv_have_clock_monotonic" = "yes"; then
- HAVE_CLOCK_MONOTONIC=1
-- REALTIME_LIBS=-lrt
-+ if test "$ac_cv_search_clock_gettime" != "none required"; then
-+ REALTIME_LIBS=$ac_cv_search_clock_gettime
-+ fi
- AC_DEFINE(HAVE_CLOCK_MONOTONIC)
- AC_SUBST(HAVE_CLOCK_MONOTONIC)
- AC_SUBST(REALTIME_LIBS)
-@@ -4808,7 +4810,7 @@ CFLAGS=$_SAVE_CFLAGS
+@@ -4580,7 +4580,7 @@
LDFLAGS=$_SAVE_LDFLAGS
LIBS=$_SAVE_LIBS
@@ -54,7 +27,7 @@
ZLIB_CFLAGS="-I${ZLIB_DIR}/include"
ZLIB_LIBS="-L${ZLIB_DIR}/lib ${ZLIB_LIBS}"
fi
-@@ -6022,6 +6024,14 @@
+@@ -5903,6 +5903,14 @@
VPX_ASFLAGS="-f elf64 -rnasm -pnasm -DPIC"
VPX_X86_ASM=1
;;
@@ -69,7 +42,7 @@
SunOS:x86)
VPX_ASFLAGS="-f elf32 -rnasm -pnasm"
VPX_X86_ASM=1
-@@ -6392,6 +6402,14 @@ if test -n "$MOZ_LIBJPEG_TURBO"; then
+@@ -6297,6 +6305,14 @@
LIBJPEG_TURBO_ASFLAGS="-f elf64 -rnasm -pnasm -D__x86_64__ -DPIC -DELF"
LIBJPEG_TURBO_X64_ASM=1
;;
diff --git a/www/firefox/files/patch-gfx-ycbcr-Makefile.in b/www/firefox/files/patch-gfx-ycbcr-Makefile.in
new file mode 100644
index 000000000000..bf6c28297222
--- /dev/null
+++ b/www/firefox/files/patch-gfx-ycbcr-Makefile.in
@@ -0,0 +1,21 @@
+--- gfx/ycbcr/Makefile.in~
++++ gfx/ycbcr/Makefile.in
+@@ -58,6 +58,10 @@ ifeq ($(OS_ARCH),Linux)
+ CPPSRCS += yuv_row_posix.cpp \
+ $(NULL)
+ else
++ifeq ($(OS_ARCH),FreeBSD)
++CPPSRCS += yuv_row_posix.cpp \
++ $(NULL)
++else
+ ifeq ($(OS_ARCH),SunOS)
+ CPPSRCS += yuv_row_posix.cpp \
+ $(NULL)
+@@ -70,6 +74,7 @@ CPPSRCS += yuv_row_other.cpp \
+ $(NULL)
+ endif # Darwin
+ endif # SunOS
++endif # FreeBSD
+ endif # linux
+ endif # windows
+ \ No newline at end of file
diff --git a/www/firefox/files/patch-xpcom_base_nsStackWalk.cpp b/www/firefox/files/patch-xpcom_base_nsStackWalk.cpp
index d9956b6852c3..a6b41d4fbc54 100644
--- a/www/firefox/files/patch-xpcom_base_nsStackWalk.cpp
+++ b/www/firefox/files/patch-xpcom_base_nsStackWalk.cpp
@@ -1,8 +1,8 @@
---- xpcom/base/nsStackWalk.cpp.orig 2010-12-15 02:03:41.000000000 +0100
-+++ xpcom/base/nsStackWalk.cpp 2010-12-15 11:28:20.000000000 +0100
-@@ -1137,7 +1137,7 @@
- #define __USE_GNU
- #endif
+--- xpcom/base/nsStackWalk.cpp.orig 2012-05-29 00:57:31.000000000 +0200
++++ xpcom/base/nsStackWalk.cpp 2012-06-03 12:33:40.000000000 +0200
+@@ -57,7 +57,7 @@
+ };
+ static CriticalAddress gCriticalAddress;
-#if defined(HAVE_DLOPEN) || defined(XP_MACOSX)
+#if defined(HAVE_DLOPEN) || defined(XP_MACOSX) || defined(__FreeBSD__)
diff --git a/www/firefox/pkg-descr b/www/firefox/pkg-descr
index c9f27891b898..faddf782e71f 100644
--- a/www/firefox/pkg-descr
+++ b/www/firefox/pkg-descr
@@ -1,5 +1,5 @@
Mozilla Firefox is a free and open source web browser descended from the
-Mozilla Application Suite. It is small, fast and easy to use, and offers
+Mozilla Application Suite. It is small, fast and easy to use, and offers
many advanced features:
o Popup Blocking