aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/openal-soft/files/patch-CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/audio/openal-soft/files/patch-CMakeLists.txt b/audio/openal-soft/files/patch-CMakeLists.txt
index 251733ff3fc3..8cc81c0419d4 100644
--- a/audio/openal-soft/files/patch-CMakeLists.txt
+++ b/audio/openal-soft/files/patch-CMakeLists.txt
@@ -1,5 +1,16 @@
--- CMakeLists.txt.orig 2010-01-20 08:40:38.000000000 +0100
+++ CMakeLists.txt 2010-01-20 08:40:50.000000000 +0100
+@@ -259,10 +259,6 @@ IF(NOT HAVE_WINDOWS_H)
+
+ CHECK_LIBRARY_EXISTS(pthread pthread_setschedparam "" HAVE_PTHREAD_SETSCHEDPARAM)
+
+- CHECK_LIBRARY_EXISTS(rt clock_gettime "" HAVE_LIBRT)
+- IF(HAVE_LIBRT)
+- SET(EXTRA_LIBS rt ${EXTRA_LIBS})
+- ENDIF()
+ ENDIF()
+
+ # Check for a 64-bit type
@@ -463,7 +463,7 @@
DESTINATION include/AL
)