aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-p2p/mktorrent/Makefile1
-rw-r--r--net-p2p/mktorrent/files/patch-init.c15
2 files changed, 16 insertions, 0 deletions
diff --git a/net-p2p/mktorrent/Makefile b/net-p2p/mktorrent/Makefile
index 49b70c37cf56..901baa96950e 100644
--- a/net-p2p/mktorrent/Makefile
+++ b/net-p2p/mktorrent/Makefile
@@ -4,6 +4,7 @@
PORTNAME= mktorrent
PORTVERSION= 1.1
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= net-p2p
MAINTAINER= ports@FreeBSD.org
diff --git a/net-p2p/mktorrent/files/patch-init.c b/net-p2p/mktorrent/files/patch-init.c
new file mode 100644
index 000000000000..d54ad940705f
--- /dev/null
+++ b/net-p2p/mktorrent/files/patch-init.c
@@ -0,0 +1,15 @@
+--- init.c.orig 2017-09-07 14:49:58 UTC
++++ init.c
+@@ -512,10 +512,10 @@ EXPORT void init(metafile_t *m, int argc
+
+ /* set the correct piece length.
+ default is 2^18 = 256kb. */
+- if (m->piece_length < 15 || m->piece_length > 28) {
++ if (m->piece_length < 15 || m->piece_length > 30) {
+ fprintf(stderr,
+ "The piece length must be a number between "
+- "15 and 28.\n");
++ "15 and 30.\n");
+ exit(EXIT_FAILURE);
+ }
+ m->piece_length = 1 << m->piece_length;