aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/unstow/Makefile35
-rw-r--r--sysutils/unstow/distinfo3
-rw-r--r--sysutils/unstow/pkg-descr7
4 files changed, 46 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index f8e6cd1b4fcd..866dbbbb7398 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -818,6 +818,7 @@
SUBDIR += unieject
SUBDIR += uniutils
SUBDIR += unquote
+ SUBDIR += unstow
SUBDIR += upsd
SUBDIR += upsdaemon
SUBDIR += upsmon
diff --git a/sysutils/unstow/Makefile b/sysutils/unstow/Makefile
new file mode 100644
index 000000000000..271080aa637b
--- /dev/null
+++ b/sysutils/unstow/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: unstow
+# Date created: 3 January 2010
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unstow
+PORTVERSION= 0.1.1
+CATEGORIES= sysutils
+MASTER_SITES= http://download.github.com/ \
+ ftp://ftp.iDaemons.org/pub/distfiles/
+DISTNAME= knu-stow-utils-885c88a
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A script to unstow packages much faster than stow -D
+
+NO_BUILD= yes
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+PORTDOCS= README.md
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin/
+.for man in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/man/${man} ${MANPREFIX}/man/man1/
+.endfor
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/unstow/distinfo b/sysutils/unstow/distinfo
new file mode 100644
index 000000000000..527459f03f10
--- /dev/null
+++ b/sysutils/unstow/distinfo
@@ -0,0 +1,3 @@
+MD5 (knu-stow-utils-885c88a.tar.gz) = b44e1163167297d27869be4fd4e82719
+SHA256 (knu-stow-utils-885c88a.tar.gz) = c67fde243736888c466f52a3a73f605bdbdce4feab3cb25f894c2f4b0a44c4ab
+SIZE (knu-stow-utils-885c88a.tar.gz) = 2278
diff --git a/sysutils/unstow/pkg-descr b/sysutils/unstow/pkg-descr
new file mode 100644
index 000000000000..b5efbe5429bb
--- /dev/null
+++ b/sysutils/unstow/pkg-descr
@@ -0,0 +1,7 @@
+unstow
+------
+
+This is a script to unstow packages much faster than stow -D.
+
+Author: Akinori MUSHA <knu@iDaemons.org>
+WWW: http://github.com/knu/stow-utils