aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/mysql++/Makefile5
-rw-r--r--databases/mysql++1/Makefile5
-rw-r--r--databases/mysql-administrator/Makefile4
-rw-r--r--devel/monotone/Makefile4
-rw-r--r--lang/mozart/Makefile4
-rw-r--r--net-p2p/mute-net/Makefile4
-rw-r--r--net/mute-net/Makefile4
-rw-r--r--sysutils/monitord/Makefile8
8 files changed, 37 insertions, 1 deletions
diff --git a/databases/mysql++/Makefile b/databases/mysql++/Makefile
index 6783f22da6b4..15adf54899b9 100644
--- a/databases/mysql++/Makefile
+++ b/databases/mysql++/Makefile
@@ -27,6 +27,11 @@ CONFIGURE_ARGS= --with-mysql=${LOCALBASE} \
INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${OSVERSION} >= 500035
PATCHFILES= patch_gcc_3.3.gz
PATCH_SITES= ${MASTER_SITES}
diff --git a/databases/mysql++1/Makefile b/databases/mysql++1/Makefile
index 6783f22da6b4..15adf54899b9 100644
--- a/databases/mysql++1/Makefile
+++ b/databases/mysql++1/Makefile
@@ -27,6 +27,11 @@ CONFIGURE_ARGS= --with-mysql=${LOCALBASE} \
INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${OSVERSION} >= 500035
PATCHFILES= patch_gcc_3.3.gz
PATCH_SITES= ${MASTER_SITES}
diff --git a/databases/mysql-administrator/Makefile b/databases/mysql-administrator/Makefile
index f417701c27a8..ecae725e2161 100644
--- a/databases/mysql-administrator/Makefile
+++ b/databases/mysql-administrator/Makefile
@@ -44,6 +44,10 @@ DIRS_ORDER= mysql-gui-common mysql-administrator
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s#%%PTHREAD_CFLAGS%%#${PTHREAD_CFLAGS}#" \
${WRKSRC}/mysql-administrator/source/linux/Makefile.am
diff --git a/devel/monotone/Makefile b/devel/monotone/Makefile
index bcac8b00b2ec..5ee42e4443a7 100644
--- a/devel/monotone/Makefile
+++ b/devel/monotone/Makefile
@@ -54,6 +54,10 @@ CONFIGURE_ARGS= --with-bundled-sqlite
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${OSVERSION} < 500000
BROKEN= "Does not run on FreeBSD-4.x at this time"
.endif
diff --git a/lang/mozart/Makefile b/lang/mozart/Makefile
index ed6e72178e9a..a280acb66a9c 100644
--- a/lang/mozart/Makefile
+++ b/lang/mozart/Makefile
@@ -45,6 +45,10 @@ CONFIGURE_ARGS= --prefix=${PREFIX}/lib/oz --disable-doc \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${ARCH} != "i386"
BROKEN= "Does not compile on !i386"
.endif
diff --git a/net-p2p/mute-net/Makefile b/net-p2p/mute-net/Makefile
index 661f04708df9..0a20d7f41387 100644
--- a/net-p2p/mute-net/Makefile
+++ b/net-p2p/mute-net/Makefile
@@ -138,6 +138,10 @@ post-install:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
# we cannot install if either a slave or master port is already
# installed
CONFLICTS+= mute-net-[0-9]*
diff --git a/net/mute-net/Makefile b/net/mute-net/Makefile
index 661f04708df9..0a20d7f41387 100644
--- a/net/mute-net/Makefile
+++ b/net/mute-net/Makefile
@@ -138,6 +138,10 @@ post-install:
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
# we cannot install if either a slave or master port is already
# installed
CONFLICTS+= mute-net-[0-9]*
diff --git a/sysutils/monitord/Makefile b/sysutils/monitord/Makefile
index 05399cf9b24d..2fa594a3508f 100644
--- a/sysutils/monitord/Makefile
+++ b/sysutils/monitord/Makefile
@@ -15,7 +15,13 @@ COMMENT= Service that restarts other standalone services
MAN8= monitord.8
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-install:
@${CP} ${WRKSRC}/monitord.conf.sample ${PREFIX}/etc/monitord.conf.sample
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>