aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/flphoto/Makefile4
-rw-r--r--graphics/flphoto/files/patch-Fl_Print_Dialog2.cxx10
-rw-r--r--graphics/flphoto/files/patch-espmsg.c11
-rw-r--r--graphics/flphoto/files/patch-http-md5.cxx11
4 files changed, 34 insertions, 2 deletions
diff --git a/graphics/flphoto/Makefile b/graphics/flphoto/Makefile
index cff13cb3ba67..f8a562c284d7 100644
--- a/graphics/flphoto/Makefile
+++ b/graphics/flphoto/Makefile
@@ -15,8 +15,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-source
MAINTAINER= ports@FreeBSD.org
COMMENT= A basic image management and display program
-LIB_DEPENDS= gphoto2.2:${PORTSDIR}/graphics/libgphoto2 \
- fltk.1:${PORTSDIR}/x11-toolkits/fltk \
+LIB_DEPENDS= gphoto2:${PORTSDIR}/graphics/libgphoto2 \
+ fltk:${PORTSDIR}/x11-toolkits/fltk \
png15:${PORTSDIR}/graphics/png
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/graphics/flphoto/files/patch-Fl_Print_Dialog2.cxx b/graphics/flphoto/files/patch-Fl_Print_Dialog2.cxx
new file mode 100644
index 000000000000..39d70a733107
--- /dev/null
+++ b/graphics/flphoto/files/patch-Fl_Print_Dialog2.cxx
@@ -0,0 +1,10 @@
+--- ./Fl_Print_Dialog2.cxx.orig 2006-11-26 22:45:08.000000000 +0100
++++ ./Fl_Print_Dialog2.cxx 2012-12-22 12:41:39.000000000 +0100
+@@ -56,6 +56,7 @@
+
+ #ifdef HAVE_LIBCUPS
+ # include <cups/cups.h>
++# include <cups/ppd.h>
+ #endif // HAVE_LIBCUPS
+
+
diff --git a/graphics/flphoto/files/patch-espmsg.c b/graphics/flphoto/files/patch-espmsg.c
new file mode 100644
index 000000000000..6c3d8a1af172
--- /dev/null
+++ b/graphics/flphoto/files/patch-espmsg.c
@@ -0,0 +1,11 @@
+--- ./espmsg.c.orig 2005-01-23 04:52:44.000000000 +0100
++++ ./espmsg.c 2012-12-22 12:41:39.000000000 +0100
+@@ -766,7 +766,7 @@
+ *bufptr++ = '&';
+ *bufptr = '\0';
+
+- sprintf(length, "%d", bufptr - buffer);
++ sprintf(length, "%ld", (long)(bufptr - buffer));
+
+ /*
+ * Send the request...
diff --git a/graphics/flphoto/files/patch-http-md5.cxx b/graphics/flphoto/files/patch-http-md5.cxx
new file mode 100644
index 000000000000..c11fc62e6f1b
--- /dev/null
+++ b/graphics/flphoto/files/patch-http-md5.cxx
@@ -0,0 +1,11 @@
+--- ./http-md5.cxx.orig 2012-12-22 12:42:25.000000000 +0100
++++ ./http-md5.cxx 2012-12-22 12:42:28.000000000 +0100
+@@ -120,7 +120,7 @@
+ {
+ int i; /* Looping var */
+ char *md5ptr; /* Pointer into MD5 string */
+- static char *hex = "0123456789abcdef"; /* Hex digits */
++ static char const *hex = "0123456789abcdef"; /* Hex digits */
+
+
+ /*