aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/ftpsync/Makefile32
-rw-r--r--ftp/ftpsync/distinfo3
-rw-r--r--ftp/ftpsync/pkg-descr7
4 files changed, 43 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index bbad45cafbfa..62dd7d42e225 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -31,6 +31,7 @@
SUBDIR += ftpproxy
SUBDIR += ftpq
SUBDIR += ftpsesame
+ SUBDIR += ftpsync
SUBDIR += ftptool
SUBDIR += gftp
SUBDIR += gnusget
diff --git a/ftp/ftpsync/Makefile b/ftp/ftpsync/Makefile
new file mode 100644
index 000000000000..c95ac884c5a7
--- /dev/null
+++ b/ftp/ftpsync/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: ftpsync
+# Date created: 31 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ftpsync
+PORTVERSION= 1.2.32
+CATEGORIES= ftp
+MASTER_SITES= SF
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Synchronizes a local and a remote FTP directory trees
+
+RUN_DEPENDS= p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww
+
+NO_BUILD= yes
+USE_BZIP2= yes
+USE_PERL5= yes
+PLIST_FILES= bin/${PORTNAME}.pl
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/
+
+.include <bsd.port.post.mk>
diff --git a/ftp/ftpsync/distinfo b/ftp/ftpsync/distinfo
new file mode 100644
index 000000000000..191c443111af
--- /dev/null
+++ b/ftp/ftpsync/distinfo
@@ -0,0 +1,3 @@
+MD5 (ftpsync-1.2.32.tar.bz2) = a58e2f7e66f93070f24e269ac026264e
+SHA256 (ftpsync-1.2.32.tar.bz2) = bdbd8af4efbf491db8fbcf93c2552eec243f73593400358014ac6506eb7101cc
+SIZE (ftpsync-1.2.32.tar.bz2) = 15776
diff --git a/ftp/ftpsync/pkg-descr b/ftp/ftpsync/pkg-descr
new file mode 100644
index 000000000000..99408254355e
--- /dev/null
+++ b/ftp/ftpsync/pkg-descr
@@ -0,0 +1,7 @@
+ftpsync.pl synchronizes a local directory tree and a remote FTP directory
+tree. It was initally written to automize web publishing, but might be
+useful for some other purposes, like mirroring not-too-large public sites,
+data replication, and more.
+
+WWW: http://ftpsync.sourceforge.net/
+Author: Christoph Lechleitner <ibcl@users.sourceforge.net>