aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-doit/Makefile26
-rw-r--r--devel/py-doit/distinfo2
-rw-r--r--devel/py-doit/pkg-descr11
-rw-r--r--devel/py-doit/pkg-plist1
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c824854dcf9a..ae1e67949f43 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3621,6 +3621,7 @@
SUBDIR += py-docopt
SUBDIR += py-dogpile.cache
SUBDIR += py-dogpile.core
+ SUBDIR += py-doit
SUBDIR += py-durus
SUBDIR += py-dynrules
SUBDIR += py-eggtestinfo
diff --git a/devel/py-doit/Makefile b/devel/py-doit/Makefile
new file mode 100644
index 000000000000..e88d7f871062
--- /dev/null
+++ b/devel/py-doit/Makefile
@@ -0,0 +1,26 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= doit
+PORTVERSION= 0.25.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Python Automation Tool
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+
+.include <bsd.port.mk>
diff --git a/devel/py-doit/distinfo b/devel/py-doit/distinfo
new file mode 100644
index 000000000000..fd95589570fd
--- /dev/null
+++ b/devel/py-doit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (doit-0.25.0.tar.gz) = 4584ba69cbb2a8dc27faf020c47c20bec3fb04c7159a959876b7bb8aafe0de54
+SIZE (doit-0.25.0.tar.gz) = 342659
diff --git a/devel/py-doit/pkg-descr b/devel/py-doit/pkg-descr
new file mode 100644
index 000000000000..d0ffc6351d61
--- /dev/null
+++ b/devel/py-doit/pkg-descr
@@ -0,0 +1,11 @@
+doit comes from the idea of bringing the power of build-tools to execute
+any kind of task.
+
+A task describes some computation to be done (actions), and contains some
+extra meta-data. Actions:
+
+ * can be external programs (executed as shell commands) or python
+ functions.
+ * a single task may define more than one action.
+
+WWW: http://pydoit.org
diff --git a/devel/py-doit/pkg-plist b/devel/py-doit/pkg-plist
new file mode 100644
index 000000000000..8fb5cc4556d5
--- /dev/null
+++ b/devel/py-doit/pkg-plist
@@ -0,0 +1 @@
+@comment $FreeBSD$