aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/trafshow/Makefile7
-rw-r--r--net/trafshow/files/extra-patch-800074+23
2 files changed, 29 insertions, 1 deletions
diff --git a/net/trafshow/Makefile b/net/trafshow/Makefile
index 76902e988ffc..8983260a9e01 100644
--- a/net/trafshow/Makefile
+++ b/net/trafshow/Makefile
@@ -21,10 +21,15 @@ ALL_TARGET= trafshow
MAN1= trafshow.1
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|-D_THREAD_SAFE||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|' \
${WRKSRC}/colormask.c ${WRKSRC}/trafshow.1 ${WRKSRC}/trafshow.c
+.if ${OSVERSION} >= 800074
+ @${PATCH} -d ${WRKSRC} < ${FILESDIR}/extra-patch-800074+
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/trafshow ${PREFIX}/bin
@@ -34,4 +39,4 @@ do-install:
${CP} -p ${PREFIX}/etc/trafshow.dist ${PREFIX}/etc/trafshow; \
fi
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/trafshow/files/extra-patch-800074+ b/net/trafshow/files/extra-patch-800074+
new file mode 100644
index 000000000000..be129daf9dbc
--- /dev/null
+++ b/net/trafshow/files/extra-patch-800074+
@@ -0,0 +1,23 @@
+#
+# http://lists.freebsd.org/pipermail/freebsd-ports/2009-March/053823.html
+#
+--- show_dump.c.orig 2009-03-29 23:18:16.000000000 +0400
++++ show_dump.c 2009-03-29 23:18:24.000000000 +0400
+@@ -30,6 +30,7 @@
+ #include <string.h>
+ #include <unistd.h>
+ #include <errno.h>
++#include <net/bpf.h>
+ #include <pcap.h>
+ #include <pthread.h>
+ #include <time.h>
+--- trafshow.c.orig 2009-03-29 23:18:49.000000000 +0400
++++ trafshow.c 2009-03-29 23:18:58.000000000 +0400
+@@ -30,6 +30,7 @@
+ #include <string.h>
+ #include <unistd.h>
+ #include <time.h>
++#include <net/bpf.h>
+ #include <pcap.h>
+ #include <pthread.h>
+ #include <errno.h>