aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/aee/Makefile49
-rw-r--r--editors/aee/files/patch-create.mk.aee2
2 files changed, 22 insertions, 29 deletions
diff --git a/editors/aee/Makefile b/editors/aee/Makefile
index 57a91270129c..ccc6bbcfdd18 100644
--- a/editors/aee/Makefile
+++ b/editors/aee/Makefile
@@ -13,46 +13,39 @@ COMMENT= Easy editor with both curses and X11 interfaces
LICENSE= ART10
USES= ncurses
-
-OPTIONS_DEFINE= XAE
-XAE_DESC= Build X11 version 'xae'
+PLIST_FILES= bin/aee bin/rae man/man1/aee.1.gz %%DATADIR%%/help.ae
+ALL_TARGET= main
MAKE_JOBS_UNSAFE= yes
-PLIST_FILES= bin/aee bin/rae man/man1/aee.1.gz %%DATADIR%%/help.ae
-
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= XAE
-.if ${PORT_OPTIONS:MXAE}
-USE_XORG= x11
-ALL_TARGET= both
-PLIST_FILES+= bin/xae bin/rxae
-DESKTOP_ENTRIES="Xae" "" "" "xae" "" false
-.else
-ALL_TARGET= main
-.endif
+XAE_DESC= Build X11 version 'xae'
+XAE_USE= XORG=x11
+XAE_PLIST_FILES= bin/xae bin/rxae
+XAE_ALL_TARGET= xae
+XAE_DESKTOP_ENTRIES= "Xae" "" "" "xae" "" false
post-patch:
-.for i in create.mk.aee create.mk.xae
@${REINPLACE_CMD} -e \
's|cc|${CC}|g ; \
s|"-s"|""|g ; \
- s|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/${i}
-.endfor
-.for i in aee.1 localize.c
- @${REINPLACE_CMD} -e \
- 's|/usr/local/lib|${DATADIR}|g' ${WRKSRC}/${i}
-.endfor
+ s|/usr/X11R6|${LOCALBASE}|g' \
+ ${WRKSRC}/create.mk.aee \
+ ${WRKSRC}/create.mk.xae
+ @${REINPLACE_CMD} -e 's|/usr/local/lib|${DATADIR}|g' \
+ ${WRKSRC}/aee.1 \
+ ${WRKSRC}/localize.c
do-install:
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} aee ${STAGEDIR}${PREFIX}/bin)
- (cd ${STAGEDIR}${PREFIX}/bin && ${LN} aee rae)
- (cd ${WRKSRC} && ${INSTALL_MAN} aee.1 ${STAGEDIR}${MANPREFIX}/man/man1)
@${MKDIR} ${STAGEDIR}${DATADIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} help.ae ${STAGEDIR}${DATADIR})
-.if ${PORT_OPTIONS:MXAE}
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} xae ${STAGEDIR}${PREFIX}/bin)
+ ${INSTALL_PROGRAM} ${WRKSRC}/aee ${STAGEDIR}${PREFIX}/bin
+ (cd ${STAGEDIR}${PREFIX}/bin && ${LN} aee rae)
+ ${INSTALL_MAN} ${WRKSRC}/aee.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/help.ae ${STAGEDIR}${DATADIR}
+
+do-install-XAE-on:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xae ${STAGEDIR}${PREFIX}/bin
(cd ${STAGEDIR}${PREFIX}/bin && ${LN} xae rxae)
-.endif
.include <bsd.port.mk>
diff --git a/editors/aee/files/patch-create.mk.aee b/editors/aee/files/patch-create.mk.aee
index 84af734d466e..f7df8cd86d9d 100644
--- a/editors/aee/files/patch-create.mk.aee
+++ b/editors/aee/files/patch-create.mk.aee
@@ -5,7 +5,7 @@
# rather than local curses)
-if [ -n "$terminfo_exists" -a -z "$termcap_exists" ]
-+if true
++if false
then
echo "Neither terminfo or termcap are on this system! "
if [ -f /usr/include/curses.h ]