aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/etoile-panekit/Makefile33
-rw-r--r--deskutils/etoile-panekit/distinfo3
-rw-r--r--deskutils/etoile-panekit/pkg-descr14
-rw-r--r--deskutils/etoile-panekit/pkg-plist14
5 files changed, 65 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 652302e5f8da..09cfabbe6b3c 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -45,6 +45,7 @@
SUBDIR += etoile-hardware
SUBDIR += etoile-lookandbehavior
SUBDIR += etoile-menuserver
+ SUBDIR += etoile-panekit
SUBDIR += etoile-preferenceskit
SUBDIR += etoile-servicesbarkit
SUBDIR += etoile-trackerkit
diff --git a/deskutils/etoile-panekit/Makefile b/deskutils/etoile-panekit/Makefile
new file mode 100644
index 000000000000..0080cb948fbf
--- /dev/null
+++ b/deskutils/etoile-panekit/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: etoile-panekit
+# Date created: 22 Dec 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= panekit
+PORTVERSION= 0.1.${SNAPSHOT}
+CATEGORIES= deskutils
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://people.freebsd.org/~%%SUBDIR%%/distfiles/
+MASTER_SITE_SUBDIR= dinoex
+PKGNAMEPREFIX= etoile-
+DISTNAME= Etoile-${SNAPSHOT}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Framework which provides flexible pane window in GNUstep
+
+USE_BZIP2= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+DEFAULT_LIBVERSION= 0.1
+USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+
+SNAPSHOT= 20061221
+WRKSRC= ${WRKDIR}/Etoile/
+USE_GNUSTEP_MAKE_DIRS+= Frameworks/PaneKit
+
+.include <bsd.port.mk>
diff --git a/deskutils/etoile-panekit/distinfo b/deskutils/etoile-panekit/distinfo
new file mode 100644
index 000000000000..545ac18e8091
--- /dev/null
+++ b/deskutils/etoile-panekit/distinfo
@@ -0,0 +1,3 @@
+MD5 (Etoile-20061221.tar.bz2) = 120ffa8cf06c58ff775f8a218ad91448
+SHA256 (Etoile-20061221.tar.bz2) = 7dc8acbf2cb46d9d119c9817204bbbbe72884065f3287877550c400e68f4c992
+SIZE (Etoile-20061221.tar.bz2) = 9867481
diff --git a/deskutils/etoile-panekit/pkg-descr b/deskutils/etoile-panekit/pkg-descr
new file mode 100644
index 000000000000..8959b8c3ec6e
--- /dev/null
+++ b/deskutils/etoile-panekit/pkg-descr
@@ -0,0 +1,14 @@
+PaneKit is a framework which provides various features to build
+flexible pane window in any GNUstep or Cocoa applications.
+PKPanesController controls the main user interface
+and several presentations are available.
+Panes can be build in bundle of Nib or programmingly.
+They are registered in PKPaneRegistry and displayed by PKPanesController.
+
+PKPreferencesController and PKPreferencesPaneRegistry
+are designed to handle preferences.
+It includes an NSPreferencePane implementation (following Cocoa API).
+
+It is based on GSSystemPreferences code written by Uli Kusterer.
+
+WWW: http://www.etoile-project.org/
diff --git a/deskutils/etoile-panekit/pkg-plist b/deskutils/etoile-panekit/pkg-plist
new file mode 100644
index 000000000000..4662361c2d8f
--- /dev/null
+++ b/deskutils/etoile-panekit/pkg-plist
@@ -0,0 +1,14 @@
+Local/Library/Headers/PaneKit/CocoaCompatibility.h
+Local/Library/Headers/PaneKit/NSPreferencePane.h
+Local/Library/Headers/PaneKit/PKPane.h
+Local/Library/Headers/PaneKit/PKPaneRegistry.h
+Local/Library/Headers/PaneKit/PKPanesController.h
+Local/Library/Headers/PaneKit/PKPreferencePane.h
+Local/Library/Headers/PaneKit/PKPreferencePaneRegistry.h
+Local/Library/Headers/PaneKit/PKPreferencesController.h
+Local/Library/Headers/PaneKit/PKPresentationBuilder.h
+Local/Library/Headers/PaneKit/PaneKit.h
+Local/Library/Libraries/libPaneKit.so
+Local/Library/Libraries/libPaneKit.so.%%MAJORLIBVERSION%%
+Local/Library/Libraries/libPaneKit.so.%%LIBVERSION%%
+@dirrm Local/Library/Headers/PaneKit