aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/openmsx/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/emulators/openmsx/Makefile b/emulators/openmsx/Makefile
index 781cefd99579..9c57ba5def9c 100644
--- a/emulators/openmsx/Makefile
+++ b/emulators/openmsx/Makefile
@@ -47,4 +47,8 @@ post-patch:
USE_GCC= 4.2+
.endif
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64: uses i386-specific asm
+.endif
+
.include <bsd.port.post.mk>