aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ports-mgmt/pkg/Makefile1
-rw-r--r--ports-mgmt/pkg/files/patch-libpkg__pkg_repo.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index b4cd385ebfdf..fd5599f01d6c 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pkg
DISTVERSION= 1.0-beta17
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= LOCAL/portmgr \
http://files.etoilebsd.net/pkg/
diff --git a/ports-mgmt/pkg/files/patch-libpkg__pkg_repo.c b/ports-mgmt/pkg/files/patch-libpkg__pkg_repo.c
new file mode 100644
index 000000000000..5e7d09375b65
--- /dev/null
+++ b/ports-mgmt/pkg/files/patch-libpkg__pkg_repo.c
@@ -0,0 +1,14 @@
+diff --git libpkg/pkg_repo.c libpkg/pkg_repo.c
+index d2ef999..d628850 100644
+--- libpkg/pkg_repo.c
++++ libpkg/pkg_repo.c
+@@ -605,8 +605,7 @@ pkg_create_repo(char *path, bool force, void (progress)(struct pkg *pkg, void *d
+ while ((ent = fts_read(fts)) != NULL) {
+ const char *name, *version, *origin, *comment, *desc;
+ const char *arch, *maintainer, *www, *prefix;
+- int64_t flatsize;
+- lic_t licenselogic;
++ int64_t flatsize, licenselogic;
+
+ /* skip everything that is not a file */
+ if (ent->fts_info != FTS_F)