aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--japanese/uim-anthy/Makefile4
-rw-r--r--japanese/uim-canna/Makefile4
-rw-r--r--japanese/uim-prime/Makefile2
-rw-r--r--textproc/uim-gnome/Makefile2
-rw-r--r--textproc/uim-gtk/Makefile2
-rw-r--r--textproc/uim-m17nlib/Makefile4
-rw-r--r--textproc/uim-qt/Makefile4
7 files changed, 11 insertions, 11 deletions
diff --git a/japanese/uim-anthy/Makefile b/japanese/uim-anthy/Makefile
index e0354edc3e7b..051f4c12f299 100644
--- a/japanese/uim-anthy/Makefile
+++ b/japanese/uim-anthy/Makefile
@@ -12,8 +12,8 @@ COMMENT= Uim plugin using Anthy input method
USE_GNOME= gtk20
-RUN_DEPENDS= uim-module-manager:${PORTSDIR}/textproc/uim
-LIB_DEPENDS= anthy.1:${PORTSDIR}/japanese/anthy
+LIB_DEPENDS= anthy.1:${PORTSDIR}/japanese/anthy \
+ uim.2:${PORTSDIR}/textproc/uim
MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}
diff --git a/japanese/uim-canna/Makefile b/japanese/uim-canna/Makefile
index b7de9c54755c..1b5ea55a452c 100644
--- a/japanese/uim-canna/Makefile
+++ b/japanese/uim-canna/Makefile
@@ -10,8 +10,8 @@ PKGNAMESUFFIX= -canna
COMMENT= Uim plugin using Canna input method
-RUN_DEPENDS= uim-module-manager:${PORTSDIR}/textproc/uim
-LIB_DEPENDS= canna.1:${PORTSDIR}/japanese/Canna
+LIB_DEPENDS= canna.1:${PORTSDIR}/japanese/Canna \
+ uim.2:${PORTSDIR}/textproc/uim
MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}
diff --git a/japanese/uim-prime/Makefile b/japanese/uim-prime/Makefile
index 06923b2e14cf..21a1f0c5cf09 100644
--- a/japanese/uim-prime/Makefile
+++ b/japanese/uim-prime/Makefile
@@ -10,8 +10,8 @@ PKGNAMESUFFIX= -prime
COMMENT= Uim plugin using PRIME input method
-RUN_DEPENDS= uim-module-manager:${PORTSDIR}/textproc/uim
BUILD_DEPENDS= prime:${PORTSDIR}/japanese/prime
+LIB_DEPENDS= uim.2:${PORTSDIR}/textproc/uim
RUN_DEPENDS+= ${BUILD_DEPENDS}
MASTERDIR= ${.CURDIR}/../../textproc/uim
diff --git a/textproc/uim-gnome/Makefile b/textproc/uim-gnome/Makefile
index 1b4f1d2bcc8d..5f936e2693dc 100644
--- a/textproc/uim-gnome/Makefile
+++ b/textproc/uim-gnome/Makefile
@@ -10,7 +10,7 @@ PKGNAMESUFFIX= -gnome
COMMENT= GNOME applets of uim input method
USE_GNOME= gtk20 gnomepanel
-RUN_DEPENDS= uim-module-manager:${PORTSDIR}/textproc/uim
+LIB_DEPENDS= uim.2:${PORTSDIR}/textproc/uim
MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}
diff --git a/textproc/uim-gtk/Makefile b/textproc/uim-gtk/Makefile
index 7f56ed71a86d..98aec34e26cd 100644
--- a/textproc/uim-gtk/Makefile
+++ b/textproc/uim-gtk/Makefile
@@ -10,7 +10,7 @@ PKGNAMESUFFIX= -gtk
COMMENT= GTK+ modules of uim input method
USE_GNOME= gtk20
-RUN_DEPENDS= uim-module-manager:${PORTSDIR}/textproc/uim
+LIB_DEPENDS= uim.2:${PORTSDIR}/textproc/uim
MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}
diff --git a/textproc/uim-m17nlib/Makefile b/textproc/uim-m17nlib/Makefile
index 18a64834c2fb..45a64fe79dee 100644
--- a/textproc/uim-m17nlib/Makefile
+++ b/textproc/uim-m17nlib/Makefile
@@ -9,8 +9,8 @@ PKGNAMESUFFIX= -m17nlib
COMMENT= Uim plugin using m17n library input method
-RUN_DEPENDS= uim-module-manager:${PORTSDIR}/textproc/uim
-LIB_DEPENDS= m17n.1:${PORTSDIR}/devel/m17n-lib
+LIB_DEPENDS= m17n.1:${PORTSDIR}/devel/m17n-lib \
+ uim.2:${PORTSDIR}/textproc/uim
MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}
diff --git a/textproc/uim-qt/Makefile b/textproc/uim-qt/Makefile
index d73050a02576..a7a6d96bf273 100644
--- a/textproc/uim-qt/Makefile
+++ b/textproc/uim-qt/Makefile
@@ -9,8 +9,8 @@ PKGNAMESUFFIX= -qt
COMMENT= QT modules of uim input method
-RUN_DEPENDS= uim-module-manager:${PORTSDIR}/textproc/uim
-LIB_DEPENDS+= qt-mt.3:${PORTSDIR}/x11-toolkits/qt33
+LIB_DEPENDS= qt-mt.3:${PORTSDIR}/x11-toolkits/qt33 \
+ uim.2:${PORTSDIR}/textproc/uim
MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}